Author Topic: after update to VM 3.2 no mails are send  (Read 1553 times)

multiaction

  • Beginner
  • *
  • Posts: 22
after update to VM 3.2 no mails are send
« on: March 28, 2017, 09:34:42 am »
Hi,
I updated to VM 3.2 (Joomla 3.6.5) and now order mails are not sending anymore...
I tested mail configuration (SMTP) and that part sends test mails, so i am thinking its a virtuemart thing....

Anyone an idea? Or has the same?

Regards

Alex

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26208
  • Always on vacation
    • Jenkin Hill Internet
Re: after update to VM 3.2 no mails are send
« Reply #1 on: March 28, 2017, 12:18:26 pm »
Are emails sent when manually updating the order status in VM backened? If so then it may be that your payment plugin is not returning a "confirmed" order status (if it returns pending then the emails will not be sent as that signifies that payment has not been made), or that the settings for "Default Order Status to send email to" in VM Configuration/Emails are incorrect.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8 PHP 7.0.23

Testing VM3.2.5 on J!3.8

multiaction

  • Beginner
  • *
  • Posts: 22
Re: after update to VM 3.2 no mails are send
« Reply #2 on: March 28, 2017, 13:06:22 pm »
Hi thanks for your reply, but it did work before the update...
I setted that mails are sended for every status.

But when order is done it doesnt send mail, also not when order is cancelled.

When i manually set order status and check the 'inform customer' checkbox, then mail is send.

Regards

Alex

AH

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2585
  • VirtueMart Version: 3.2.4
Re: after update to VM 3.2 no mails are send
« Reply #3 on: March 28, 2017, 14:20:36 pm »
please check your configuration to see if the emails - status options are set as you require

Maybe they did change on update?
regards
A

Joomla 3.7.4
php 5.6 + php 7

multiaction

  • Beginner
  • *
  • Posts: 22
Re: after update to VM 3.2 no mails are send
« Reply #4 on: March 28, 2017, 14:24:50 pm »
Yes it is.... for example (the most easy to simulate)... i set email on cancelling order... So i cancel the order, status of order is cancelled by shop, but neither shop as customer gets email.

Regards

Alex

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9327
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: after update to VM 3.2 no mails are send
« Reply #5 on: March 28, 2017, 18:51:03 pm »
the order update change in the BE uses the checkbox.... But the checkbox is preset according to the settings in the vm config. Please check the email debug mode, maybe it is enabled
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

multiaction

  • Beginner
  • *
  • Posts: 22
Re: after update to VM 3.2 no mails are send
« Reply #6 on: March 28, 2017, 22:51:35 pm »
Hi, I dont know what you mean with: the order update change in the BE uses the checkbox.
But debug mode on emails is NOT enabled.

Regards

Alex

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9327
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: after update to VM 3.2 no mails are send
« Reply #7 on: March 29, 2017, 20:01:12 pm »
When you change the order status in the Backend order list, then you may notice that the checkboxes change. But only when you do that PER item. When you use the bulk, then it takes the checkboxes of the bar above the table,...
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

multiaction

  • Beginner
  • *
  • Posts: 22
Re: after update to VM 3.2 no mails are send
« Reply #8 on: March 30, 2017, 11:36:08 am »
Ok, i understand, but my mails doesnt still work

Regards

Alex

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9327
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: after update to VM 3.2 no mails are send
« Reply #9 on: March 30, 2017, 22:31:53 pm »
Do you use some 3rd party software?
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

multiaction

  • Beginner
  • *
  • Posts: 22
Re: after update to VM 3.2 no mails are send
« Reply #10 on: March 31, 2017, 14:58:54 pm »
Yes sure, A VAT checker and a change customergroup changer at VAT-check is ok.
But the mail did it before in the previous version with those plugins.

Paymant plugin still sets order status on paid, but mail is not received anymore

Regards

Alex

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26208
  • Always on vacation
    • Jenkin Hill Internet
Re: after update to VM 3.2 no mails are send
« Reply #11 on: March 31, 2017, 15:03:29 pm »
No other reports of mail stopping. Have you tried using PHP Mail instead of SMTP?
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8 PHP 7.0.23

Testing VM3.2.5 on J!3.8

cat1910

  • Beginner
  • *
  • Posts: 8
Re: after update to VM 3.2 no mails are send
« Reply #12 on: May 03, 2017, 18:14:40 pm »
Same problem for me, no more emails going out of virtuemart since the update to VM3.6.2.
Everything was ok before the update.
Other emails with Joomla, Breezing Forms, Acymailing, etc. are ok.
That's a big problem.
Joomla 3.6.5 // php 5.6

cvrak

  • Jr. Member
  • **
  • Posts: 52
  • A beginner
Re: after update to VM 3.2 no mails are send
« Reply #13 on: May 13, 2017, 11:47:55 am »
I have a similar problem:
After fighting many days trying to fix various problems (another post in the forum), I created a clean installation:
  1. Clean install Joomla 3.7.0
  2. Install latest versions of Gantry template, JCE editor, DJ Slider, BT Login, Sourcerer,
  3. Make multilingual
  4. Clean install VM 3.2.1
  5. Import VM data from old installation (there were about 630 products I didn't want to loose)
  6. Make some template and css adjustments.
  7. install VM winbank getway component

Everything worked ok.
I tested some purchases with demo bank account, everything ok.

But, when I set the actual bank account I didn't get orders emails.
When I checked VM backend, the order was pending. I changed the status to Confirmed, no emails received.
Checking the pdf invoice I've found out the fooolowing errors:

Warning: Illegal string offset 'relative' in
/var/www/vhosts/site name/libraries/cms/html/html.php on line 620
Warning: Illegal string offset 'pathOnly' in
/var/www/vhosts/site name/libraries/cms/html/html.php on line 621
Warning: Illegal string offset 'detectBrowser' in
/var/www/vhosts/site name/libraries/cms/html/html.php on line 622
Warning: Illegal string offset 'detectDebug' in
/var/www/vhosts/site name/libraries/cms/html/html.php on line 623
Warning: Illegal string offset 'relative' in
/var/www/vhosts/site name/libraries/cms/html/html.php on line 626
Warning: Illegal string offset 'detectBrowser' in
/var/www/vhosts/site name/libraries/cms/html/html.php on line 626
Warning: Illegal string offset 'detectDebug' in
/var/www/vhosts/site name/libraries/cms/html/html.php on line 626
Warning: Illegal string offset 'pathOnly' in
/var/www/vhosts/site name/libraries/cms/html/html.php on line 629

How this can be solved?
Thanks

My system configuration is Joomla 3.7.0  VM 3.2.1   PHP 7

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26208
  • Always on vacation
    • Jenkin Hill Internet
Re: after update to VM 3.2 no mails are send
« Reply #14 on: May 13, 2017, 12:46:50 pm »
Those errors come from using outdated template files. See http://forum.virtuemart.net/index.php?topic=137327.msg480890#msg480890  and following messages.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8 PHP 7.0.23

Testing VM3.2.5 on J!3.8