Author Topic: Error in installation 3.2.0  (Read 329 times)

roeroelectric

  • Beginner
  • *
  • Posts: 24
    • Ro&Ro Electric Italian Lighting
  • Skype Name: roero-electric
Error in installation 3.2.0
« on: March 20, 2017, 22:37:16 pm »
Hello to all.
When I install the update to version 3.2.0 appears the following error message
Column length too big for column 'cat_params' (max = 16383); use BLOB or TEXT instead SQL=ALTER TABLE `#__virtuemart_categories` ADD `cat_params` varchar(17000) NOT NULL DEFAULT '' AFTER `hits`
Marcello Role

reggaebkk

  • Beginner
  • *
  • Posts: 16
  • Website Designer in Cambodia
    • Khmer-Dev, Web Design in Cambodia
  • VirtueMart Version: V3
Re: Error in installation 3.2.0
« Reply #1 on: March 21, 2017, 12:56:12 pm »
Hi, I think we're having the same problem, when I update Virtuemart 3.0.18 to 3.2.0, I get error messages as well as notice that say that some updates were not possible.
Strangely I don't find many threads that are related, did I miss something?

PS. sorry I didn't copy the exact error messages here because I've already reinstalled my website from backup, if necessary please ask me for error messages and I'll do the whole process again.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26209
  • Always on vacation
    • Jenkin Hill Internet
Re: Error in installation 3.2.0
« Reply #2 on: March 21, 2017, 12:59:16 pm »
@reggaebkk are you using the suto-updater or installing the components manually using Joomla's extensions manager? (I never use the auto-updater)
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8 PHP 7.0.23

Testing VM3.2.5 on J!3.8

reggaebkk

  • Beginner
  • *
  • Posts: 16
  • Website Designer in Cambodia
    • Khmer-Dev, Web Design in Cambodia
  • VirtueMart Version: V3
Re: Error in installation 3.2.0
« Reply #3 on: March 21, 2017, 13:24:53 pm »
I'm using the Joomla updater.
I just went through again:
The Admin Component updates fine it seems, but when I try to update plugins and modules I get this:
Error
Invalid extension update
Notice
Before updating ensure that the update is compatible with your Joomla! installation.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26209
  • Always on vacation
    • Jenkin Hill Internet
Re: Error in installation 3.2.0
« Reply #4 on: March 21, 2017, 13:32:06 pm »
There is a date mismatch using the Joomla auto-updater. Install the aio component using the Install option rather than the Update option in Joomla's Extensions Manager.  http://forum.virtuemart.net/index.php?topic=123808.0
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8 PHP 7.0.23

Testing VM3.2.5 on J!3.8

reggaebkk

  • Beginner
  • *
  • Posts: 16
  • Website Designer in Cambodia
    • Khmer-Dev, Web Design in Cambodia
  • VirtueMart Version: V3
Re: Error in installation 3.2.0
« Reply #5 on: March 21, 2017, 13:51:01 pm »
Worked fantastic, thanks a lot.

roeroelectric

  • Beginner
  • *
  • Posts: 24
    • Ro&Ro Electric Italian Lighting
  • Skype Name: roero-electric
Re: Error in installation 3.2.0
« Reply #6 on: March 21, 2017, 14:09:20 pm »
I have the same error also in manual update of the virtuemart component, not with AIO
Marcello Role