Author Topic: CACHE PROBLEM WITH VM PLUGIN  (Read 145 times)

wonderchris

  • Beginner
  • *
  • Posts: 1
  • Skype Name: wonderchris
CACHE PROBLEM WITH VM PLUGIN
« on: March 20, 2017, 09:12:57 am »
Hi,

I'm using Vm 3.0.12 and joomla 3.6.4 for a french webshop.
In Vm I'm using the plugin Expeditorinet developped by Alatak.
This plugin is ment to export orders infos in text format to create labels for shipping.
My problem is that when I do my first export (with the 2 last orders for example) the plugin export correctly the 2 adresses.
But when I want to do a second export with different orders, the export is the same that for my first export: same names and addresses.
Apparently a cache problem.
The only way I found to make another export with new infos is to disconnect from my account, refresh the navigator cache (chrome, but it's the same with other navigator), connect again, and it works for one export, and only one.
So I have to disconnect>refresh>connect... for each order I want to export.
I try everything I could that have something to do with cache in joomla. Even put all cache off.
Nothing change.

If anyone have any idea where the problem could come from ? I very out of idea on this problem that poison my life every day.
Many thanks in advance for helping.

Chris

alatak

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2013
    • alatak.net
Re: CACHE PROBLEM WITH VM PLUGIN
« Reply #1 on: March 20, 2017, 09:18:28 am »
Hello
 
In your case , the plugin was working, and stopped to work one day.
This plugin is used by a lot of people, and nobody reported me this issue.

What changed in between ?
What is your actual VM version ?

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 25909
  • Always on vacation
    • Jenkin Hill Internet
Re: CACHE PROBLEM WITH VM PLUGIN
« Reply #2 on: March 20, 2017, 12:24:38 pm »
I'm using Vm 3.0.12 and joomla 3.6.4 for a french webshop.

Did you miss the vital security release?
https://www.joomla.org/announcements/release-news/5693-joomla-3-6-5-released.html
http://forum.virtuemart.net/index.php?topic=118683.0

Check that the site has not been hacked - one indication is new users with admin permissions! 

VM3.0.12 is old now.....
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.3.9579 on Joomla 3.7.3 PHP 7.0.19

Testing VMVM3.2.3.9587 on J!3.7.3