Author Topic: SAML authentication  (Read 134 times)

kalvin

  • Beginner
  • *
  • Posts: 2
  • A beginner
SAML authentication
« on: March 09, 2017, 16:39:46 pm »
I did some searching on this topic but I didn't come up with anything? We are looking for a cart that is compatible with SAML authentication. This is the ONLY method of authentication we can use. Would anyone know if this cart would be compatible? Thank you!

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 25548
  • Always on vacation
    • Jenkin Hill Internet
Re: SAML authentication
« Reply #1 on: March 09, 2017, 16:47:02 pm »
I think the key to this is SAML authentication for Joomla on which VirtueMart sits.  There are extensions to do that - eg https://extensions.joomla.org/extension/saml-2-0-idp-for-joomla/
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.0 on Joomla 3.6.5 PHP 7.0.12

Testing VM3.2.1 on J!3.6.5 and J!3.7B3

kalvin

  • Beginner
  • *
  • Posts: 2
  • A beginner
Re: SAML authentication
« Reply #2 on: March 13, 2017, 19:24:30 pm »
Thanks for the reply Kelvyn!

I had happened upon that extension as well but wasn't sure if it would do the trick? I did contact that extension author to find out more details. We are trying to gauge the direction of this project and our solution sits firmly with SAML compatibility - do you know of any sites / current implementations such as this? Thank you for the reply!

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 25548
  • Always on vacation
    • Jenkin Hill Internet
Re: SAML authentication
« Reply #3 on: March 13, 2017, 23:29:01 pm »
No I did have one hotel intranet client looking at this, but they dropped the idea. I think it was too complex for their IT guy.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.0 on Joomla 3.6.5 PHP 7.0.12

Testing VM3.2.1 on J!3.6.5 and J!3.7B3