Author Topic: Multilanguage in product_desc not working  (Read 756 times)

grease082

  • Beginner
  • *
  • Posts: 14
Multilanguage in product_desc not working
« on: January 17, 2017, 13:44:27 pm »
Hi,

I had issues with 3.0.18 and Multilanguage of product_desc. So I updated to 3.0.18.9a but still having the same issue.
I'm using three different languages and when I want to translate from my default language (german) to english the product name and product short description gets translated and loaded from the database table: virtuemart_products_en_gb
But the long Product description isn't loaded and still remains german.

When I'm in the english language view I can change the product description and it get's saved to the right database virtuemart_products_en_gb column product_desc but after saving again the german product_desc is loaded and not the english one.
So if I would click save again the english translation would be overwritten with the german description again.

How can I solve this issue?

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9327
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Multilanguage in product_desc not working
« Reply #1 on: January 17, 2017, 15:03:28 pm »
I just tested it and it works for me. But my editor added a paragraph tag p to the z. So I got
z
test
instead of ztest. But I think that is a problem with the editor. These problems changes by the used editor.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

grease082

  • Beginner
  • *
  • Posts: 14
Re: Multilanguage in product_desc not working
« Reply #2 on: January 17, 2017, 15:34:02 pm »
I tried it with jck editor and the new ark editor. But both Editor have the same issue.

If I disable the editor, it works.
How can I solve this issue?
I want to use an editor for the product description.

lindapowers

  • Full Member
  • ***
  • Posts: 1335
  • If you're going through hell, keep going.
    • Venta de naranjas online y mandarinas
  • Skype Name: manu.gonzalez91
  • VirtueMart Version: Latest avi
Re: Multilanguage in product_desc not working
« Reply #3 on: January 17, 2017, 18:05:53 pm »
Have you tried with TinyMCE?

I had issues with other editors like JCE and so but with the default one for now seems to work.
 I just installed com_virtuemart.3.0.18.9_9423 and tested and it worked also in this version.

Someone mentioned that with JCE Editor version 2.5.31 should work too, the newer versions of JCE cause issues.

https://www.joomlacontenteditor.net/downloads/editor/legacy
http://www.comenaranjas.com - Navel oranges and clementines from Spain

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9327
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Multilanguage in product_desc not working
« Reply #4 on: January 18, 2017, 17:16:18 pm »
If I disable the editor, it works.
How can I solve this issue?

yeh, when we would know that, we would fix it. I do not understand, why the editors have problems. Seems to be some cache issue.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

grease082

  • Beginner
  • *
  • Posts: 14
Re: Multilanguage in product_desc not working
« Reply #5 on: January 19, 2017, 12:58:05 pm »
Thanks.

for now it works with tinymce editor but I would prefer the ark editor.
Anyway it works and that's important.

CE WebDesign München

  • Jr. Member
  • **
  • Posts: 112
  • CE WebDesign München
    • CE WebDesign München
Re: Multilanguage in product_desc not working
« Reply #6 on: March 09, 2017, 18:17:06 pm »
Fixed in JCE 2.6.9 

Info on fix (just guessing!):

Replace vmviewadmin.php in /administrator/components/com_virtuemart/helpers/ with the file in the attached zip
https://www.joomlacontenteditor.net/support/forum/82961-jce-virtuemart-language-problem#reply-83277

Add legacy "mce_editable" class
https://github.com/widgetfactory/jce/commit/184d859d0d8149da9df1d3a57a6e6554a8aa1c32

Update to use TinyMCE 4 methods
https://github.com/widgetfactory/jce/commit/25eb89fa5aba3069b9186882bafb15af64256d9c
CE WebDesign München: https://ce-webdesign.de | Websites, eCommerce WebShops | Responsive Design | SEO