Author Topic: validateIpnContent: Error while posting IPN: , 0  (Read 1002 times)

artaxx

  • Beginner
  • *
  • Posts: 1
  • A beginner
validateIpnContent: Error while posting IPN: , 0
« on: January 09, 2017, 14:52:00 pm »
Hi there,

I know that a lot of people do have this problem but after trying all solutions provided bei this forum and Google I have to ask here. Sorry for that!

Joomla: Joomla! 3.6.5 Stable
PHP: 5.5.38
Virtuemart: VirtueMart 3.0.18

I configures the IPN on Paypal with Return and IPN but I always get this error after paying.

What I've done:
- Checked Reverse Proxy => none
- Checked OpenSSL => activated
- Double-Checked the Return and IPN Settings in Paypal Profile
- Changed locale to UTF-8

Are there any other solutions for this problem?

Thank you!

Greets
Daniel

Grepo

  • Beginner
  • *
  • Posts: 1
  • A beginner
  • Skype Name: Grepo887
Re: validateIpnContent: Error while posting IPN: , 0
« Reply #1 on: February 17, 2017, 11:34:38 am »
I had a similar problem. But as I understand it, no one has given an answer?:( Maybe someone in the know, could this be due to misconfigured proxy server? Thanks in advance.

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3186
  • using Piwik instead of Google Analytics
Re: validateIpnContent: Error while posting IPN: , 0
« Reply #2 on: February 18, 2017, 11:45:02 am »
I configures the IPN on Paypal with Return and IPN but I always get this error after paying.

What I've done:
- Checked Reverse Proxy => none
- Checked OpenSSL => activated
- Double-Checked the Return and IPN Settings in Paypal Profile
- Changed locale to UTF-8

Do you use the paypal sandbox or production setting? See here: https://www.paypal-knowledge.com/infocenter/index?page=content&id=FAQ1914
VirtueMart PayPal Standard is using:
https://api-3t.sandbox.paypal.com
https://api-3t.paypal.com

If you check your website's domain with this tool: https://www.sha2sslchecker.com
does it find 'sha256WithRSAEncryption' or something else?

If you can't find a solution, you may consider to set IPN to 'Off' in you PayPal account settings. I've never enabled it and PayPal works fine. I do get 'you received a paypment' emails from PayPal without IPN enabled.

Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations