Author Topic: The payment method description is left blank on the customer confirmation email  (Read 702 times)

rvbgnu

  • 3rd party VirtueMart Developer
  • Jr. Member
  • *
  • Posts: 113
    • Puma-IT.ie
Hello,

The confirmation email sent after payment (status confirmed).
The issue happens with Authorize.net. But the "Standard" payment method, included in VM, does NOT have this issue.
Tested with Joomla 3.4.8 / VM 3.0.12 (and earlier)

I've tried to debug a bit this issue, by comparing standard.php and authorizenet.php, but I did not find a solution.

After searching on the forum, it seems that it has been more or less reported before, but no solution found.

http://forum.virtuemart.net/index.php?topic=130282.0
http://forum.virtuemart.net/index.php?topic=129746.0

and also with VM 2.6.x
http://forum.virtuemart.net/index.php?topic=125534.0

Do you experience the same problem?
Best Regards, Hervé Boinnard - Irish Time (GMT)
Joomla! multilingual website and online business made easy - https://www.puma-it.ie

Updated for VM3 and Joomla 3.x! Stripe.com payment plugin for VirtueMart: https://www.puma-it.ie/en/joomla-and-virtuemart-extensions/stripe-for-virtuemart
Authipay (AIB Merchant Services) for VirtueMart 2 & 3: https://www.puma-it.ie/en/joomla-and-virtuemart-extensions/authipay-aib-merchant-services-for-virtuemart

rvbgnu

  • 3rd party VirtueMart Developer
  • Jr. Member
  • *
  • Posts: 113
    • Puma-IT.ie
Hello,

Any taker/debugger for this one? It is still happening in VM 3.2.12 and Joomla 3.8.5 today.

Please see email images to understand faster:
[/img]
Best Regards, Hervé Boinnard - Irish Time (GMT)
Joomla! multilingual website and online business made easy - https://www.puma-it.ie

Updated for VM3 and Joomla 3.x! Stripe.com payment plugin for VirtueMart: https://www.puma-it.ie/en/joomla-and-virtuemart-extensions/stripe-for-virtuemart
Authipay (AIB Merchant Services) for VirtueMart 2 & 3: https://www.puma-it.ie/en/joomla-and-virtuemart-extensions/authipay-aib-merchant-services-for-virtuemart

rvbgnu

  • 3rd party VirtueMart Developer
  • Jr. Member
  • *
  • Posts: 113
    • Puma-IT.ie
Hello,

Good news! A client of mine shared a fix for this issue. So it should also solved the issue for Authorize.net payment plugin!

Code: [Select]
protected function plgVmOnShowOrderFEPayment()
should be

Code: [Select]
public function plgVmOnShowOrderFEPayment()http://dev.virtuemart.net/projects/virtuemart/repository/entry/trunk/virtuemart/plugins/vmpayment/authorizenet/authorizenet.php#L1095

Thanks Peter to point it to me!
Best Regards, Hervé Boinnard - Irish Time (GMT)
Joomla! multilingual website and online business made easy - https://www.puma-it.ie

Updated for VM3 and Joomla 3.x! Stripe.com payment plugin for VirtueMart: https://www.puma-it.ie/en/joomla-and-virtuemart-extensions/stripe-for-virtuemart
Authipay (AIB Merchant Services) for VirtueMart 2 & 3: https://www.puma-it.ie/en/joomla-and-virtuemart-extensions/authipay-aib-merchant-services-for-virtuemart