Author Topic: Strict Standards: Declaration error  (Read 1048 times)

sylwekb

  • Jr. Member
  • **
  • Posts: 67
Strict Standards: Declaration error
« on: January 05, 2016, 19:08:56 pm »
Joomla 3.4.8 + VirtueMart 3.0.12, Shoplab template, php version 5.6.16

How to solve this problem?

Strict Standards: Declaration of plgVMPaymentPayzen::emptyCart() should be compatible with vmPSPlugin::emptyCart($session_id = NULL, $order_number = NULL) in /.../plugins/vmpayment/payzen/payzen.php on line 0

Strict Standards: Declaration of plgVMPaymentSystempay::emptyCart() should be compatible with vmPSPlugin::emptyCart($session_id = NULL, $order_number = NULL) in /../plugins/vmpayment/systempay/systempay.php on line 0

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26430
  • Always on vacation
    • Jenkin Hill Internet
Re: Strict Standards: Declaration error
« Reply #1 on: January 05, 2016, 19:49:20 pm »
http://forum.virtuemart.net/index.php?topic=102555.0

If you do not use Systempay or Payzen then disable the plugins.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.10 on Joomla 3.8.3 PHP 7.0.25

Testing VM3.2.10.9700 on J3.8.3

sylwekb

  • Jr. Member
  • **
  • Posts: 67
Re: Strict Standards: Declaration error
« Reply #2 on: January 05, 2016, 20:10:54 pm »
Thank You

pierrehaut

  • Beginner
  • *
  • Posts: 1
  • A beginner
Re: Strict Standards: Declaration error
« Reply #3 on: March 12, 2017, 19:17:28 pm »
Hello
I have the same problem
but I use  PayZen
So I can't disable the plugin .

It seems that appears when I updated to Joomla! 3.6.5 
(I did not modify VirtueMart - VirtueMart 3.0.4  AIO)

Thank you for yours answers

Pi.

Ghost

  • Jr. Member
  • **
  • Posts: 378
Re: Strict Standards: Declaration error
« Reply #4 on: March 13, 2017, 13:28:03 pm »
Start by upgrading VM to a version that isn't 2+ years old.