Author Topic: From 3.0.9 to 3.0.10 Custom Fields dont show up  (Read 8643 times)

SnakeFFM

  • Beginner
  • *
  • Posts: 27
From 3.0.9 to 3.0.10 Custom Fields dont show up
« on: November 01, 2015, 22:00:40 pm »
Hi!

just tried 3.0.10 and everything was working pretty fine except of the 'custom fields" function.

I use custom fields especially to show typical attributes above products, for instance '1. edition', but I then dont use any values or something. For instance: http://www.tradingcards4you.de/de/yugioh/premium-gold-2/Absoluter%20K%C3%B6nig%20D%C3%BCsen-Jack-detail.html (page is in German, therfore 1. edition is equal to '1. Auflage')

In custom field options I've typed in the following parameters: "string" - Show title? 'yes' public? 'yes' layout position 'ontop'

Once I ve updated to 3.0.10 all custom fields were wiped away. I've noticed that once I've stated something in the value field of a certain product, then the certain custom field showed up again.

I now changed back to 3.0.9 and the custom fields are there again - Did i miss something in regarding my custom field options which needs to be changed when using 3.0.10?

I hope this feedback is kind of helpful for you guys.

Best,
Snake

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10158
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

SnakeFFM

  • Beginner
  • *
  • Posts: 27
Re: From 3.0.9 to 3.0.10 Custom Fields dont show up
« Reply #2 on: November 02, 2015, 14:28:21 pm »
Hi Milbo,

is this a known issue?

I ll have a try and let you know the results.

Thanks for your swift response.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10158
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

SnakeFFM

  • Beginner
  • *
  • Posts: 27
Re: From 3.0.9 to 3.0.10 Custom Fields dont show up
« Reply #4 on: November 02, 2015, 19:36:07 pm »
Just installed it locally and installed it, result now:

- Custom fields still dont show up and additional error in cart: 'Programmer used an unknown userfield agreed' which only shows up when I use the virtueplanet plugin 'onepage checkout'

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10158
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: From 3.0.9 to 3.0.10 Custom Fields dont show up
« Reply #5 on: November 02, 2015, 20:41:04 pm »
then you should create the userfield agreed. Sounds like it is missing.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

SnakeFFM

  • Beginner
  • *
  • Posts: 27
Re: From 3.0.9 to 3.0.10 Custom Fields dont show up
« Reply #6 on: November 02, 2015, 21:44:15 pm »
Custom Field

Well, regarding custom fields it's still the same. They are only shown when I add any value. For instance I have the following custom field:

- String
- Title: 'Gold Secret Rare'

If I type in as value '1' then you see it. If the field is empty then it's gone again. In 3.0.9 it was not necessary to enter any value to see the customfields.

Checkout

I am using the plugin as I am not so much into the code of virtuemart (quick solution). Was also working without any alerts on 3.0.9 - Normal checkout works perfectly. I know you guys dont support 3rd party extensions, I ve just noticed that there is also something different than before.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10158
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: From 3.0.9 to 3.0.10 Custom Fields dont show up
« Reply #7 on: November 02, 2015, 23:19:59 pm »
It is only a small thing, i am sure there will be an update by the 3rd party.

"If I type in as value '1' then you see it. If the field is empty then it's gone again. In 3.0.9 it was not necessary to enter any value to see the customfields."

in the category browse view?
Yes we removed showing of the title, when the value is empty, usually it is not wanted. Hmmm, I fear I have to create an option for, but you could also just override the function. It is overrideable!
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

SnakeFFM

  • Beginner
  • *
  • Posts: 27
Re: From 3.0.9 to 3.0.10 Custom Fields dont show up
« Reply #8 on: November 03, 2015, 00:34:55 am »
Havent seen any post in the forum yet, maybe I ll tell the 3rd party guys.

Category Browse view is the view that appear after you ve clicked on a product right? http://www.tradingcards4you.de/de/yugioh/premium-gold-2/ger%C3%BCmpelriese-detail.html

In my "live" version I have still 3.0.9 running thats why you can still see the product fields.

Well, I wouldnt mind to do an override (just a normal override in the html folder of the template, right?). Would you mind to tell me how the override would have to look like?

Have a good night.

SnakeFFM

  • Beginner
  • *
  • Posts: 27
Re: From 3.0.9 to 3.0.10 Custom Fields dont show up
« Reply #9 on: November 03, 2015, 20:02:01 pm »
well, the reason for the error in the cart was related to the shopper field 'agreed' not published...

and for the custom fields I made an override in custofields as stated (sublayouts > customfields.php):

Code: [Select]
/*|| empty($field->display)*/
Code: [Select]
foreach ($product->customfieldsSorted[$position] as $field) {
if ( $field->is_hidden /*|| empty($field->display)*/) continue; //OSP http://forum.virtuemart.net/index.php?topic=99320.0
?><div class="product-field product-field-type-<?php echo $field->field_type ?>">
<?php if (!$customTitle and $field->custom_title != $custom_title and $field->show_title) { ?>
<span class="product-fields-title-wrapper"><span class="product-fields-title"><strong><?php echo vmText::($field->custom_title?></strong></span>
<?php if ($field->custom_tip) {
echo JHtml::tooltip (vmText::_($field->custom_tip), vmText::($field->custom_title), 'tooltip.png');
?>
</span>
<?php }
if (!empty($field->display)){
?>
<div class="product-field-display"><?php echo $field->display ?></div><?php
}
if (!empty($field->custom_desc)){
?>
<div class="product-field-desc"><?php echo vmText::_($field->custom_desc?></div> <?php
}
?>

</div>
<?php
$custom_title $field->custom_title;
?>


Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10158
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: From 3.0.9 to 3.0.10 Custom Fields dont show up
« Reply #10 on: November 03, 2015, 22:13:15 pm »
yeh, you made it yourself, looks good.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

SnakeFFM

  • Beginner
  • *
  • Posts: 27
Re: From 3.0.9 to 3.0.10 Custom Fields dont show up
« Reply #11 on: November 04, 2015, 09:52:22 am »
I am not sure how other people use custom fields, but I liked your idea to add an option to show the custom field yet it has no value. However, I dont know how much work that would cause for you, but I was quite happy to use the fields tough they had 'no value'.

Thanks for ur support mate.

jooomlaa

  • Beginner
  • *
  • Posts: 26
    • mediaDESIGN
  • VirtueMart Version: newest
Re: From 3.0.9 to 3.0.10 Custom Fields dont show up
« Reply #12 on: November 17, 2015, 17:22:01 pm »
Have installed VM Version 3.0.12 (J!3.4.5). The error is still displayed. :-(

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10355
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
Re: From 3.0.9 to 3.0.10 Custom Fields dont show up
« Reply #13 on: November 17, 2015, 19:26:56 pm »
Crystal ball broke... which error?
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

jooomlaa

  • Beginner
  • *
  • Posts: 26
    • mediaDESIGN
  • VirtueMart Version: newest
Re: From 3.0.9 to 3.0.10 Custom Fields dont show up
« Reply #14 on: November 18, 2015, 08:09:54 am »
The Cart-Message: "Error: Programmer used an unknown userfield agreed".
The Error exists since i have update vm from 3.0.9 to 3.0.12