Author Topic: Product name with a single quote in multilingual setting is not saved corrected  (Read 470 times)

ptrouw

  • Jr. Member
  • **
  • Posts: 124
I have English product names with a single quote in the name like: Renault Master III '10- rear bumper protector ABS.
When I save this record into a different language, this single quote is changed into the HTML number '
Now the product name reads: Renault Master III '10- achterbumper protector ABS, in Dutch.

If I save the product again, it adds another HTML number to the product name. It now reads: Renault Master III &'10- achterbumper protector ABS.
This happens in all installed languages, except the default English.

I have included 3 screen shots.
1. English product name
2. Saved the Dutch product name with '
3. Saved twice in Dutch, now with &'

I am using J3.4.4 and VM3.0.10. I am not using an editor.
Any thoughts on this?
Can you reproduce this behaviour?

BTW I double checked the SQL record showing the stored English product name as: Renault Master III '10- rear bumper protector ABS. So the English source has this HTML number already in the database.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9683
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Please take a carefull look.

It is normal that it is stored encoded. Maybe the problem is the js, when oyu change the language. what happens whe you changed the language and press f5? because the php should decrypt it.... and maybe the js, switching the values, does not.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

ptrouw

  • Jr. Member
  • **
  • Posts: 124
A F5 doesn't make a difference.
It still shows the &#39, only in the extra languages. If I save twice, it adds another HTML number like: Peugeot 308 SW II '13- Einstiegsleisten.
Could be a js thing. Within the js console I can't see any strange errors. I tried it in firefox and chrome, both are doing the same strange thing!

I also tried a complete clean installed 3.0.8 environment which came with a commercial template. Tried it on local host. I am getting exact the same behaviour. Saving it once, you will see #39; and saving it twice '

Any other ideas?

Wibah

  • Beginner
  • *
  • Posts: 4
Problem also exists with double quotes or indeed all special characters.
They get translated when switching languages. Probably caused by javascript.

Could this be fixed in the next update?