Author Topic: SAVE button doesn't work  (Read 967 times)

marko227

  • Beginner
  • *
  • Posts: 7
SAVE button doesn't work
« on: September 23, 2015, 11:07:48 am »
After update to VM 3.0.10 and Joomla 3.4.4 all buttons in product edit (save, save & close, close) doesn't work.

I try to upload new image for product, click save, page is loading and nothing happens.
When i refresh page it show me this messages:
Code: [Select]
Error
vmError: Sorry,It's not a valid media file

Message
Product successfully saved

Any solution for this?

betterlead

  • Jr. Member
  • **
  • Posts: 167
    • LIVING STUDIO
  • VirtueMart Version: 3.2.12
Re: SAVE button doesn't work
« Reply #1 on: September 24, 2015, 03:02:26 am »
I have experienced the same. Since 3.0.10, you need to, in "image action" check for "upload"
Why the default is "no action" since this version, I really don't understand. Why, even is there such choice?
One more click, doesn't speed up the work... We site builder really click enough as it is...
/cheers

Skickat från min LG-H815 via Tapatalk

Live site runs on Joomla 3.8.13 & VM 3.2.12

PHP: 7.0.22

marko227

  • Beginner
  • *
  • Posts: 7
Re: SAVE button doesn't work
« Reply #2 on: September 24, 2015, 09:31:49 am »
Choosing Upload or any other action doesn't solve this issue.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9919
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: SAVE button doesn't work
« Reply #3 on: September 24, 2015, 10:05:21 am »
Why the default is "no action" since this version, I really don't understand.
Me 2

Why, even is there such choice?
Because when you always assume an upload, you get other problems (real problems, compared to now)

I have no clue, why you assume, that we are just assholes and removed it to annoy you.

The reality is simple, it stopped working for unknown reason. From my point of view, it never worked, because I use the "browse" button, a week ago or so,.. someone told me it stopped working, I wondered that it did. So he explained me it worked, using the method to dragndrop the file into the field.

Choosing Upload or any other action doesn't solve this issue.

Then the file you want to upload is the problem
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

betterlead

  • Jr. Member
  • **
  • Posts: 167
    • LIVING STUDIO
  • VirtueMart Version: 3.2.12
Re: SAVE button doesn't work
« Reply #4 on: September 24, 2015, 10:35:05 am »
C'mon, of course I didn't for a second mean anyone is an asshole. I am truly sorry for making your morning so cloudy. Mea culpa, I was in a bad mood. Please accept my apologies, Milbo.

Don't you honestly not do a lot of stuff just to annoy us ;)

Now, in other words, I am very grateful to have the possibility to use Virtuemart, actually for free.

Peace out.
Live site runs on Joomla 3.8.13 & VM 3.2.12

PHP: 7.0.22

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9919
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: SAVE button doesn't work
« Reply #5 on: September 24, 2015, 10:39:12 am »
Completly accepted, clouds moved, sun is shining.

I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

marko227

  • Beginner
  • *
  • Posts: 7
Re: SAVE button doesn't work
« Reply #6 on: September 24, 2015, 10:55:40 am »
Then the file you want to upload is the problem

Files are not problem. All files are uploaded successfully before updating Joomla and Virtuemart...
Now when i try to upload same files there is that error....

If you want i can send you live url with admin access to take a look and see where problem is.
I'm willing to pay someone to help me with this.

Thanks!

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9919
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: SAVE button doesn't work
« Reply #7 on: September 24, 2015, 12:11:34 pm »
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

marko227

  • Beginner
  • *
  • Posts: 7
Re: SAVE button doesn't work
« Reply #8 on: September 24, 2015, 16:43:05 pm »
I just bought support ticket and send you data on PM

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9919
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: SAVE button doesn't work
« Reply #9 on: September 24, 2015, 20:31:01 pm »
I have experienced the same. Since 3.0.10, you need to, in "image action" check for "upload"

btw, fixed it today. Was nasty.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/