Author Topic: install/update generates: 405 Not Allowed -or- please rise execution time and up  (Read 9909 times)

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9726
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

rs3511

  • Beginner
  • *
  • Posts: 9
Hi Milbo,
Thank you for such a great extension! I just wanted to give you some information about how I was able to solve the database warning message.  I was able to correct the database but I could not use the tool "Install or if necessary update tables".  It would give the same 405 error. Instead I used the tool, "Reset all tables and install sample data", which ran to completion within seconds.  I had to rebuild my store categories, products and settings but it worked.

My question is related to the differences between the two tools.  I assume that the tool that worked, "Reset all tables and install sample data", uses some of the same code to reset the tables but then does extra work by installing sample data. What do you think would cause the tool "Install or if necessary update tables" to not run to completion and the other "Reset all tables and install sample data" to work perfectly when the ladder probably has much more work involved to complete its tasks?

Joomla 3.4.1
Virtuemart 3.0.8

Thanks again,

RS

responseit

  • Beginner
  • *
  • Posts: 5
  • A beginner
Running these did nothing. I have increased the max_execution_time to 300 and it still does nothing. I am not even updating, this is a fresh install and I get these errors ANY time I save the configuration. This is a bit ridiculous that there are over a thousand views on all the topics related to this and still no solutions that work.

brentonking

  • Jr. Member
  • **
  • Posts: 74
    • Brenton King Graphic Design, Web Design and Joomla! Site Development
I have also run in to this issue - however mine is a 504 Gateway Timeout

When it happened the first time I noticed that quite a few error messages appeared in the front end and a few things we missing in the backend such as order statuses (only pending option was available), vm menu items & shopper groups, etc.

I uploaded via FTP and tried Installing from Directory. I ran in to the same timeout issue, however I noticed most of the errors and missing elements from the backend were fixed. Order Statuses (except Pending) were still missing though. So it would seem that the update/install made it further through before timing out.

I then thought that it might be database related, so I tried "Install of if necessary update tables" & then received a 504 timeout again. I have used the same hosting (siteground) on multiple sites with virtuemart and other extensions that might be on the "heavier" end of execution time requirements & haven't had this problem with a VM install before. I find it odd that it's only just started occurring (for me) with 3.0.9 & 3.0.9.4.

Not sure if that helps shed any further light on the potential issue. Curious to hear if anyone else in this thread has solved their problems yet.

----- UPDATE -----

I manually imported install.sql, install_essential_data.sql & install_required_data.sql in to my database (via phpmyadmin) and that seemed to resolve most of my issues. I just had to copy the "_virtuemart_orderstates" values again to fix the order status issue.

I know that this might just be MY particular issue, however I thought it could be helpful. If I had to guess I'd say whatever issue was causing the timeout for me, may have been related to the SQL database edits during install.

backwardsfish

  • Beginner
  • *
  • Posts: 10
  • A beginner
OMG - Happening to me too.


This install through phpAdmin you speak of, is it relatively easy to do?

Ran the "install/update button"  a few times - it takes a good 5 minutes of the browser loading until the error comes back by the way - AND after manually increasing via provider a-la support Ticket and all. But ran it a few times and made note of the error on tip line. It's the same one each time; so doesn't like progress is being made despite the time-out runs out.

Before max execution was 30.
Increased to 300.
Mem limit 128M.

vm 3.0.9
Joomla 3.3.6

 

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27043
  • Always on vacation
    • Jenkin Hill Internet
You should be using Joomla 3.4.3

What host are you using?
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.0.9935 on Joomla 3.8.12 PHP 7.0.31
Testing VM 3.4.0.9941 on Joomla 3.8.12

backwardsfish

  • Beginner
  • *
  • Posts: 10
  • A beginner
Just upgraded to J3.4.3 and am running the "install or if necessary update" function in another window. It's still loading while I type.



I'm with "Host Monster" ... Have given them a username/login to try and run the update task on their end - maybe they can run it locally or something. Have used previous Virtuemart versions for years; first sign of a problem has been this on my brand new site - AFTER entering like nearly 300 products. Ugh.

The other window is still loading. Will post reply when it finishes.

backwardsfish

  • Beginner
  • *
  • Posts: 10
  • A beginner
INteresting.

Atfer updating Joomla, and running the VM database update if necessary thing i get:
[an error occurred while processing this directive]

Then, hit "back" in browser and the usual long string of "rise execution time" errors are there.

ALSO, now, NEW error shows up when adding a new product:
1054 Unknown column 'file_class' in 'field list' SQL=INSERT INTO `qqk3m_virtuemart_medias` (`virtuemart_media_id`,`virtuemart_vendor_id`,`file_title`,`file_description`,`file_meta`,`file_class`,`file_mimetype`,`file_type`,`file_url`,`file_url_thumb`,`published`,`file_is_downloadable`,`file_is_forSale`,`file_is_product_image`,`shared`,`file_params`,`file_lang`,`created_on`,`created_by`,`modified_on`,`modified_by`) VALUES ('0','1','Presto-Bottle.jpg','','','','image/jpeg','product','images/stories/virtuemart/product/Presto-Bottle.jpg','','1','0','0','0','0','','','2015-07-22 05:50:52','42','2015-07-22 05:50:52','42')

Product was saved, image was not. I'm guessing this may have to do with the tables not getting fully updated in database.


No word back from host support ticket on whether they were able to login and try running on their end.




ultravelvet

  • Beginner
  • *
  • Posts: 6
hello,
I am running into this problem as backwardsfish (Error 1054 when trying to upload a product image) as well as Nginx/Not Allowed errors when trying to save configuration.  Increasing max execution time is not an option. 
Ran VM3.0.9 on Joomla 3.4.3.  Nginx/Not Allowed errors when trying to save configuration.  I re-installed Joomla (3.4.3) and installed VM 2.9.8 and I could update configurations, upload product photos, etc quickly & flawlessly.  Updated to VM 3.0.9 and sluggishness & not allowed errors re-appear when I tried to make a configuration change. tried to install/update data to no avail.

The install also gave an error, but I can upload the package and install from directory next time. I did not install sample data and only have 2 products, no orders, invoices, etc--in other words, not much data.
Host = Hostgator. 
PHP=5.4.38
Any insight would be appreciated. 

backwardsfish

  • Beginner
  • *
  • Posts: 10
  • A beginner
Interesting. So maybe I could "downgrade" VM and get back to a functioning system but the sounds of things....

I'm committed to Joomla at this point, as well as my host - so seems like my only option.
 Are we the only ones upgrading? Darnit, why why why did I upgrade?!  :-\ :'(

Does anyone reading this have a functioning UPGRADED 3.0.9 version of VM? Or are all the functioning copies mentioned in previous posts fresh/sample data installs?

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27043
  • Always on vacation
    • Jenkin Hill Internet
I have updated a lot of VM sites to 3.0.9 and now to 3.0.9.4 with no issues. With way in excess of 50,000 downloads of 3.0.9 the few reports of issues are almost all installs on Hostgator and now one on Hostmonster. As I have never used those hosts I have no idea how their packages are set up, but one potential cause of failure for shared hosting on gator has been identified:  http://support.hostgator.com/articles/cpanel/php-settings-that-cannot-be-changed

The full thread is there at http://forum.virtuemart.net/index.php?topic=129761
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.0.9935 on Joomla 3.8.12 PHP 7.0.31
Testing VM 3.4.0.9941 on Joomla 3.8.12

ultravelvet

  • Beginner
  • *
  • Posts: 6
thanks Mr Hill,
that is most helpful.  indeed, i know that hostgator doesn't allow shared customers to alter certain php settings.  i didn't think it would affect me this much. 

can you please indicate a host(s) where vm version 3.0.x has been successful? and what is the max execution time setting that is appropriate?

your thoughts are most appreciated.
lisa

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27043
  • Always on vacation
    • Jenkin Hill Internet
I use United Hosting servers and have never had an installation issue. For Joomla 3 - I use the following settings in local php.ini

max_execution_time = 120
memory_limit = 256M

; File Uploads ;
upload_max_filesize = 32M

post_max_size = 32M
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.0.9935 on Joomla 3.8.12 PHP 7.0.31
Testing VM 3.4.0.9941 on Joomla 3.8.12

backwardsfish

  • Beginner
  • *
  • Posts: 10
  • A beginner
Thank-you for the info. Very interesting re host and I figured as much with so many downloads that this must be a rather isolated problem. I'll read into the thread you recommended, get in touch with my host and report back any progress (or lack thereof!)

backwardsfish

  • Beginner
  • *
  • Posts: 10
  • A beginner
Host Monster has increased my max execution from 30 to 300 already but still getting the error. I've asked them to increase memory to see if that helps.