Author Topic: VM Products not working anymore after Joomla update  (Read 16573 times)

MAD King

  • Jr. Member
  • **
  • Posts: 385
  • Supporter Membership - Gold
  • VirtueMart Version: Always the Latest
VM Products not working anymore after Joomla update
« on: March 22, 2015, 15:03:09 pm »
After I updated Joomla to version 3.4.1, I am not able to Save & Close, Save, or Cancel products anymore. The buttons do not react.
I already reported this issue to Joomla and they guess is:

Quote
My first bet is that they somehow rely on MooTools being loaded without loading it themself.


Joomla 3.4.1
Vm 3.0.6.2
Joomla! 3.9.12
VirtueMart 3.6.2 10159

MAD King

  • Jr. Member
  • **
  • Posts: 385
  • Supporter Membership - Gold
  • VirtueMart Version: Always the Latest
Re: VM Products not working anymore after Joomla update
« Reply #1 on: March 22, 2015, 19:31:22 pm »
UPDATE: I restored it to Joomla 3.4.0 with VM  3.0.6.2 and the same issue. It is definitely Virtuemart.
Joomla! 3.9.12
VirtueMart 3.6.2 10159

lindapowers

  • Full Member
  • ***
  • Posts: 1335
  • If you're going through hell, keep going.
    • Los Angeles immigration lawyers
  • Skype Name: manu.gonzalez91
  • VirtueMart Version: Latest avi
Re: VM Products not working anymore after Joomla update
« Reply #2 on: March 22, 2015, 20:17:32 pm »
Tested with

Joomla 3.4.1
Vm 3.0.6.2

Happens the same to me.

Regards

MAD King

  • Jr. Member
  • **
  • Posts: 385
  • Supporter Membership - Gold
  • VirtueMart Version: Always the Latest
Re: VM Products not working anymore after Joomla update
« Reply #3 on: March 22, 2015, 20:52:59 pm »
Uff, I am glad I am not the only one.
Joomla! 3.9.12
VirtueMart 3.6.2 10159

Anirudh

  • Beginner
  • *
  • Posts: 25
Re: VM Products not working anymore after Joomla update
« Reply #4 on: March 22, 2015, 21:38:59 pm »
same here!




Virtuemart 3.0.6.2
Joomla 3.4.1

Jormolca

  • Beginner
  • *
  • Posts: 1
Re: VM Products not working anymore after Joomla update
« Reply #5 on: March 22, 2015, 23:40:25 pm »
Hi, I have the same problem:
Joomla 3.4.1
Virtuemart 3.0.6.2

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27730
  • Always on vacation
    • Jenkin Hill Internet
Re: VM Products not working anymore after Joomla update
« Reply #6 on: March 22, 2015, 23:42:59 pm »
Works fine for me with new install of J3.4.0 but not with new install of J3.4.1 - the error has been identified but not the exact cause. There were more than a few code changes/fixes between J3.4 & J3.4.1. And issues starting to appear in the Joomla bug tracker. http://issues.joomla.org/tracker/joomla-cms
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.8.0 10314 on Joomla 3.9.16 PHP 7.0.33

MAD King

  • Jr. Member
  • **
  • Posts: 385
  • Supporter Membership - Gold
  • VirtueMart Version: Always the Latest
Re: VM Products not working anymore after Joomla update
« Reply #7 on: March 22, 2015, 23:46:14 pm »
Like I wrote in my previous post. It does also not work with Joomla 3.4 on my site, but it was also an update and not a fresh installation. So, there is something not right in the update too.
Joomla! 3.9.12
VirtueMart 3.6.2 10159

Anirudh

  • Beginner
  • *
  • Posts: 25
Re: VM Products not working anymore after Joomla update
« Reply #8 on: March 23, 2015, 02:10:06 am »
Works fine for me with new install of J3.4 but not with new install of J3.4.1 - the error has been identified but not the exact cause. There were more than a few code changes/fixes between J3.4 & J3.4.1. And issues starting to appear in the Joomla bug tracker. http://issues.joomla.org/tracker/joomla-cms

Do you mean that if I roll back to J 3.4, I will get the Save and Close button back to normal?

MAD King

  • Jr. Member
  • **
  • Posts: 385
  • Supporter Membership - Gold
  • VirtueMart Version: Always the Latest
Re: VM Products not working anymore after Joomla update
« Reply #9 on: March 23, 2015, 02:18:18 am »
No it will not. Tried it already.
Joomla! 3.9.12
VirtueMart 3.6.2 10159

Mike J

  • Beginner
  • *
  • Posts: 34
Re: VM Products not working anymore after Joomla update
« Reply #10 on: March 23, 2015, 05:47:29 am »
Same problem here :'( ... Any solutions?
VirtueMart 3.6.4
Joomla! 3.9.12
PHP 7.2

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27730
  • Always on vacation
    • Jenkin Hill Internet
Re: VM Products not working anymore after Joomla update
« Reply #11 on: March 23, 2015, 11:26:07 am »
Do you mean that if I roll back to J 3.4, I will get the Save and Close button back to normal?

A rollback from 3.4.1 to 3.4 does not work, but a fresh install of 3.4 worked OK for me. The devs are working on a solution.

If it were an issue with VM3.0.6.2 on J3.4 then the forum would have been inundated with reports already.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.8.0 10314 on Joomla 3.9.16 PHP 7.0.33

gudrus

  • Beginner
  • *
  • Posts: 2
  • A beginner
  • Skype Name: setupe45
Надо ждать пока разработчики исправят ошибку в Joomla и после этого сделать обновление?


При удалении крестиком в товаре с права

Цена товара (Вы находитесь в группе покупателей COM_VIRTUEMART_SHOPPERGROUP_DEFAULT)

все сохраняется но без цены соответственно!


When you delete a cross in from the right product

Commodity price (you're in a group of buyers COM_VIRTUEMART_SHOPPERGROUP_DEFAULT)

all retained but without the price accordingly!


VirtueMart 3.0.6.3
Joomla! версия, 3.4.1

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10040
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: VM Products not working anymore after Joomla update
« Reply #13 on: March 23, 2015, 16:17:06 pm »
UPDATE: I restored it to Joomla 3.4.0 with VM  3.0.6.2 and the same issue. It is definitely Virtuemart.

You must of course delete your browser cache! Joomla does NOT send the current version as vm does. So you must delete the cache. Btw

http://forum.virtuemart.net/index.php?topic=128962.msg443567#msg443567

It seems the solution is to use j3.4.1 with the js of j3.4.0
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10040
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: VM Products not working anymore after Joomla update
« Reply #14 on: March 23, 2015, 16:19:30 pm »
When you delete a cross in from the right product

Commodity price (you're in a group of buyers COM_VIRTUEMART_SHOPPERGROUP_DEFAULT)

all retained but without the price accordingly!

You mean, when you use the red cross to delete all products prices, then it works. Yes. The problem is the new validator, which cannot handle this multiple arrays,

So this input here
mprices[product_price_publish_up][]

throws this error
Error: Syntax error, unrecognized expression: #mprices[product_price_publish_up][]-lbl
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/