Author Topic: [solved] add image to categories not working in my VM 3.0.6.2  (Read 1073 times)

doc_denis

  • Beginner
  • *
  • Posts: 34
joomla 3 and vm 3.0.6.2
when creating a new product category: adding picture does not work, the site looks good adding the image folder images / stories / virtuemart / category
but the image is not displayed in the back office.
I can not replace either (because it is not added).

found only technique, take a picture of the demo categories with "+16" button and i replace this picture :(
I have no more than 1 or 2 in advance.

Another practical question:

is there a technique to duplicate categories as for products?
this function back office virtuemart would be very useful to move faster.
with and / or without copying subcategories

doc_denis

  • Beginner
  • *
  • Posts: 34
Re: add image to categories not working in my VM 3.0.6.2
« Reply #1 on: March 14, 2015, 14:58:15 pm »
adding image categories works on another site for my tests.

my question
is there a way to repair the VM tables without risky to overwrite the existing catalog?

CSV export the catalog, may be the solution.
to use a "clean" backup and re-import additional items ...

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27574
  • Always on vacation
    • Jenkin Hill Internet
Re: add image to categories not working in my VM 3.0.6.2
« Reply #2 on: March 14, 2015, 15:51:04 pm »
Tools/Install or if necessary update tables    - fixes tables,  does not overwrite any data
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.6.8 10204 on Joomla 3.9.13 PHP 7.0.33

doc_denis

  • Beginner
  • *
  • Posts: 34
Re: add image to categories not working in my VM 3.0.6.2
« Reply #3 on: March 14, 2015, 16:18:54 pm »
thank you Jenkinhill,
i have a error message :

Incorrect table definition; there can be only one auto column and it must be defined as a key SQL=ALTER TABLE `joswz_virtuemart_medias` CHANGE COLUMN `virtuemart_media_id` `virtuemart_media_id` INT(1) UNSIGNED NOT NULL AUTO_INCREMENT FIRST

doc_denis

  • Beginner
  • *
  • Posts: 34
Re: add image to categories not working in my VM 3.0.6.2
« Reply #4 on: March 14, 2015, 17:28:40 pm »
hello, to solved the problem of the previous post,
I imported the table structure  "virtuemart_medias" of my test site.

then exported the data only "without the structure" of my table virtuemart_media the production site.

then i delete the table "virtuemart_media" on my website "production".
i recreate table with the exported structure

and then import the data from the table "virtuemart_media" of prodution site.

Now, the function "add an image" works well !

thank you for the idea that brought me the solution!

thank you again jenkinhill.   :)

doc_denis

  • Beginner
  • *
  • Posts: 34
Re: [solved] add image to categories not working in my VM 3.0.6.2
« Reply #5 on: March 14, 2015, 18:43:12 pm »
hello,

I also review the tables : virtuemart_products , virtuemart_product_medias, virtuemart_product_prices:

return the primary key and add auto increment with phpmyadmin.
Once done, the "update table" system to function and announced: "Database updated"

great!