Author Topic: Product Categories dissapearing after removing the Manufacturers?  (Read 576 times)

vicmarcal

  • Beginner
  • *
  • Posts: 15
Hi guys!
I think this is a bug, however if it is not, please move to the proper forum.
I'm using VirtueMart 3.0.2.
Way to reproduce it:
1)I installed VirtueMart with the default content.
2)I created several Product Categories.
3)I added a couple of products in each category and assigned manufacturers.
4)Then I deleted all the Manufacturers and Manufacturers Categories.
5)Now, all my Products Categories have dissapeared! However, in the Products, my items are present and they have their Categories properly filled(even more, they link to valid Product Categories)
6)The main issue is that now I can't create a "Menu Item->VirtueMart Product Category" since the only Products Category there is just the "Top Level Category"

I'm attaching a couple of screenshots:
bug1.png: Shows how my Product Categories is empty, as if none were created.
bug2.png: Shows how in "Filter" there is none Product Categories shown (usually here we can find them to filter the products by Category)
bug3.png : A product is shown, and its Product Category is properly shown however.
bug4.png: However the main issue is that the Product Categories seems to not be available and hence...I can't use the " Product Category" filter
Any idea?or solution?

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9856
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Product Categories dissapearing after removing the Manufacturers?
« Reply #1 on: February 03, 2015, 07:50:06 am »
Please update to vm3.0.4, can you reproduce it? I was not able to reproduce it, but maybe I missed something.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/