Author Topic: Not Province/State is displayed.  (Read 3966 times)

dinoide

  • Beginner
  • *
  • Posts: 23
Not Province/State is displayed.
« on: October 31, 2014, 09:07:48 am »
The button display nothing, and I can not go forward in the bying process.

Countries and states are populated in the administration VM side.

VM version 2.9.9.2
Joomla latest: 3.x

check at; http://farmacia-el-coto.com/index.php/usuario/direcci%C3%B3n_facturac%C3%ADon


[attachment cleanup by admin]

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28223
  • Always on vacation
    • Jenkin Hill Internet
Re: Not Province/State is displayed.
« Reply #1 on: October 31, 2014, 20:48:14 pm »
You have a JavaScript problem. You are loading two versions of jQuery and also you are not loading the full suite of VM .js files. especially chosen.jquery.min.js (used for the dropdown)

Check settings in Config/templates/Activate Css Styles & Javascripts
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.9.10473 on Joomla 3.9.28 PHP 7.4.14

FaintOfFeint

  • Beginner
  • *
  • Posts: 6
  • A beginner
Re: Not Province/State is displayed.
« Reply #2 on: November 20, 2015, 19:08:24 pm »
OK, that hint helped me. Tinkering with the settings which you mentioned did not help, but when I changed the VirtueMart template back to Protostar -- then the U.S. states menu began working. Apparently the Joomspirit template which I'm using has a Javascript conflict with VM.