Author Topic: Duplicate order conformations + no payment/shipment names displayed [VM 2.6.16]  (Read 9325 times)

carolmarkerson

  • Beginner
  • *
  • Posts: 2
Hi I am having an issue with my order conformation and invoice.

When a new order is placed the user receives 2 order emails one that contains the payment/shipment and one that's missing the names. Attached to each email is the PDF invoice that also is missing the payment/shipment info. The missing info is only on the first pending email sent out all other emails after have the correct information. If i disable the invoice generation on pending orders then if I force generate an invoice it works fine. The payment method is 'VM Payment - Standard' and the shipment method is 'VM Shipment - By weight, ZIP and countries'.

I am running VirtueMart 2.6.8 and Joomla 2.5.24. I have run the database update tool and the renew config from file tool. The database has been migrated from a previous version that on initial testing a month ago didn't seem to have issue. I haven't made any modifications to the files.

Thank you if you have any help :)

jlover

  • Beginner
  • *
  • Posts: 18
same problem here.

have your got solution?

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10416
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
AFAIK this is fixed on 2.6.10 which you should be on anyway - it is the only current secure version
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

GP-Dev

  • Beginner
  • *
  • Posts: 6
Hello,

I am on Virtumemart 2.6.10 / Joomla 2.5.25 and the issue still exists. I didn't check with 2.6.8 since I upgraded from an earlier version.

The issue presents this way for me:

On order status "Pending" the vendor and the client get 2 emails, the one is the proper email with all the info and the other is missing the payment/shipment info.

The bad email is also shorter in width, proper VM emails take the full width of the page.

I don't use invoices so I don't know how these are affected.

Thank you

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28303
  • Always on vacation
    • Jenkin Hill Internet
Pending means that an order has been confirmed by the shopper but they have not yet paid. When the payment is made the order is set to Confirmed. You don't really want to have emails sent if the order is not yet paid, so for "Default Order Status to send email to shopper"  I only use Confirmed (and Confirmed by shopper when necessary) and the same two selected for "Default Order Status to send email to vendor". I only see one email to the vendor and one to the shopper.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.9.10473 on Joomla 3.9.28 PHP 7.4.14

GP-Dev

  • Beginner
  • *
  • Posts: 6
I agree that the email to the client could be disabled for pending orders.
However it is essential that the vendor gets an email for pending orders since most of these don't auto confirm (they are paid on delivery).

So there is no reason that 2 emails should be send for pending orders.

JMoVS

  • Beginner
  • *
  • Posts: 9
I also get the same error as of Virtuemart 2.6.10 on Joomla 2.5.27
2 emails of which one is missing the payment information (critical for pay upfront via bank transfer). Emails are sent twice to both the vendor and the shopper.

Dragoner

  • Beginner
  • *
  • Posts: 38
Hello, i have same problem. I need send mail to vendor and shopper where status is "P". Now VM send 2 and 2 emails.

I test VM 2.6.10 a 2.6.11 ... same problem ... (J 2.5.27)

Please HELP.

GP-Dev

  • Beginner
  • *
  • Posts: 6
Hello,

I just upgraded to 2.6.16 and the problem still exists. How is that possible?

Can a moderator change the title of the thread so that people know this doesn't concern just 2.6.8?

Thank you

janpihl

  • Beginner
  • *
  • Posts: 25
I just upgraded from 2.6.14 to 2.6.16 and the problem still exists.
In 2.6.14 the problem seemed solved but in 2.6.16 its back again.

Thank you

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10213
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
You must go in your config and store it at least one time.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

GP-Dev

  • Beginner
  • *
  • Posts: 6
Hi Milbo,

You mean go to Configuration->Configuration and click Save?
I tried that but I am afraid the bug still exists.

GP-Dev

  • Beginner
  • *
  • Posts: 6
Just upgraded to 2.6.17 and the issue still exists...
I also tried to click save on the configuration.

iRescue.gr

  • Beginner
  • *
  • Posts: 6
I am also in 2.6.17 and dealing with the same problem.
Any fix?

GP-Dev

  • Beginner
  • *
  • Posts: 6
Version 2.6.18 and the issue is still there.