Author Topic: safe path  (Read 1976 times)

randlieb

  • Beginner
  • *
  • Posts: 30
safe path
« on: October 20, 2014, 04:59:29 am »
I have set the safe path folder and the invoices folder per the warning text but still get the error warning in the admin.
----------------
Warning, the Safe Path is empty, for safety reasons it is very important to create a folder in a path not accessible by an URL, create also a folder invoices in it to store your sensitive data secure. Our suggested path is for your system /home/randlieb/craftingtheweb.net/websites/vmfiles, use this link to the config
---------------------------

Any ideas? Thanks.

Virtuemart 2.9.9f on Joomla 3.3.6

alatak

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2048
    • alatak.net
Re: safe path
« Reply #1 on: October 22, 2014, 19:38:00 pm »
Hello
Quote
I have set the safe path folder
the safe path must be an absolute path. Can that be the reason?

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10638
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.8.8
Re: safe path
« Reply #2 on: October 22, 2014, 20:33:57 pm »
and that path suggested (if u used it) is definitely not above the public folder - try  http://www.craftingtheweb.net/websites/vmfiles/invoices/

would be something like /home/randlieb/vmfiles
GJC Web Design
VirtueMart and Joomla Developers - php developers https://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
https://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

randlieb

  • Beginner
  • *
  • Posts: 30
Re: safe path
« Reply #3 on: October 23, 2014, 00:15:17 am »
Wel duh! Did a search for the error warning and found a help page on VM site that explained it all. Thanks for the info on where to put the folder. Looks like it's working ok now.