Author Topic: Need to keep this setting after update  (Read 549 times)

tselis

  • Beginner
  • *
  • Posts: 26
Need to keep this setting after update
« on: July 01, 2014, 19:34:24 pm »
hi, any time that i update virtuemart the setting in the photo is changed to VARCHAR so i am losing may data of my site. i need to keep it as LONGTEXT, some applications could change this setting also. i need to do it non changeable.

[attachment cleanup by admin]

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 7590
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.2
Re: Need to keep this setting after update
« Reply #1 on: July 01, 2014, 22:45:24 pm »
it will change cos updates normally refresh the tables etc .. sql is sql - if the script runs it will change - there is no lock I know of that will just lock the type.

you need to backup (as u should on every update) - reset to longtext and reimport just that column -
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

tselis

  • Beginner
  • *
  • Posts: 26
Re: Need to keep this setting after update
« Reply #2 on: July 08, 2014, 06:19:25 am »
thank you! ;)

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9336
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Need to keep this setting after update
« Reply #3 on: July 10, 2014, 19:27:13 pm »
ahh no.
First, you really do not need longtext. You could store the Lord of the Rings in it. text is absolutly adequate (you can already store the hobbit in it).

Second, there is an hidden option, which you can set in your virtuemart.cfg file.
dblayoutstrict=1

go to the tools, use "update config by file", be aware that you will lose some config settings, it is then reset to the values of the file.

This process is in enhanced in vm3, there you just enter in the file and store the config, done.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Rikard

  • Beginner
  • *
  • Posts: 2
  • A beginner
Re: Need to keep this setting after update
« Reply #4 on: October 13, 2017, 15:35:22 pm »
I have the same problem, my long description texts are truncated. The strange thing is that one of the languages isn't truncated, only the rest of them are. Anyway, I have updated my "/administrator/components/com_virtuemart/virtuemart.cfg" to dblayoutstrict=0 from (#dblayoutstrict) but my product category texts are still truncated. Is there anything else I need to do?

I'm running joomla 3.8.1 and VM 3.2.4 and php 7.1.10

Thanks,

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26315
  • Always on vacation
    • Jenkin Hill Internet
Re: Need to keep this setting after update
« Reply #5 on: October 13, 2017, 16:36:34 pm »
That's a 3 year old thread for a much older VM version.

Check if your template is a problem - test with Protostar.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8 PHP 7.0.23

Testing VM3.2.5.9653 on J!3.8