Author Topic: Another V2.6 update that has ruined my site! Help!  (Read 2645 times)

ucanfixit

  • Beginner
  • *
  • Posts: 19
Another V2.6 update that has ruined my site! Help!
« on: May 04, 2014, 06:17:05 am »
I am running joomla 2.5.20 and VM 2.6... PHP 5.3.24 I updated from the previous version through the extenstions manager.... Now my home page is blank!

The rest of the site works fine but my homepage wont display!!! Help please!

I turn on the Virtumart Debug messages and see "Fatal error: Class 'vmRequest' not found in /home/content/51/7550951/html/plugins/vmcustom/specification/specification.php on line 98"

on my homepage.

I HAVE NO CLUE WHERE TO START FIXING THIS!!!

Also now that I turn on debugging in my Virtumart admin I see these errors:

vmdebug $siteLang: en-GB self::$_jpConfig->lang en_gb
vmdebug vmTime: loadConfig db no: 0.00405192375183105
vmdebug Start used Ram 3.25M
vmdebug vmTime: VirtueMartControllerVirtuemart Finished task virtuemart: 0.377852916717529
vmdebug End used Ram 4.5M
vmdebug Peak memory peak 4.5M

And at the TOP of my joomal page in the ADMIN I see:

Notice: Undefined offset: 0 in /home/content/51/7550951/html/plugins/system/jo_vm_socialshare/jo_vm_socialshare.php on line 26

Notice: Undefined offset: 0 in /home/content/51/7550951/html/plugins/system/jo_vm_socialshare/jo_vm_socialshare.php on line 27

Notice: Undefined offset: 0 in /home/content/51/7550951/html/plugins/system/jo_vm_socialshare/jo_vm_socialshare.php on line 30

HELP!!!

Thanks in advance!

ucanfixit

  • Beginner
  • *
  • Posts: 19
Re: Another V2.6 update that has ruined my site! Help!
« Reply #1 on: May 04, 2014, 06:22:52 am »
UPDATE: I disabled the plugin called "VMCustom - specification" and how the homepage loads fine.

Any idea why this happened and what I can do to fix it plugin? It must be for something

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27598
  • Always on vacation
    • Jenkin Hill Internet
Re: Another V2.6 update that has ruined my site! Help!
« Reply #2 on: May 04, 2014, 11:20:56 am »
Did you also install/update the aio component?

Have a look at http://forum.virtuemart.net/index.php?topic=123237.

Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.6.10.10211 on Joomla 3.9.13 PHP 7.0.33

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 9228
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
Re: Another V2.6 update that has ruined my site! Help!
« Reply #3 on: May 04, 2014, 13:20:15 pm »
So - a test..

Clean J2.5.20 - Vm2.0.26d & AIO same

Live update to VM2.6.0 via the VM live updater

Runs fine and finishes with
Quote
Checking VirtueMart modules...Installing VirtueMart Administrator modules
VirtueMart2 modules already installed
VirtueMart2 pdf moved to the joomla libraries folder
Installing VirtueMart Plugins and modules Success.

You may directly uninstall this component. Your plugins will remain. But we advice to keep the AIO installer for updating

on administrator/index.php?option=com_virtuemart&view=liveupdate&task=install

White screen on frontend with fatal error (in logs) of

PHP Fatal error:  Class 'vRequest' not found in /home/xxxxxx/public_html/vm2t4/plugins/vmcustom/specification/specification.php on line 98

Backend:  administrator/index.php?option=com_virtuemart_allinone

lang vars not translated

Quote
Virtuemart 2 All in one Installer – LIVEUPDATE_TASK_OVERVIEW
LIVEUPDATE_NOUPDATES_HEAD

LIVEUPDATE_CURRENTVERSION 2.6.0
LIVEUPDATE_LATESTVERSION 2.6.0
LIVEUPDATE_LATESTRELEASED 2014-04-07
LIVEUPDATE_DOWNLOADURL http://virtuemart.net/component/ars/repository/virtuemart-2-aio/virtuemart-2-aio-2-6-0/comvirtuemart-2-6-0extaio-zip

no xmap etc as reported in some posts

So would appear something is wrong with the installer: the plugins/vmcustom/specification/specification.php is the latest - i.e AIO has installed - all files in plugins and modules are new (afaik it's new for 2.6.0?)

Trying to update again from LIVEUPDATE_REFRESH_INFO  results in no change

Looking in the admin helpers folder on the server there are indeed 4 files missing - see screen shot


Even after logging in and out - cache clearing - refreshing the live updater is still reporting  the old VM version

Quote
A new version is available

Before you update your live system, please test the update on a backup system in order to prevent loss of data. Expect small incompatibilities, if you are using 3rd party extensions or your own customizations (plugins, modules, templates).
Remember to update also your plugins and modules, for which you may use the live updater in the VirtueMart-AIO installer.
Installed version 2.0.26d
Latest version 2.6.0
Latest release date 2014-04-07
Direct download URL http://virtuemart.net/component/ars/repository/virtuemart/virtuemart-2-6-0/comvirtuemart-2-6-0-zip
VirtueMart 2.0.26d MINOR Revision: 7569 [PolarFox]
January 10 2014 1205 GMT

It really seems the Live Updater updates the AIO but NOT the VM component

file times on VM mods and plugins ->12:18

file times on VM comp:  ->  12:06 (when I updated to 2.0.26d prior to starting this test)

Then tried a manual install of 2.6.0 thru Joomla installer

Successful!

All errors gone - comp updated -   Live update reports correct version

CONCLUSION:

The Live Updater is ONLY updating the AIO - this is the source of these multiple white screens with PHP Fatal error:  Class 'vRequest' not found in /home/gjcwebde/public_html/vm2t4/plugins/vmcustom/specification/specification.php on line 98

It isn't reporting the failure at all and appears to have worked

SOLUTION:

Don't use the Live Updater (I personally never do - have always had problems with it) - use the Joomla installer

If you have a white screen and trace the error as PHP Fatal error:  Class 'vRequest' not found in /home/gjcwebde/public_html/vm2t4/plugins/vmcustom/specification/specification.php on line 98 then re-install JUST the com_virtuemart.2.6.0.zip  from
http://dev.virtuemart.net/attachments/download/698/com_virtuemart.2.6.0_extract_first.zip



[attachment cleanup by admin]
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27598
  • Always on vacation
    • Jenkin Hill Internet
Re: Another V2.6 update that has ruined my site! Help!
« Reply #4 on: May 04, 2014, 15:03:15 pm »
Quote
SOLUTION:

Don't use the Live Updater (I personally never do - have always had problems with it) - use the Joomla installer

I also have never used it despite hundreds of VM updates - I always use Joomla's extensions installer.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.6.10.10211 on Joomla 3.9.13 PHP 7.0.33