Author Topic: [SOLVED] BUG: Wrong language at order confirmation emails  (Read 632 times)

tzic

  • Jr. Member
  • **
  • Posts: 59
[SOLVED] BUG: Wrong language at order confirmation emails
« on: April 07, 2014, 14:46:02 pm »
Hello,

I have had this problem since early versions of VM2. I am now running the latest (2.0.26d) and still it is not fixed or I am doing something wrong.

The problem: I live in Greece, the website is in Greek, so when someone places an order he gets an "order pending email" in Greek as he/she should. But when I send the product and I mark the order as "SENT" if I dont change the backend language to Greek (I dont want to do that, I am used to English) the shopper will get the confirmation email in English.

The el-GR.com_virtuemart.ini file is as follows, in Greek

Code: [Select]
COM_VIRTUEMART_MAIL_SUBJ_SHOPPER_C="[%3$s], επιβεβαιωμένη παραγγελία από την %1$s, σύνολικό ποσό %2$s"
COM_VIRTUEMART_MAIL_SUBJ_SHOPPER_S="[%3$s], η παραγγελία σας από την %1$s, συνολικού ποσού %2$s, έχει αποσταλεί"
COM_VIRTUEMART_MAIL_SUBJ_SHOPPER_P="H παραγγελία σας είναι σε εξέλιξη, σύνολικό ποσό %2$s %1$s"

COM_VIRTUEMART_MAIL_SUBJ_VENDOR_C="[%3$s], επιβεβαιωμένη παραγγελία από την %1$s, σύνολικό ποσό %2$s"
COM_VIRTUEMART_MAIL_SUBJ_VENDOR_P="[%3$s], ΝΕΑ παραγγελία από %1$s, σύνολικό ποσό %2$s"
COM_VIRTUEMART_MAIL_SUBJ_VENDOR_S="[%3$s], η παραγγελία σας από την %1$s, συνολικού ποσού %2$s, έχει αποσταλεί"

Can please someone help me with this problem?

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3552
  • using Matomo instead of Google Analytics
Re: BUG: Wrong language at order confirmation emails
« Reply #1 on: April 07, 2014, 15:36:00 pm »
That problem was fixed approximately one year ago in version 2.0.21. I just made a test in my own 2.0.26d shop sending the 'shipped' order status email from my english language backend to a german language test order/customer. The email did arrive in German.

At the moment I unfortunately have no idea why it doesn't work in your case.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

tzic

  • Jr. Member
  • **
  • Posts: 59
Re: [SOLVED] BUG: Wrong language at order confirmation emails
« Reply #2 on: April 07, 2014, 22:20:56 pm »
Thank you for the reply. I had to create a language override in /httpdocs/administrator/language/overrides in order to make it work. Still havent figured out what was the problem and the confirmed order email was in the correct language and the sent order email was in te wrong one

PS Actually I copy / pasted el-GR.com_virtuemart.ini to en-GB.override.ini and it worked just fine