Author Topic: Joomla 3.X and VM2.2  (Read 1046 times)

tutnet

  • Beginner
  • *
  • Posts: 23
Joomla 3.X and VM2.2
« on: December 10, 2013, 20:17:36 pm »
Hi,

In July (http://virtuemart.net/news/latest-news/442-gold-version-2-0-series-released) the roadmap talks about Joomla 3.x compatibility.

I am trying to take the decision whether to use VM for a fully responsive Bootstrap website, compatible with other Joomla extensions built specifically for Joomla 3.x, that will start to be built early in 2014.  I need to take into account that the end of life for Joomla 2.5 is only 12 months away and I want to build on a platform that will be around without complex migrations on a production site required a few months down the line.

Could a member of the dev team let us know when we can expect Joomla 3.X compatibility with VM.

Thanks

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28324
  • Always on vacation
    • Jenkin Hill Internet
Re: Joomla 3.X and VM2.2
« Reply #1 on: December 11, 2013, 18:45:18 pm »
You should already have seen http://forum.virtuemart.net/index.php?topic=115326.0

Development if VM2.1/2.2 started in October and was already J3.0/3.1 compatible.  http://forum.virtuemart.net/index.php?topic=119177.0

As with some templates and other Joomla components, the release of J3.2 to replace J3.1.x  broke it! More people are required to help with the development testing, so feel free to grab the SVN.

I don't think it is going to be a complex migration, maybe similar to going from J2.5 to J3.x
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart  4.0.2 10661 on Joomla 3.10.9 PHP 7.4.29

tutnet

  • Beginner
  • *
  • Posts: 23
Re: Joomla 3.X and VM2.2
« Reply #2 on: December 12, 2013, 11:53:53 am »
Hi Kelvyn,

Thanks for the information - I'll follow up on the SVN.

The 3.1.x -> 3.2 has thrown a lot of components, I agree, and I worry about 3.5 in March - I haven't seen what the predicted changes are.

In terms of templating for VM the key must be to try to be able to incorporate a flexible approach to Bootstrap - the use of Bootstrap 2.3 instead of 3 in the J 3.2.x JUI is at best a nuisance thinking that Bootstrap 3 is out there in the wild.

Thanks for your input.  You do a sterling job on this forum!

Nick