Author Topic: Can't update... Invalid Token, in store config  (Read 3481 times)

kirkdickinson

  • Beginner
  • *
  • Posts: 18
Can't update... Invalid Token, in store config
« on: November 18, 2013, 18:01:03 pm »
I noticed when I opened VirtueMart today that it tells me there is a new version available. There is a link to click on to update to the newest version.  I get an error that isn't very descriptive:
Invalid Token, in store config

I have searched this site and the only post I have found about this seems to be in a different part of VM.

Thanks,

Kikr
PHP Built On:    Windows NT NTC45 6.1 build 7601 (Windows Server 2008 R2 Standard Edition Service Pack 1) i586
Database Version:      5.6.14
Database Collation:      utf8_general_ci
PHP Version:    5.3.13
Web Server:    Microsoft-IIS/7.5
WebServer to PHP Interface:    cgi-fcgi
Joomla! Version:    Joomla! 2.5.16 Stable [ Ember ] 06-November-2013 22:30 GMT
User Agent    Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

jenkinhill

  • Global Moderator
  • Super Hero
  • *
  • Posts: 21131
  • Web developer and consultant
    • Jenkin Hill Internet
Re: Can't update... Invalid Token, in store config
« Reply #1 on: November 18, 2013, 18:25:48 pm »
That error comes from the Akeeba updater code. You should update using Joomla's extensions manager. Get the file package from http://dev.virtuemart.net/projects/virtuemart/files

Never update a live site - always test first on a working backup of the site.
Kelvyn
Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

IMPORTANT:  VirtueMart versions before 2.6.10 are insecure. Updating is strongly advised.


Currently using VM2.6.12 on Joomla 2.5.27 PHP 5.4.21

Currently testing VM2.9.9fRC on J3.3.6

kirkdickinson

  • Beginner
  • *
  • Posts: 18
Re: Can't update... Invalid Token, in store config
« Reply #2 on: November 18, 2013, 23:35:56 pm »
Thanks.  This site is still a testing site. I am not live yet.  I am trying to get away from a very buggy OSCommerce site.  I fear that I am going from one buggy cart to a different buggy cart.  I have not had an easy time of getting this working.

Kirk
PHP Built On:    Windows NT NTC45 6.1 build 7601 (Windows Server 2008 R2 Standard Edition Service Pack 1) i586
Database Version:      5.6.14
Database Collation:      utf8_general_ci
PHP Version:    5.3.13
Web Server:    Microsoft-IIS/7.5
WebServer to PHP Interface:    cgi-fcgi
Joomla! Version:    Joomla! 2.5.16 Stable [ Ember ] 06-November-2013 22:30 GMT
User Agent    Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

jk15060

  • Beginner
  • *
  • Posts: 6
Re: Can't update... Invalid Token, in store config
« Reply #3 on: November 21, 2013, 22:24:24 pm »
Every time I upgrade my client's VirtueMart extension, I have to disable Akeeba's System Restore Points, which has been suggested as a workaround here in the VM Forums.  Will VM address the "invalid token in store config" issue in its next release so that it works with, instead of against, other extensions like the Restore Points?

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 5893
  • VM3 ready to take off
    • VM2 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Can't update... Invalid Token, in store config
« Reply #4 on: December 02, 2013, 11:24:09 am »
We cant remove it. Akeeba is recognised as hacker. It should follow the rules and we wouldnt have any problem.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

bmw2182

  • Beginner
  • *
  • Posts: 47
Re: Can't update... Invalid Token, in store config
« Reply #5 on: December 06, 2013, 03:18:57 am »
I am trying to update virtuemart from 2.0.18a to virtuemart 2.0.24c.  When trying to do the automatic update it gives me the invalid token in store config.  In reading about that message it says to try to install it manually.  When I install it manually I get the following:
JFolder::create: Could not create directory
Warning: Failed to move file!
Unable to find install package


My tmp directory has full 777 access.

Please help!  What am I missing?

VirtueMart Forum

Re: Can't update... Invalid Token, in store config
« Reply #5 on: December 06, 2013, 03:18:57 am »