Author Topic: error at administrator/components/com_virtuemart/helpers/vmview.php on line 342  (Read 7072 times)

escapezone

  • Beginner
  • *
  • Posts: 24
Hello!

After upgrading from 2.0.22c to 2.0.24 i am getting this error at vm backend

Notice: Undefined index: el-GR in /var/www/vhosts/mysite.gr/sitefolder/administrator/components/com_virtuemart/helpers/vmview.php on line 342

Notice: Trying to get property of non-object in /var/www/vhosts/mysite.gr/sitefolder/administrator/components/com_virtuemart/helpers/vmview.php on line 342

Notice: Undefined index: el-GR in /var/www/vhosts/mysite.gr/sitefolder/administrator/components/com_virtuemart/helpers/vmview.php on line 342

Notice: Trying to get property of non-object in /var/www/vhosts/mysite.gr/sitefolder/administrator/components/com_virtuemart/helpers/vmview.php on line 342

Notice: Undefined index: el-GR in /var/www/vhosts/mysite.gr/sitefolder/administrator/components/com_virtuemart/helpers/vmview.php on line 342

Notice: Trying to get property of non-object in /var/www/vhosts/mysite.gr/sitefolder/administrator/components/com_virtuemart/helpers/vmview.php on line 342

Can you help me plz ?

If i replace that  file with the vmview.php from 2.0.22c the problem dissapears

Thank you!


Joomla 2.5.14
Virtuemart 2.0.24

alatak

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2047
    • alatak.net
Hello
Did you published the languages defined in Language manager > Content ?

escapezone

  • Beginner
  • *
  • Posts: 24
Hello alatak !

Thank you very much for your answer! Seems to be ok now :)
... but it is strange... in other eshop that i am running joomla 2.5.14 and vm 2.0.24 (upgraded from 2.0.22c) i don't have this problem and i don't have this language published at Language manager > Content and i don't run multilingual, just greek lang on my sites... Do you know why ?

Thank you!

alatak

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2047
    • alatak.net
hello

Quote
i am running joomla 2.5.14 and vm 2.0.24 (upgraded from 2.0.22c) i don't have this problem a
there must be something which is different in your config.
what did you have as Multilingual shop in the virtuemart configuration in both site?

escapezone

  • Beginner
  • *
  • Posts: 24
Hello Alatak!

I have only the  Greek Lang ...

See attach picture.

Thank you!

[attachment cleanup by admin]

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10070
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Maybe the system is using internally the english tables what happens, you use english here?
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

escapezone

  • Beginner
  • *
  • Posts: 24
Maybe the system is using internally the english tables what happens, you use english here?

Hello Milbo ! Thank you for your answer!

I am not using English ... only the Greek Lang...

p.barg

  • 3rd party VirtueMart Developer
  • Jr. Member
  • *
  • Posts: 166
    • Barg IT
Same problem with a German shop after upgrade to VM2.0.24 .... PHP notices showing, as that shop is still on a local dev server.
(@escapezone: you probably have different PHP settings in your different shops, one showing notices and the other doesn't)

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10070
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
What I meant is

Use english in your vm config. and in joomla greece.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

djygue

  • Beginner
  • *
  • Posts: 2
Hello, i have the same problem but i can't resolve it with your indication. Can you help me please ?
In joomla config, i have  in language manager
-in frontend : English and French, french is default
-in backend : English and French, french is default
- in content, i only have English wich is published.
In VM Config, in multilingual, i can have English and/or French. I choose one (English or French), or both, but
i always have the problem.
Have you an idea ?
Thank you.
Joomla 2.5.8
Virtuemart 2.0.24

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10070
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Hello
Did you published the languages defined in Language manager > Content ?

Please check the config here /administrator/index.php?option=com_languages&view=languages  tab content
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

djygue

  • Beginner
  • *
  • Posts: 2
OK, it's solved.
The problem was that i didn't know how to add french language in tab content. But there is no install to do, i just add a french with the add button.
Thank you.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10070
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Yes, from my point of view a bit stupid. I added fallback to the next version. So that you see an error, but it should still work.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/