Author Topic: Virtuemart 2.1 on joomla 3  (Read 117882 times)

Frank Beier

  • Beginner
  • *
  • Posts: 41
  • Do or Do Not, there is no try.
    • Ohio Web Design - Dynamic Webs, LLC
Re: Virtuemart 2.1 on joomla 3
« Reply #75 on: April 06, 2014, 16:45:01 pm »
I have found the same strict standards errors on a Joomla 2.5.14 test installation.  I have VM 2.1.1 installed and testing.  Here are the first few of hundreds of lines of errors:


Strict Standards: Non-static method SimplePie_Misc::fix_protocol() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 833

Strict Standards: Non-static method SimplePie_Misc::normalize_url() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 9287

Strict Standards: Non-static method SimplePie_Misc::parse_url() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 9288

Strict Standards: Non-static method SimplePie_Misc::parse_url() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 1542

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3749
  • using Matomo instead of Google Analytics
Re: Virtuemart 2.1 on joomla 3
« Reply #76 on: April 06, 2014, 17:33:18 pm »
The simplepie error is just the rss feed. If you clear the Joomla cache, the strict standards error should disappear.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

Frank Beier

  • Beginner
  • *
  • Posts: 41
  • Do or Do Not, there is no try.
    • Ohio Web Design - Dynamic Webs, LLC
Re: Virtuemart 2.1 on joomla 3
« Reply #77 on: April 06, 2014, 20:22:00 pm »
Cleared Cache and purged, no change in errors.   This is test site Joomla 2.5.14 and VM 2.1.1. 

These occur when launch Virtuemart Control Panel from the administrator.

First few lines of errors reported:

Strict Standards: Non-static method SimplePie_Misc::fix_protocol() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 833

Strict Standards: Non-static method SimplePie_Misc::normalize_url() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 9287

Strict Standards: Non-static method SimplePie_Misc::parse_url() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 9288

Strict Standards: Non-static method SimplePie_Misc::parse_url() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 1542

Strict Standards: Non-static method SimplePie_Misc::get_curl_version() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 7675

Strict Standards: Non-static method SimplePie_Misc::get_curl_version() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 7687

Strict Standards: Non-static method SimplePie_Misc::xml_encoding() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 1721

Strict Standards: Non-static method SimplePie_Misc::xml_encoding() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 1740

Strict Standards: Non-static method SimplePie_Misc::change_encoding() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 1759

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10451
  • VM4.0.7 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Virtuemart 2.1 on joomla 3
« Reply #78 on: April 06, 2014, 20:33:53 pm »
As already said before, we cannot remove this notice, it is part of the joomla library. It was "always" there.
The reason you see this is a wrong error reporting configuration.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Frank Beier

  • Beginner
  • *
  • Posts: 41
  • Do or Do Not, there is no try.
    • Ohio Web Design - Dynamic Webs, LLC
Re: Virtuemart 2.1 on joomla 3
« Reply #79 on: April 06, 2014, 20:41:53 pm »
I read another post that said if I upgrade to SimplePie1.3 this would eliminate these errors which are related to php version incompatibility.  Does VM 2.1.1 have SimplePie1.3 installed by default?  Let me know if I'm not understanding this correctly.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10451
  • VM4.0.7 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Virtuemart 2.1 on joomla 3
« Reply #80 on: April 07, 2014, 10:52:13 am »
No, we just use the simplepie of joomla. You see the error due the changed error handling in joomla 3.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Frank Beier

  • Beginner
  • *
  • Posts: 41
  • Do or Do Not, there is no try.
    • Ohio Web Design - Dynamic Webs, LLC
Re: Virtuemart 2.1 on joomla 3
« Reply #81 on: April 08, 2014, 03:05:53 am »
Ok - Sorry, I didn't see this was for Joomla 3. installation.  I'm running into the conflict in Joomla 2.5.14 and VM 2.1.1

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10451
  • VM4.0.7 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Virtuemart 2.1 on joomla 3
« Reply #82 on: April 08, 2014, 12:45:23 pm »
Then you use php5.4, same here, changed error reporting. I am going to release the vm2.9 soon. Actually the vm2.1 is quite outdated.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

fmvm

  • Beginner
  • *
  • Posts: 11
Re: Virtuemart 2.1 on joomla 3
« Reply #83 on: April 15, 2014, 11:07:26 am »
I am going to release the vm2.9 soon.

When exactly?

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10451
  • VM4.0.7 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Virtuemart 2.1 on joomla 3
« Reply #84 on: April 15, 2014, 13:06:34 pm »
today, tomorrow. You can see here a live test store http://vm2.rupostel.com/vm3test/component/virtuemart/
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

lipes

  • Full Member
  • ***
  • Posts: 720
Re: Virtuemart 2.1 on joomla 3
« Reply #85 on: April 17, 2014, 03:05:41 am »
 :D
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

fmvm

  • Beginner
  • *
  • Posts: 11
Re: Virtuemart 2.1 on joomla 3
« Reply #86 on: April 17, 2014, 11:07:37 am »
today, tomorrow.

today is "after tomorrow" but vm2.9 is still missing, I mean dev.virtuemart.net ...

if I'm now adding categories and products with vm2.9.7659 from rupostel.com and later would install (or update to) stable vm2.9 will my products be stored anyway, yes? your new release won't touch database?

Anirudh

  • Beginner
  • *
  • Posts: 25
Re: Virtuemart 2.1 on joomla 3
« Reply #87 on: April 19, 2014, 03:59:02 am »
today, tomorrow. You can see here a live test store http://vm2.rupostel.com/vm3test/component/virtuemart/

Unfortunately! I simply can't start a new project using Joomla 2.5 as migration is so painful and now that Joomla 3.3 is LTS(whatever) please try to aim the release by 23rd.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10451
  • VM4.0.7 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Virtuemart 2.1 on joomla 3
« Reply #88 on: April 23, 2014, 22:58:05 pm »
today, tomorrow.

today is "after tomorrow" but vm2.9 is still missing, I mean dev.virtuemart.net ...

if I'm now adding categories and products with vm2.9.7659 from rupostel.com and later would install (or update to) stable vm2.9 will my products be stored anyway, yes? your new release won't touch database?

Yes, there are no changes for the tables. We are atm just hunting the bugs left, the installer, a simple update and more bootstrap
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

AH

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3510
  • VirtueMart Version: 3.8.9
Re: Virtuemart 2.1 on joomla 3
« Reply #89 on: April 23, 2014, 23:49:10 pm »
Will there be the ability to NOT use bootstrap and reduce site load times?
Regards
A

Joomla 3.9.27
php 7.4