Author Topic: Virtuemart 2.1 on joomla 3  (Read 116163 times)

Snake 60

  • Beginner
  • *
  • Posts: 12
    • Snake 60 BLOG
  • VirtueMart Version: 2.0.22a
Re: Virtuemart 2.1 on joomla 3
« Reply #60 on: January 31, 2014, 17:48:09 pm »
Hi! I am try to install last version of VM2.1 posted by Milbo and during installation AIO recive 2 this errors
Quote
( ! ) SCREAM: Error suppression ignored for
( ! ) Warning: require(C:\wamp\www\1st-site/administrator\components\com_virtuemart\helpers\config.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in C:\wamp\www\1st-site\tmp\install_52ebd0dc38334\script.vmallinone.php on line 396
Call Stack
#   Time   Memory   Function   Location
1   0.0006   657928   {main}( )   ..\index.php:0
2   0.1736   9545688   JAdministrator->dispatch( )   ..\index.php:46
3   0.1737   9547360   JComponentHelper::renderComponent( )   ..\application.php:153
4   0.1800   9605000   JComponentHelper::executeComponent( )   ..\helper.php:351
5   0.1804   9652728   require_once( 'C:\wamp\www\1st-site\administrator\components\com_installer\installer.php' )   ..\helper.php:383
6   0.1843   10002528   JController->execute( )   ..\installer.php:18
7   0.1843   10002608   InstallerControllerInstall->install( )   ..\controller.php:761
8   0.1889   10489328   InstallerModelInstall->install( )   ..\install.php:29
9   1.3805   11365336   JInstaller->install( )   ..\install.php:105
10   1.3912   11975296   JInstallerComponent->install( )   ..\installer.php:472
11   1.3916   11976744   JInstallerComponent->update( )   ..\component.php:219
12   21.3337   13520576   com_virtuemart_allinoneInstallerScript->postflight( )   ..\component.php:1076
13   21.3337   13520576   com_virtuemart_allinoneInstallerScript->vmInstall( )   ..\script.vmallinone.php:45
14   21.3364   13521728   com_virtuemart_allinoneInstallerScript->installPlugin( )   ..\script.vmallinone.php:61
15   21.3440   13527472   com_virtuemart_allinoneInstallerScript->updatePluginTable( )   ..\script.vmallinone.php:345

( ! ) SCREAM: Error suppression ignored for
( ! ) Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required 'C:\wamp\www\1st-site/administrator\components\com_virtuemart\helpers\config.php' (include_path='.;C:\php\pear') in C:\wamp\www\1st-site\tmp\install_52ebd0dc38334\script.vmallinone.php on line 396
Call Stack
#   Time   Memory   Function   Location
1   0.0006   657928   {main}( )   ..\index.php:0
2   0.1736   9545688   JAdministrator->dispatch( )   ..\index.php:46
3   0.1737   9547360   JComponentHelper::renderComponent( )   ..\application.php:153
4   0.1800   9605000   JComponentHelper::executeComponent( )   ..\helper.php:351
5   0.1804   9652728   require_once( 'C:\wamp\www\1st-site\administrator\components\com_installer\installer.php' )   ..\helper.php:383
6   0.1843   10002528   JController->execute( )   ..\installer.php:18
7   0.1843   10002608   InstallerControllerInstall->install( )   ..\controller.php:761
8   0.1889   10489328   InstallerModelInstall->install( )   ..\install.php:29
9   1.3805   11365336   JInstaller->install( )   ..\install.php:105
10   1.3912   11975296   JInstallerComponent->install( )   ..\installer.php:472
11   1.3916   11976744   JInstallerComponent->update( )   ..\component.php:219
12   21.3337   13520576   com_virtuemart_allinoneInstallerScript->postflight( )   ..\component.php:1076
13   21.3337   13520576   com_virtuemart_allinoneInstallerScript->vmInstall( )   ..\script.vmallinone.php:45
14   21.3364   13521728   com_virtuemart_allinoneInstallerScript->installPlugin( )   ..\script.vmallinone.php:61
15   21.3440   13527472   com_virtuemart_allinoneInstallerScript->updatePluginTable( )   ..\script.vmallinone.php:345
How to fix this?
I am try install on my test server on Joomla! 2.5.17. 1st package(distributive of Virtuemart) installed correctly...

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10283
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Virtuemart 2.1 on joomla 3
« Reply #61 on: January 31, 2014, 20:29:27 pm »

Warning: Missing argument 2 for plgVmCustomTextinput::plgVmDeclarePluginParamsCustom() in C:\xampp\htdocs\cms\plugins\vmcustom\textinput\textinput.php on line 141

.....


You did not install the latest AIO. Just ignore the simplepie error. It is just the rss feed on the first page.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

CE WebDesign München

  • Jr. Member
  • **
  • Posts: 112
  • CE WebDesign München
    • CE WebDesign München
Re: Virtuemart 2.1 on joomla 3
« Reply #62 on: February 01, 2014, 09:36:57 am »
thanks, installed latest AIO, now only one message in FE:

Fatal error: Class 'JElement' not found in C:\xampp\htdocs\cms\plugins\vmpayment\klarna\klarna\elements\klarnamultilist.php on line 24

i will disable klarna plugin then,

best regards and sorry for forgetting AIO
CE WebDesign München: https://ce-webdesign.de | Websites, eCommerce WebShops | Responsive Design | SEO

CE WebDesign München

  • Jr. Member
  • **
  • Posts: 112
  • CE WebDesign München
    • CE WebDesign München
Re: Virtuemart 2.1 on joomla 3
« Reply #63 on: February 01, 2014, 10:53:38 am »
ok, after disable klarna plugin, FE looks fine. (disabled extention VM-Youtube-Plugin)

in BE, can't switch language, when editing product : message "invalid Token"

CE WebDesign München: https://ce-webdesign.de | Websites, eCommerce WebShops | Responsive Design | SEO

stAn99

  • Contributing Developer
  • Jr. Member
  • *
  • Posts: 99
    • One Page Checkout for Virtuemart 2
Re: Virtuemart 2.1 on joomla 3
« Reply #64 on: February 18, 2014, 16:36:00 pm »
Dear Friends, for testing purposes we had release an FTP Virtuemart 3 on Joomla 3.2 installation package and VM3 installation package that you can check here:

http://www.rupostel.com/joomla/hacks/virtuemart-for-joomla-3

It has a modified Live Update funtionality that points to our build service that creates live update packages daily from the latest VM SVN (trunk 2.1)

For support of the installer, please contact us direct at our forums here:
http://www.rupostel.com/phpBB3/viewforum.php?f=4&sid=528b31c58e26207f38edf1cfe0c138a8

For Virtuemart related issues (other then installation or live update) please use this forum.

Best Regards,
Stan, RuposTel.com
----
RuposTel.com
www.rupostel.com
Your customized checkout solution for Virtuemart

CE WebDesign München

  • Jr. Member
  • **
  • Posts: 112
  • CE WebDesign München
    • CE WebDesign München
Re: Virtuemart 2.1 on joomla 3
« Reply #65 on: February 22, 2014, 11:30:21 am »
hi, testet update vm2.0.26d to 2.5.0 + aio! (j2.5.18)

everything fine, great! all my issues (here in this thread) are solved, thank you very much!!!


just this warning (maybe just due to my local xampp1.7.3, php5.3.1 ?):

Warning: fopen() [function.fopen]: php_network_getaddresses: getaddrinfo failed: Der angegebene Host ist unbekannt. in C:\xampp\htdocs\cms\administrator\components\com_virtuemart\helpers\connection.php on line 173

Warning: fopen(http://www.ecb.europa.eu:80/stats/eurofxref/eurofxref-daily.xml) [function.fopen]: failed to open stream: php_network_getaddresses: getaddrinfo failed: Der angegebene Host ist unbekannt. in C:\xampp\htdocs\cms\administrator\components\com_virtuemart\helpers\connection.php on line 173


for whishlist:
- cloning of products including translated describtions
- sorting of related products per drag'n'drop

best regards
CE WebDesign München: https://ce-webdesign.de | Websites, eCommerce WebShops | Responsive Design | SEO

colmagoo

  • Beginner
  • *
  • Posts: 9
Re: Virtuemart 2.1 on joomla 3
« Reply #66 on: March 05, 2014, 01:14:26 am »
sorry to digress from the thread a little bit. I have built a site in Joomla 3.1.5 and now the customer wants ecommerce. I'm not aware of a 3 to 2.5 downgrade procedure, so - with this in mind - I'd be interested to voice your opinions on whether it is worth me taking the risk with this latest test version of Virtuemart. I do know a little php and what the customer wants is very simple in terms of vm functionality (as long as products can be added to cart & checkout ok) but I dont want to be spending days debugging. I dont use many plugins but those I do, I'm guessing thats where the problems may show up?

Any advice much appreciated. Thanks

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10283
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Virtuemart 2.1 on joomla 3
« Reply #67 on: March 05, 2014, 22:58:57 pm »
Yepp, I would try it. Try next version in a week, the svn is atm a bit buggy (more than the releases at dev.virtuemart.net). If you find problems, then write them in an extra post here (do not use this thread to report bugs).
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

colmagoo

  • Beginner
  • *
  • Posts: 9
Re: Virtuemart 2.1 on joomla 3
« Reply #68 on: March 06, 2014, 02:02:35 am »
thanks Milbo

lipes

  • Full Member
  • ***
  • Posts: 720
Re: Virtuemart 2.1 on joomla 3
« Reply #69 on: March 08, 2014, 22:03:01 pm »
VM 2.1 (test) file will works on Joomla 3.x ?  Does someone got a calendar prevision date to realease the stable file of VM 2.x to Joomla 3.x ?
I love the Joomla 3 admin dashboard seems like wordpress

Request to Dev Team: It's posible to have a nice feature in VM (please?)
I would like to have one fieldset (in Product area) to write the EAN code of the product. (Just a new column in sql dB...)
For example, in my father website i use Sku to write the product model name and product name (brand name + model name)
So it misses the search data of the product EAN and users could also use that field to others like ISBN or UPC if they dont use or need the EAN ...
is just increment one simple fieldset and it make all the difference to get a better stronger faster ecommerce system...

thanks,
best regards
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28324
  • Always on vacation
    • Jenkin Hill Internet
Re: Virtuemart 2.1 on joomla 3
« Reply #70 on: March 08, 2014, 23:24:07 pm »
EAN is included in the next version - try 2.5.2 on J2.5.x   

Joomla release of J3.5 has been delayed, possibly up to 6 months.  For some info see http://forum.virtuemart.net/index.php?topic=122641.msg418595#msg418595
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart  4.0.2 10661 on Joomla 3.10.9 PHP 7.4.29

lipes

  • Full Member
  • ***
  • Posts: 720
Re: Virtuemart 2.1 on joomla 3
« Reply #71 on: March 09, 2014, 00:37:31 am »
That's the kind of message with good and bad news (choose the first) ... eheheh :D
lets wait for J3.5 release..

Thanks jenkinhill
Best regards
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

kissmypwetyyy

  • Beginner
  • *
  • Posts: 1
Re: Virtuemart 2.1 on joomla 3
« Reply #72 on: March 09, 2014, 08:28:35 am »
hi is it possible to notify admin inside joomla when someone orders products (not using emails)

lipes

  • Full Member
  • ***
  • Posts: 720
Re: Virtuemart 2.1 on joomla 3
« Reply #73 on: March 09, 2014, 21:08:29 pm »
kissmypwetyyy, is that question related with this topic? :)
(next time choose the correct area to insert a question, please!)

You could see when someone buy/request a product inside Joomla/Virtuemart Admin, you dont need email to check it.
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

Frank Beier

  • Beginner
  • *
  • Posts: 41
  • Do or Do Not, there is no try.
    • Ohio Web Design - Dynamic Webs, LLC
Re: Virtuemart 2.1 on joomla 3
« Reply #74 on: April 06, 2014, 15:55:57 pm »
I have found the same strict standards errors on a Joomla 2.5.14 test installation.  I have VM 2.1.1 installed and testing.  Here are the first few of hundreds of lines of errors:


Strict Standards: Non-static method SimplePie_Misc::fix_protocol() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 833

Strict Standards: Non-static method SimplePie_Misc::normalize_url() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 9287

Strict Standards: Non-static method SimplePie_Misc::parse_url() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 9288

Strict Standards: Non-static method SimplePie_Misc::parse_url() should not be called statically, assuming $this from incompatible context in /home/joomlado/public_html/libraries/simplepie/simplepie.php on line 1542