Author Topic: Changing Auth.net to work for Cybersource  (Read 15977 times)

digical

  • Jr. Member
  • **
  • Posts: 72
Re: Changing Auth.net to work for Cybersource
« Reply #15 on: October 27, 2006, 20:29:01 pm »
On the two pull-down menus where I select "Pending", "Confirmed", there is no tag lines like the others.  Did I mess up my english.php hack?

- rg


mrosile

  • Beginner
  • *
  • Posts: 17
Re: Changing Auth.net to work for Cybersource
« Reply #16 on: November 07, 2006, 21:07:38 pm »
Update on the CyberSource payment module!
v1.1 Released 11/7/2006

WHATS NEW:
   * Added additional CyberSource methods
      - Void Captures
      - Refund Payment
   * More detailed debug messages returned from the
     "handleError" function
   * AUTH_ONLY and AUTH_CAPTURE are both valid responses to CS_TYPE
      - AUTH_ONLY will only authorize the transaction
      - AUTH_CAPTURE will attempt to capture payment after performing
        authorization
   * REVIEW status for authorizations
      - If an authorization is marked as 'review', the order *should*
        still be recorded in VirtueMart along with the reason which
        will be displayed under the "Payment Log"
   * More detailed Payment log for each CyberSource service
   * No more error messages will be displayed when adding this payment
     module.

[attachment cleanup by admin]

digical

  • Jr. Member
  • **
  • Posts: 72
Re: Changing Auth.net to work for Cybersource
« Reply #17 on: December 01, 2006, 20:40:57 pm »
Hi, 

I just downloaded your update.  There are several problems with it on my installation:

1. There's no place to put my cybersource login id on the config screen
2. The field labels for verified status & invalid status are missing on the config page
3. This version says that the cybs.ini file path is invalid on this new version.  If I restore it to the prior version, it doesn't show a path error.

- rg


Justin

  • Beginner
  • *
  • Posts: 27
    • ASGvis, LLC
Re: Changing Auth.net to work for Cybersource
« Reply #18 on: January 10, 2007, 04:33:30 am »
Hello,

I'm also finding an error with the index used for $this->reply it is using ccAuthReply_reasonCode and it seems to need reasonCode.

If this is the case let me know so i can go ahead and edit the code I have accordingly. btw I'm using cybersource api 5.0.1
Programmer
ASGVIS, LLC
921 E. Fort Avenue Suite 300
Baltimore, MD 21230

+1 410-468-0777

digical

  • Jr. Member
  • **
  • Posts: 72
Re: Changing Auth.net to work for Cybersource
« Reply #19 on: January 14, 2007, 06:13:01 am »
did you get a chance to fix these bugs?  are you seeing the bugs that I see?