Author Topic: Cart not update when add/delete products  (Read 3958 times)

Beni

  • Beginner
  • *
  • Posts: 20
Cart not update when add/delete products
« on: August 31, 2013, 16:56:13 pm »
Hi,
I have a demo webshop with sampledata. (J!2.5.14 VM2.0.22b)
I only change with template override the category short text character count and display in category view "add to cart" button with qty.

If I add to cart product, (in category or productdetails view) and click in a modal popup "go a cart" the cart show with empty. Press F5 and all OK.
If I delete product from cart, not hide only If I press F5... :(
Why?

I search a lot of time in forum and Google but not find the answer... I have Jquery Easy Plugin with default options, DJIMageslider and JCE editor with JCEMEdiaBox.
Someone can help me?
URL:www.demovm.butor-vasalat.hu/webshop/

Thanks a lot: Beni

Maxim Pishnyak

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2657
Re: Cart not update when add/delete products
« Reply #1 on: August 31, 2013, 19:10:46 pm »
I have Jquery Easy Plugin with default options, DJIMageslider and JCE editor with JCEMEdiaBox.
You also use Jbetolo, which you don't know how to configure. Get rid of Jbetolo then.

Beni

  • Beginner
  • *
  • Posts: 20
Re: Cart not update when add/delete products
« Reply #2 on: August 31, 2013, 19:25:08 pm »
I disabled the Jbetolo, but the error is same...

Maxim Pishnyak

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2657
Re: Cart not update when add/delete products
« Reply #3 on: August 31, 2013, 20:01:47 pm »
Clean cache of browser and recheck. Jbetolo was able to freeze cache browser.

Beni

  • Beginner
  • *
  • Posts: 20
Re: Cart not update when add/delete products
« Reply #4 on: August 31, 2013, 20:18:06 pm »
A tried this, but not solved the problem...
If I clear the cache the first product is adding the cart well, but then a same problem...

Maxim Pishnyak

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2657
Re: Cart not update when add/delete products
« Reply #5 on: August 31, 2013, 22:34:32 pm »
A tried this, but not solved the problem...
If I clear the cache the first product is adding the cart well, but then a same problem...
Who was 1st and who was 2nd?

Beni

  • Beginner
  • *
  • Posts: 20
Re: Cart not update when add/delete products
« Reply #6 on: September 02, 2013, 15:19:20 pm »
I not well formulated...
1. clear cache
2. the cart is empty
3. add one product to the cart
4. the cart show this product - all right....
5. try delete this product - not show the delete, only if I update the page
6. add another product to the cart - not show this is new product, only if I update the page

This is a sad story. If you need, I can send admin user and password datas.
Beni

Maxim Pishnyak

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2657
Re: Cart not update when add/delete products
« Reply #7 on: September 02, 2013, 17:32:07 pm »
components\com_virtuemart\assets\js\vmprices.js was turned off in your web shop. Check VM config or check other 3rd party Joomla extension on your web site.

Beni

  • Beginner
  • *
  • Posts: 20
Re: Cart not update when add/delete products
« Reply #8 on: September 03, 2013, 16:50:55 pm »
Dear Maxim, Thanks your help!
I deleted VM tables and reinstall the original VM with sample data.
I disabled all 3rd party plugins and set the default template. (beez_2)
And now loaded the vmprices.js, but the cart isn't work! :(
Beni

If you need, I can send the superadmin access - this is only a demo site.

Maxim Pishnyak

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2657
Re: Cart not update when add/delete products
« Reply #9 on: September 04, 2013, 11:19:48 am »
Everything work fine. Clear your browser cache or check in another browser.

Beni

  • Beginner
  • *
  • Posts: 20
Re: Cart not update when add/delete products
« Reply #10 on: September 04, 2013, 13:46:32 pm »
YES. I fixed my problem at today morning.
My htaccess blocked the page update...
Thank you very much your help!
Beni

Beni

  • Beginner
  • *
  • Posts: 20
Re: Cart not update when add/delete products
« Reply #11 on: September 04, 2013, 15:59:52 pm »
This code blocked the VM cart update in .htaccess :
<IfModule mod_expires.c>
...
ExpiresDefault A5184000
ExpiresByType application/x-javascript A5184000
ExpiresByType application/javascript A5184000
ExpiresByType text/javascript A5184000
ExpiresByType text/html A6000
</IfModule>

Maxim Pishnyak

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2657
Re: Cart not update when add/delete products
« Reply #12 on: September 04, 2013, 21:57:43 pm »
Nice attempt of trying to speed up your web site loading time. You are on the right way. Keep trying.

Cotec

  • Beginner
  • *
  • Posts: 20
Re: Cart not update when add/delete products
« Reply #13 on: March 09, 2014, 20:38:09 pm »
This did not seem to work for me. I am still not having virtuemart cart work.

Here is a link: http://subaqueousmusic.com/sample-libraries/glitch-the-machine-detail

Thanks everyone for all the help. Love the community here.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27465
  • Always on vacation
    • Jenkin Hill Internet
Re: Cart not update when add/delete products
« Reply #14 on: March 09, 2014, 21:23:35 pm »
@Cotec I'm surprised that anything works. Not only are you loading a version of jQuery that is incompatible with VirtueMart, but also 3 different versions of jquery.noConflict.js

On a product page in Firebug on Firefox the reported console errors are:

TypeError: $.noConflict is not a function
   

$.noConflict();

latin-...-detail (line 1165)
[object Object] method not exists!
   

else return console.error(arg0.toString()+" method not exists!");

21
improv...ogin.js (line 41)
"CSS Usage: initializing extensions"
"NetworkError: 404 Not Found - http://www.subaqueousmusic.com/components/com_yagendooproductmanager/themes/yag_blueberry_etheme/assets/yagImages/template_style/style_2/dropshadow_left_large.png"
dropsh...rge.png
"NetworkError: 404 Not Found - http://www.subaqueousmusic.com/components/com_yagendooproductmanager/themes/yag_blueberry_etheme/assets/yagImages/template_style/style_2/dropshadow_right_large.png"
dropsh...rge.png
"NetworkError: 404 Not Found - http://www.subaqueousmusic.com/components/com_yagendooproductmanager/themes/yag_blueberry_etheme/assets/yagImages/template_style/style_2/dropshadow_left_small.png"
dropsh...all.png
"NetworkError: 404 Not Found - http://www.subaqueousmusic.com/components/com_yagendooproductmanager/themes/yag_blueberry_etheme/assets/yagImages/template_style/style_2/dropshadow_right_small.png"
dropsh...all.png
20:12:18.885 CSI/tbsd_
20:12:18.886 CSI/_tbnd
ReferenceError: Class is not defined
   

...rySmartLoad({'offset': {'x': 200, 'y': 200}, 'placeholder': '/templates/rt_ionos...

index....mponent (line 64)
TypeError: Function.attempt is not a function
   

...turn e;});})();o.Features.xhr=!!(o.Request);var j=(Function.attempt(function(){r...

browse...ines.js (line 10)
TypeError: window.addEvent is not a function
   

...rySmartLoad({'offset': {'x': 200, 'y': 200}, 'placeholder': '/templates/rt_ionos...

index....mponent (line 64)
"NetworkError: 404 Not Found - http://www.subaqueousmusic.com/components/com_yagendooproductmanager/themes/yag_blueberry_etheme/assets/yagImages/template_style/style_2/close_squeezebox.png"
close_...box.png

______________________________________

You are using an RT template which is not VM friendly and have some other bells & whistles that makes an unstable environment.  I think you should look at debugging.
http://forum.virtuemart.net/index.php?topic=119638.0
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.10 PHP 7.0.33
Testing VM 3.5.0.10097 on Joomla 3.9.10