Author Topic: Display modal popup upon 'Add to cart' not working  (Read 41674 times)

nbirrell

  • Beginner
  • *
  • Posts: 23
Display modal popup upon 'Add to cart' not working
« on: August 03, 2013, 03:01:23 am »
Hi, I am having an issue with the modal popup after adding an item to cart and also with my cart still showing up as having 0 items in it even after adding something to cart.

I have the 'Display modal popup upon 'Add to cart'' option checked in my shop configuration settings.

Any help with how i can get this modal popup to show and how my cart can show items in it when i add something to it instead of remaining at 0 items?

I am using Joomla! 2.5.4

Thanks

z-analysts

  • Jr. Member
  • **
  • Posts: 162
Re: Display modal popup upon 'Add to cart' not working
« Reply #1 on: August 03, 2013, 04:13:52 am »
Hello,

Please indicate which version of VirtueMart you are using and what version of PHP you have. Also if you are still using Joomla 2.5.4 you really should upgrade to 2.5.14.

I am having this issue with VM 2.0.22a.

Thanks

Maxim Pishnyak

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2657
Re: Display modal popup upon 'Add to cart' not working
« Reply #2 on: August 03, 2013, 12:44:35 pm »
Link?

z-analysts

  • Jr. Member
  • **
  • Posts: 162
Re: Display modal popup upon 'Add to cart' not working
« Reply #3 on: August 04, 2013, 17:29:23 pm »
http://zclientdev.net/stardev

vm - 2.0.22a
php - 5.3.16
joomla - 2.5.14

Maxim Pishnyak

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2657
Re: Display modal popup upon 'Add to cart' not working
« Reply #4 on: August 05, 2013, 12:21:35 pm »
I am having this issue with VM 2.0.22a.
And I can't see this issue on your web site. Direct link to a specific page, name of your browser, screen shot, please?

z-analysts

  • Jr. Member
  • **
  • Posts: 162
Re: Display modal popup upon 'Add to cart' not working
« Reply #5 on: August 05, 2013, 21:54:04 pm »
Hello Maxim,

A little bit of creativity would have answered your questions. What you need to do is click on the Shop drop down menu to select a category, then from the category page select a product to add to your cart. At that point you will notice that there is no modal popup. If you also click on the YOUR CART image on the left hand side of the screen you will see that the cart status indicates it is empty however if you click to display the cart it shows the item that was just added.

I am using Chrome as my browser on Windows 7.

Please let me know if you need more information.


Maxim Pishnyak

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2657
Re: Display modal popup upon 'Add to cart' not working
« Reply #6 on: August 06, 2013, 13:29:29 pm »
A little bit of creativity would have answered your questions.
Nice poke  :), but why so 'much aggression'  ;) ? I was enough creative before you gave me your directions. And my Firefox was able to add your product.

Burn Google Chrome everybody!

z-analysts

  • Jr. Member
  • **
  • Posts: 162
Re: Display modal popup upon 'Add to cart' not working
« Reply #7 on: August 06, 2013, 16:44:15 pm »
OK, so if it works in Firefox but not Chrome that is a problem. What changed in 22a that caused the regression? The modal popup works fine in 20b?

Maxim Pishnyak

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2657
Re: Display modal popup upon 'Add to cart' not working
« Reply #8 on: August 06, 2013, 19:35:54 pm »
Firebug?

ataman79

  • Beginner
  • *
  • Posts: 12

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27432
  • Always on vacation
    • Jenkin Hill Internet
Re: Display modal popup upon 'Add to cart' not working
« Reply #10 on: August 14, 2013, 08:46:31 am »
ataman it works fine for me in Chrome Version 28.0.1500.95 m
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.8 PHP 7.0.33
Testing VM .3.6.0.10075 on Joomla 3.9.8

ataman79

  • Beginner
  • *
  • Posts: 12
Re: Display modal popup upon 'Add to cart' not working
« Reply #11 on: August 14, 2013, 08:46:41 am »
Hi I have the same problem  - in Chrome the pop up is not showing.

My Joomla is 2.5.14, PHP 5.3.24

Here is the site: http://norbekov.bg/%D0%B7%D0%B0%D0%BF%D0%B8%D1%88%D0%B8-%D1%81%D0%B5-%D0%B7%D0%B0-%D1%83%D1%87%D0%B5%D0%B1%D0%BD%D0%BE-%D0%BE%D0%B7%D0%B4%D1%80%D0%B0%D0%B2%D0%B8%D1%82%D0%B5%D0%BB%D0%B5%D0%BD-%D1%81%D0%B5%D0%BC%D0%B8%D0%BD%D0%B0%D1%80-%D0%B2%D1%82%D0%BE%D1%80%D0%BE-%D0%BD%D0%B8%D0%B2%D0%BE

Can someone help with a solution ?

Thank you in advance

So, very strange. Now it works under chrome ???
I actualize the VM plugin table 2 times - and seems to work now. You can find it Joomla under Components->virtuemart-aio

Can you try the same and share the results ?

ataman79

  • Beginner
  • *
  • Posts: 12
Re: Display modal popup upon 'Add to cart' not working
« Reply #12 on: August 14, 2013, 08:47:45 am »
@jenkinhill
yes , now it works - as I wrote in my upper post. Hope it will help others too

z-analysts

  • Jr. Member
  • **
  • Posts: 162
Re: Display modal popup upon 'Add to cart' not working
« Reply #13 on: August 14, 2013, 17:58:19 pm »
@jenkinhill
yes , now it works - as I wrote in my upper post. Hope it will help others too

Thanks, ataman79! That worked for me as well.

amymattian

  • Jr. Member
  • **
  • Posts: 143
Re: Display modal popup upon 'Add to cart' not working
« Reply #14 on: September 11, 2013, 16:19:21 pm »
Having the same problem on the category-page but not on the product page:
http://shamaanirumpu.net/rumpu-ukon%20puoti/fi/nayttaa-etusivun/shamaanirummut

I have updated for 2.0.22c version both the VM2 and the AIO. But no change. This issue is at least with Chrome and Firefox so not a browser issue (since it does work fine on the product page). Also when clicking Add to cart on the category-page the item is not moved directly to the cart in the upper-corner of the site. Only when moving forward the upper-cart gets updated.

What else can be causing this?

In the middle of making the site multilingual, but quite there yet... having some issues regarding that too...  :(

- Anne


p.s. on this category page it does not work:
http://shamaanirumpu.net/rumpu-ukon%20puoti/fi/nayttaa-etusivun/shamaanirummut