Author Topic: vmError: You are not an administrator or the correct vendor, storing of product  (Read 2924 times)

brsi

  • Beginner
  • *
  • Posts: 12
Hi,
Since V 2.0.22 (on Joomla 2.5.11), I receive above message after entering about 15 new products in VM (so no config change involved); there is no child product involved either (see other topic with same subject for that issue). Editing of exisitng product remains possible
Is there some limitation to entries somewhere.
Thanks.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10087
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
VirtueMart has no artificial limits, only by database and so. The reason must be different. Please update to vm2.0.22a. Then you should check if your vendor is correctly set.

I think this FAQ should help http://forum.virtuemart.net/index.php?topic=99353.0 At best read it first completly
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

brsi

  • Beginner
  • *
  • Posts: 12
Hi and thanks for the prompt reply; it seems that the problem is linked with the auto generated product alias, for product with similar names; if I understand correctly, alias for the first entry is same as product name, than for there is a time stamp (date) added; adding twice a product with same name on a same date  then leads to this error. I suppose one has to manually change the alias to avoid this?
Thanks again.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28021
  • Always on vacation
    • Jenkin Hill Internet
I suppose one has to manually change the alias to avoid this?

That is advisable anyway for SEO purposes.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.7 10374 on Joomla 3.9.24 PHP 7.4.12