Author Topic: Product image link to external server  (Read 7648 times)

castart

  • Guest
Product image link to external server
« on: April 12, 2013, 22:21:45 pm »
Joomla 2.5.9 VM 2.0.20b

How can a product image link to an image on an external server be realised?
In Virtuemart 2.0 it seems not possible anymore. Only image files from images/stories/virtuemart/product/ can be linked.

Do I have to import the full url to an external image in the product table fields file_url  and file_url_thumb?


Cast-Art

K&K media production

  • VirtueMart Developer Team
  • Global Moderator
  • Full Member
  • *
  • Posts: 838
  • VirtueMart Version: VM3 on J3
Re: Product image link to external server
« Reply #1 on: April 14, 2013, 02:56:01 am »
simple add the path to your image in the fields for "Used url" and "Used thumb url"

castart

  • Guest
Re: Product image link to external server
« Reply #2 on: April 14, 2013, 08:36:08 am »
Now that was easy.
I was confused because I couldn't delete the standard path.
But when I filled in the complete url http://www...... etc) like you said the path was overruled.


Thanks

castart

  • Guest
Re: Product image link to external server
« Reply #3 on: April 15, 2013, 10:21:07 am »
Still there is a problem

I imported a .csv file with product data with CSVI.
The file contains filled file_url and file_url_thumb fields but the product-media table is not updated.

Cast-Art


K&K media production

  • VirtueMart Developer Team
  • Global Moderator
  • Full Member
  • *
  • Posts: 838
  • VirtueMart Version: VM3 on J3
Re: Product image link to external server
« Reply #4 on: April 15, 2013, 11:00:59 am »
on database?

maybe your CSVI settings are not correct

look to the CSVI forum
http://www.csvimproved.com/forum/index?view=category&layout=list

castart

  • Guest
Re: Product image link to external server
« Reply #5 on: April 23, 2013, 09:01:09 am »
1.When I use CSVI and Process image switched on, a record is inserted in the virtuemart-medias table with the external url in the file_url field.
But no virtuemart-product-media record is inserted.

2.When I insert the records by using a standard noimage and then change the file_url field manually in an external file url
the result in the productpage in the frontend looks like this:

<div class="main-image">
<a href="http://www.insulindedenhaag.nl/2013/http://www.cast-art.nl/images/schilderijen_galeries/nieuw/2012_cocacola_DSC_4198.jpg" rel="vm-additional-images" title="noimage2.gif"><img alt="noimage2.gif" src="http://www.cast-art.nl/images/schilderijen_galeries/nieuw/2012_cocacola_DSC_4198.jpg"></img></a>
<div class="clear">
</div></div>

The a href contains a predefined path and the file_url is attached to it.

Do you have any other suggestion.
I posted his question on a few other forums and this weekend I asked the question to the "Joomla Doctor" during the Joomla days,
but nobody seems to know.

 



 

K&K media production

  • VirtueMart Developer Team
  • Global Moderator
  • Full Member
  • *
  • Posts: 838
  • VirtueMart Version: VM3 on J3
Re: Product image link to external server
« Reply #6 on: April 23, 2013, 13:04:58 pm »
1:

You musst assign the image to your product in CSVI. If you only import the images, CSVI insert it only in the medias table.

2:

OK this is a small bug. I've fixed it for the next version. You can use the attached file and copy it to

administrator/components/com_virtuemart/helpers/  (unzip the file first)

[attachment cleanup by admin]

castart

  • Guest
Re: Product image link to external server
« Reply #7 on: May 01, 2013, 15:18:40 pm »
1. Do you mean that in a product import csv file record the file_url and file_url_thumb fields must be present?

I tried that (csvi image process switch on) but then no virtuemart_product_media records is inserted

2. Works fine . Thanks

K&K media production

  • VirtueMart Developer Team
  • Global Moderator
  • Full Member
  • *
  • Posts: 838
  • VirtueMart Version: VM3 on J3
Re: Product image link to external server
« Reply #8 on: May 01, 2013, 15:26:42 pm »
I think you should ask in the csvi forum how csvi handle the product import with external images

naldjb

  • Beginner
  • *
  • Posts: 28
  • Skype Name: nald.jb
Re: Product image link to external server
« Reply #9 on: June 12, 2013, 20:54:31 pm »
Hi I got this to work for me with external image url link..

I use the Example VirtueMart Product import,

--File option tab
Auto detect delimiters = yes
Use headers/nodes as configuration= yes

--Fields
Remove all, nothing should be there

--Options
doesn't really matter what you have there

--Image
----General Options
Process images = yes
Create image name = yes
image name = product SKU "if you use the product name and your product name has white space it will messup the image url,, like if your product name is "product test" the image name will be "product test.jpg" and browsers can't read white space(%20).. so i would advice to use the product sku
image format, and Change case = it depends on you anything would be fine
-----Full image options
Keep original file = no
Image name format = no
Save images on server = yes
Resize large image = yes
width and height = your choice

--Path
images/stories/virtuemart/product/

here's the output http://testserver.websitedesignparramatta.com.au/index.php?option=com_virtuemart&view=productdetails&virtuemart_product_id=38#prettyPhoto

[attachment cleanup by admin]

castart

  • Guest
Re: Product image link to external server
« Reply #10 on: June 13, 2013, 09:05:01 am »
I tested  1 csv record containing a product_sku, file_url and file_url_thumb field. (files attached)

In CSVI :

Process image - yes
Create image name - yes
Save images on server - yes
Automatic thumbnail creation - yes
Path - images/stories/virtuemart/product/

The result in Virtuemart:
In the backend

    In images/stories/virtuemart/product/ a file was stored 01-11-09-test.jpg
    In images/stories/virtuemart/product/resized no file ws stored


In the frontend

    A thumb is shown but the url looks wrong
    <img src="/2013/images/stories/virtuemart/product/http://www.importa.nl/~images/120_025ANT.JPG" alt="01-11-09-test" class="browseProductImage" />
    A full image is shown.

The only question now is, why was the thumbnail not stored and why was it displayed in spite of that?

The thumbnail was being stored as :
/var/www/html/2013/images/stories/virtuemart/product/http://www.importa.nl/~images/120_025ANT.JPG
 that is an incorrect name.

CSVI support comment:

Since you are letting CSVI create a thumbnail I would suggest to leave the file_url_thumb empty so CSVI will create the thumbnail from the larger image you saved on the server.

Kind regards,

That works!

[attachment cleanup by admin]

zac

  • Beginner
  • *
  • Posts: 5
Re: Product image link to external server
« Reply #11 on: October 14, 2013, 06:42:38 am »
Please help!  I have large database with almost 3K products I am trying to move over to virtuemart for a friend.  Please check the file and tell me what needs to be changed and what settings I need to use to get the images and thumbnails to migrate.  Any assistance is greatly appreciated!!!
http://joesamsfunshop.com/prototype/TEST_import1.csv

castart

  • Guest
Re: Product image link to external server
« Reply #12 on: October 14, 2013, 09:19:01 am »
Subscribe at http://www.csvimproved.com.
Download CSVI Improved component.
Install in Joomla.

Using this component you can import .csv files.
Find out how it works, there is an online tutorial.
Before using this component for your migration, first test a few small files with not too much data.
(For instance a file with 1 record and 3 fields)

Cast-Art


 

yannis_r

  • Beginner
  • *
  • Posts: 5
Re: Product image link to external server still not working
« Reply #13 on: January 04, 2014, 13:15:54 pm »
Hello,

I did import the proposed file.
Then I went to table virtuemart_medias and changed the default file_url and file_url_thumb to: http://s7d9.scene7.com/is/image/bebe/rbb-196731-fff-i1?$Main$

Here is the record:

virtuemart_media_id   virtuemart_vendor_id   file_title   file_description   file_meta   file_mimetype   file_type   file_url   file_url_thumb   file_lang   file_is_product_image   file_is_downloadable   file_is_forSale   file_params   shared   published   created_on   created_by   modified_on   modified_by   locked_on   locked_by
172   1   img8889032[1].jpg         image/jpeg   product   http://s7d9.scene7.com/is/image/bebe/rbb-196731-fff-i1?$Main$   [/b]http://s7d9.scene7.com/is/image/bebe/rbb-196731-fff-i1?$Main$      0   0   0      0   1   11/20/2013 12:18:59 AM   35   11/20/2013 12:30:13 AM   35   1/19/2013 12:00:00 AM   0

But when I went to check it I get a broken image:
http://www.womansheaven.com/vp/en/front-page/women/clothing/lingerie/individual-10-leg-support-detail

any ideas what went wrong?




1:

You musst assign the image to your product in CSVI. If you only import the images, CSVI insert it only in the medias table.

2:

OK this is a small bug. I've fixed it for the next version. You can use the attached file and copy it to

administrator/components/com_virtuemart/helpers/  (unzip the file first)