Author Topic: "Please accept the terms of service to confirm" BUG after upgrade to 2.0.20a  (Read 21035 times)

jcmanc

  • Beginner
  • *
  • Posts: 3
Everything was working fine on my site until I upgraded to the latest (2.0.20a) version yesterday. I'm running the latest Joomla 2.5.9.

Now when a user clicks on the "Checkout Now" button, they remain on the same page but with the following message:

"Please accept the terms of service to confirm"

and are now unable to proceed as neither the Terms of Service checkbox, or label text appear.

I have:

Must agree to Terms of Service on EVERY ORDER? - YES
Show Terms of Service on the cart/checkout? - YES

selected in the backend admin configuration.

Any help would be greatly appreciated.

jcmanc

  • Beginner
  • *
  • Posts: 3
Just reverted back to previous version through my backup and its now working fine so clearly there is an issue with the new 2.0.20a upgrade

menfbeast

  • Beginner
  • *
  • Posts: 1
I have the same issue.
Need help on this soon  :(

madamsplash

  • Beginner
  • *
  • Posts: 29
  • I have been a beginner since 2000
    • Splash Internet Marketing Australia
Yup me too - but it's to do with Shop Licious - as if I dismantle that - Virtuemart works fine
http://splash.net.au - Beginners since 1994 - everybody in Virtuemart is a Beginner - unless they sign up as an expert - hey you gonna do that?

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10144
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
We just moved the TOS to the begin of the checkout process. The rest is the same.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

mirrorsandglass

  • Jr. Member
  • **
  • Posts: 169
  • Time Is Precious, Waste It Wisely
Version info:      VM2.0.20a  -  J2.5.9
This is still happening on mine.

This bug happened intermittently with 2.0.18 but usually clearing cache and cookies and restarting the browser sorted it out but not so far with 2.0.20a
I've cleared both several times and even reverted my cart template override(just minor layout) just incase but still no go. :(

EDIT:
In FireBug this seems to be the offending input : <input type="hidden" value="0" name="tosAccepted">
Even after ticking the box this hidden value stays at 0 I would imagine it should go to 1.

EDIT 2: This would seem to be a SEF issue as if I disable SEF it seems to work okay. Will investigate further.

csimmo

  • Jr. Member
  • **
  • Posts: 50
Add me to the list of those suffering from this issue.
VM 2.0.20b
Joomla 2.5.9

csimmo

  • Jr. Member
  • **
  • Posts: 50
My template doesn't use a customized cart, but they did help me solve the issue. You need to reset the VM config file. This fixed the problem for me.

Schakkalaka

  • Beginner
  • *
  • Posts: 2
me too

remeedella

  • Jr. Member
  • **
  • Posts: 62
i can confirm it works

mirrorsandglass

  • Jr. Member
  • **
  • Posts: 169
  • Time Is Precious, Waste It Wisely
My template doesn't use a customized cart, but they did help me solve the issue. You need to reset the VM config file. This fixed the problem for me.
How do you mean reset it?

juansolos

  • Beginner
  • *
  • Posts: 1
Same problem.
Reset the config file doesn't solve the problem.

csimmo

  • Jr. Member
  • **
  • Posts: 50
under tools there is an option to reset the virtuemart config file. I had to do it twice in 2 days though.

franzpeter

  • 3rd party VirtueMart Developer
  • Jr. Member
  • *
  • Posts: 467
    • 2in1-online | Software, Mac, PC, Netzwerk, Drucker, Pad, Display
  • VirtueMart Version: Virtuemart 3.2.6
Does that happen with the default VM template too? If not, it is a template issue.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10144
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Yup me too - but it's to do with Shop Licious - as if I dismantle that - Virtuemart works fine
Updated version was 1 day later already uploaded.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/