Author Topic: Multivendor feature REGRESSION!  (Read 1349 times)

newlog

  • Beginner
  • *
  • Posts: 4
Multivendor feature REGRESSION!
« on: March 13, 2013, 10:02:12 am »
Hi everyone

Despite many claims by VM Dev team members on the Forum, there seems to a serious regression regarding multivendor (administrated, single cart) in VM 2.

In VM 1 everything seems to be clear: http://virtuemart.net/documentation/User_Manual/Vendors.html.

Now in VM 2, once multivendor administration has been activated:
  • Where do you add a new vendor?
  • How do you edit the "Is a vendor" status of a user?

Why the heck did those nice multivendor administration features (create, edit) disappear???
 :-[

NL

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27778
  • Always on vacation
    • Jenkin Hill Internet
Re: Multivendor feature REGRESSION!
« Reply #1 on: March 13, 2013, 13:37:47 pm »
Lets be clear about this. Multivendor never worked with VirtueMart 1.1 There was some alpha level code within the core but development never got furtther than that. It had been planned to be included at some stage but nobody wrote any code that worked. Yes, there was a vendor as described in the old documentation you refer to, but only a single one. The docs were written at the beginning of the VM1.1 project assuming that MV would actually be working at some stage, but it was not possible.

To enable a new vendor in VM2.0.20 go to VM Configuration/Shop and set "Enable Multivendor (experimental only for developers)"  to "administrated multivendor"  Then go to Orders & Shppers/Shoppers. You should see a Vendor? column. Now you can select an admin user and hit "is a vendor" - then you should see a green tick in the Vendor column against that admin user.

Products can be assigned to that new vendor in the product editor.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.8.4.10335 on Joomla 3.9.19 PHP 7.3.18