Author Topic: [solved]Jquery validationEngine issue after update to 2.0.18a  (Read 6857 times)

MarioP

  • Jr. Member
  • **
  • Posts: 176
  • VirtueMart Version: VM 3.8.6, J! 3.9.5
[solved]Jquery validationEngine issue after update to 2.0.18a
« on: February 06, 2013, 10:03:01 am »
Hello.
Joomla! 2.5.8
After update VM from 2.0.16 to 2.0.18a version I have a problem with translation into Polish "ask a question" modal popup (product details page). It looks like the jquery.validationEngine-pl.js ( ...\components\com_virtuemart\assets\js\languages\ ) doesn't work.  Following sentences:
* This field is required
* Minimum 50 characters allowed
aren't translated, like it took place before the update of the VM...

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3737
  • using Matomo instead of Google Analytics
Re: Jquery validationEngine issue after update to 2.0.18a
« Reply #1 on: February 22, 2013, 18:22:05 pm »
just in case you didn't solve that yet - see here: http://forum.virtuemart.net/index.php?topic=104621.msg350513#msg350513
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

MarioP

  • Jr. Member
  • **
  • Posts: 176
  • VirtueMart Version: VM 3.8.6, J! 3.9.5
Re: Jquery validationEngine issue after update to 2.0.18a
« Reply #2 on: March 01, 2013, 21:58:22 pm »
Thanks for the attempt to help but I've read the topic before I post mine - I have a different issue.  Like I wrote "It looks like the jquery.validationEngine-pl.js ( ...\components\com_virtuemart\assets\js\languages\ ) doesn't work. " So I already have the jquery.validationEngine-pl.js file (enclosed to strandard instalation of VM) but the translation doesn't work... Before the update VM from 2.0.16 to 2.0.18a version everything was OK.

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3737
  • using Matomo instead of Google Analytics
Re: Jquery validationEngine issue after update to 2.0.18a
« Reply #3 on: March 01, 2013, 23:16:36 pm »
Do you have the Google jQuery enabled in VM configuration?
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

MarioP

  • Jr. Member
  • **
  • Posts: 176
  • VirtueMart Version: VM 3.8.6, J! 3.9.5
Re: Jquery validationEngine issue after update to 2.0.18a
« Reply #4 on: March 01, 2013, 23:41:16 pm »
Yes, I do

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3737
  • using Matomo instead of Google Analytics
Re: Jquery validationEngine issue after update to 2.0.18a
« Reply #5 on: March 02, 2013, 00:00:41 am »
Try if it makes a difference if you disable the Google jQuery and enable the VirtueMart jQuery. Google uses a newer version of jQuery, that might produce a javascript conflict. I usually recommend to use the VM jQuery, because you never know when Google changes the version and often the Google api is slow. (Don't enable both!)
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

MarioP

  • Jr. Member
  • **
  • Posts: 176
  • VirtueMart Version: VM 3.8.6, J! 3.9.5
Re: Jquery validationEngine issue after update to 2.0.18a
« Reply #6 on: March 02, 2013, 00:23:56 am »
I've tried your solution  (I've had enabled both jquery - Google and VirtueMart ) , unfortunately nothing changed after the modification. When the libraries are working independently, neither Google jQuery nor VirtueMart jQuery doesn't help - the translation doesn't work. I have one website based upon VM 2.0.16 with enabled both Jquery libraries and the translation works fine....

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3737
  • using Matomo instead of Google Analytics
Re: Jquery validationEngine issue after update to 2.0.18a
« Reply #7 on: March 08, 2013, 15:28:51 pm »
Just tested this in VM 2.0.14 (works) and VM 2.0.18c (doesn't work). However, I didn't figure out yet what is causing this. The validation.engine files seem to be identical in both versions.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3737
  • using Matomo instead of Google Analytics
Re: Jquery validationEngine issue after update to 2.0.18a
« Reply #8 on: March 08, 2013, 21:03:21 pm »
The problem in version 2.0.18x is that the other jQuery validationEngine language files are not loaded. The solution requires a fix in the file
...\administrator\components\com_virtuemart\helpers\config.php
It's already been fixed in the SVN repository and will be included in the next version.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

alatak

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2048
    • alatak.net
Re: Jquery validationEngine issue after update to 2.0.18a
« Reply #9 on: March 11, 2013, 12:55:55 pm »
Hello
I have fixed that issue
The problem was checking if the language file exists or not.