Author Topic: the virtuemart search module throws me 0 results of any word  (Read 9841 times)

josecruz

  • Beginner
  • *
  • Posts: 1
the virtuemart search module throws me 0 results of any word
« on: February 05, 2013, 19:43:35 pm »
hello good afternoon,
and I hope you can help me with a problem I have.
I am using joomla 2.5.8 and virtuemart 2.0.18a. I have more than 4000 products.
the virtuemart search module throws me 0 results of any word, but the search module joomla if I show the products only without money and without my virtuemart design.
settings in virtuemart in available search fields I have selected: product name, product id, manufacturer and category. but still does not show me ninguún result.
and check the log file from my server and no mention of virtuemart.
inporté not my store, I did everything manually and not ne had not realized until I was asked to place a search engine.
and I hope you can help me since I have not found anything on the net or in this forum.
my site: http://www.ferreteriacuauhtemoc.com

Makis77

  • Beginner
  • *
  • Posts: 49
Re: the virtuemart search module throws me 0 results of any word
« Reply #1 on: July 13, 2013, 00:37:55 am »
Hi Jose.
How did u solve this issue?

I'm having the same problem as well.

rjcroasdale

  • Jr. Member
  • **
  • Posts: 81
    • Marketing Consultants
Re: the virtuemart search module throws me 0 results of any word
« Reply #2 on: July 16, 2013, 17:34:53 pm »
hello (^_^)

I am also having problems with search.

For me its intermittent. Sometimes it will search within the current category. Sometimes not. Sometimes gets results from virtuemart root, sometimes not. If I am on the product details page, it consistently manages to find the product name.

I've checked Product Sort Order Settings, and Search Filter Category from the module.

This is the best thread I can see, maybe it will work for you. It doesn’t seem to work for me. http://forum.virtuemart.net/index.php?topic=105382.msg350929#msg350929

Also in this thread it is mentioned:  "If you go to your Joomla 2.5+ Plugin Manager and set the filter to "Search", you will see a 'VM - Search, Virtuemart Product' plugin. " http://forum.virtuemart.net/index.php?topic=105382.msg377237#msg377237

I dont have such a joomla plugin installed, but I don’t have in a clean install I did a while ago either.

I am on a migrated system from J1.5 and vm1 to j2.5 and vm2, started migration with Installed version 2.0.22

Going to update to Latest version 2.0.22a now.

Seems like lots of people on the forum having virtuemart search module problems.

rjcroasdale

  • Jr. Member
  • **
  • Posts: 81
    • Marketing Consultants
Re: the virtuemart search module throws me 0 results of any word
« Reply #3 on: July 16, 2013, 22:52:11 pm »
Update to 2.0.22a does not fix it.

rjcroasdale

  • Jr. Member
  • **
  • Posts: 81
    • Marketing Consultants
Re: the virtuemart search module throws me 0 results of any word
« Reply #4 on: July 17, 2013, 13:07:30 pm »
I have the search working now, so many threads and think I've read them all. Not sure if this is right, its from memory (i have like 30tabs open, all virtuemart forum)

404 error on "search in shop" enable SEF / remove from template

to get all results, not only results from current category -

I ended up getting the search to show all results regardless of which category - think this was done by adding this to search mod file @line 45
Code: [Select]
<input type="hidden" name="virtuemart_category_id" value="0" />
then using the following to not show the current category name if on search page, but do show if on category page
Code: [Select]
<?php $searchnone=JRequest::getVar('keyword',0); ?>
<?php if (empty($searchnone)) {?>
<h1><?php echo $this->category->category_name?></h1>  [b]<<// LINE 175 //>>[/b]
<?php ?>

may also have done this
http://forum.virtuemart.net/index.php?topic=98558.msg325198#msg325198

A big thank you to all who help maintain the forum and help the noobs :)

atrus

  • Jr. Member
  • **
  • Posts: 127
Re: the virtuemart search module throws me 0 results of any word
« Reply #5 on: July 29, 2013, 17:35:07 pm »
Hi to all,

The problem remains and it is also causing issues with the manufacturer module so the problem i guess is somewhere in /administrator/components/com_virtuemart/models/product.php

Any luck?

Rgrds,
Chris

rjcroasdale

  • Jr. Member
  • **
  • Posts: 81
    • Marketing Consultants
Re: the virtuemart search module throws me 0 results of any word
« Reply #6 on: July 30, 2013, 16:22:07 pm »
I have the same problem on another migration from 1 to 2; are you on a migration or fresh install - also which version?

I will try to pay more attention on how I fixed - this time round.

I know we're not the only ones having this problem - at least pretty sure because there are lots of threads.

Let us know if you have any luck

rjcroasdale

  • Jr. Member
  • **
  • Posts: 81
    • Marketing Consultants
Re: the virtuemart search module throws me 0 results of any word
« Reply #7 on: August 01, 2013, 03:54:59 am »
Hi atrus (^_^)

i dont use the manufacturer module so dont know about that

but I did the three things i posted above and on another site where i had the same problem and now the search works fine for me (the search works fine now on both sites and one site has been live for two weeks)

it works for me - hope you find a solution

al_bel

  • Beginner
  • *
  • Posts: 2
Re: the virtuemart search module throws me 0 results of any word
« Reply #8 on: February 13, 2014, 23:45:17 pm »
I have same problem with "category filter" in virtuemart search module on 2.0.26d.

Your solution works fine.
<input type="hidden" name="virtuemart_category_id" value="0" />