Author Topic: V 1.1.9 and php 5.x compatibility  (Read 2116 times)

Semaphore

  • Beginner
  • *
  • Posts: 6
V 1.1.9 and php 5.x compatibility
« on: January 09, 2013, 17:38:19 pm »
Hi Community,
Can somebody resume the comptability of VM 1.1.9 with
  • PHP 5.2 :: OK
  • PHP 5.3.2.1 :: OK
  • PHP 5.4 :: Not good

Thanks for the infos ?

Joseph Kwan

  • Advanced
  • Hero Member
  • *****
  • Posts: 2344
Re: V 1.1.9 and php 5.x compatibility
« Reply #1 on: February 06, 2013, 01:52:01 am »
Are you sure that the problems are due to VM? Compatibility problems of database do not seem to be VM-related. What problems do you encounter?
Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

GJC Web Design

  • 3rd party VirtueMart Developer
  • Hero Member
  • *
  • Posts: 1618
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.7
Re: V 1.1.9 and php 5.x compatibility
« Reply #2 on: February 06, 2013, 10:07:51 am »
VM1.1.9 happily runs on PHP Version:    5.3.21
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
AusPost Shipping Plugin - e-go Shipping Plugin - Postcode Shipping Plugin - Radius Shipping Plugin - NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart 2.0 Product Review Component
http://extensions.joomla.org/extensions/owner/lumoo
Contact for any VirtueMart or Joomla development & customisation

Semaphore

  • Beginner
  • *
  • Posts: 6
Re: V 1.1.9 and php 5.x compatibility
« Reply #3 on: February 06, 2013, 10:16:37 am »
Ok, Edited !
And nobody for php 5.4 ?

Joseph Kwan

  • Advanced
  • Hero Member
  • *****
  • Posts: 2344
Re: V 1.1.9 and php 5.x compatibility
« Reply #4 on: February 06, 2013, 17:37:02 pm »
Sorry I misread the question and thought you are talking about mysql. Can you tell what issues/symptoms are there?
Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

Semaphore

  • Beginner
  • *
  • Posts: 6
Re: V 1.1.9 and php 5.x compatibility
« Reply #5 on: February 06, 2013, 18:22:02 pm »
Like I said I the first post : just the compatibility with the php version.
It's for information because I see these questions every where and nobody give the information ;-)

Joseph Kwan

  • Advanced
  • Hero Member
  • *****
  • Posts: 2344
Re: V 1.1.9 and php 5.x compatibility
« Reply #6 on: February 06, 2013, 20:46:21 pm »
What are the specific compatibility problems? Any function not working? Installation not working?
Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

Semaphore

  • Beginner
  • *
  • Posts: 6
Re: V 1.1.9 and php 5.x compatibility
« Reply #7 on: February 06, 2013, 21:46:29 pm »
 No no no, I don't need help, I don't have any pb. I just want to list here the VM1.9 com:patibility because a lot of ppl ask on many forum and I though it was a good idea to post all these information at least one time, that's all.

jenkinhill

  • Global Moderator
  • Super Hero
  • *
  • Posts: 20673
  • Web developer and consultant
    • Jenkin Hill Internet
Re: V 1.1.9 and php 5.x compatibility
« Reply #8 on: February 06, 2013, 23:56:47 pm »
Problems arise when you get to PHP5.4 as Joomla 1.5 does not run properly there without some hacking, so you can't easily test VM1.1.9

Kelvyn
Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM2.6.8b on Joomla 2.5.24 PHP 5.4.21

Currently testing VM2.9.9a on J3.3.3

Semaphore

  • Beginner
  • *
  • Posts: 6
Re: V 1.1.9 and php 5.x compatibility
« Reply #9 on: February 07, 2013, 00:00:51 am »
There is post/list with these bad (h)a(ck)s for VM (I don't talk about 3rdparty plugin etc) when upgrading to VM2 is not possible ?

GJC Web Design

  • 3rd party VirtueMart Developer
  • Hero Member
  • *
  • Posts: 1618
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.7
Re: V 1.1.9 and php 5.x compatibility
« Reply #10 on: February 07, 2013, 10:30:03 am »
Simplest way is just install 1st a J1.5 on php5.4 and see what happens - any warnings and errors are reported if you push up the debugging and away you go -
all fixes for php incompatibility are well documented and in my experience easy to fix (normally function substitution)

Once that's up and running try VM1.1 and do the same..
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
AusPost Shipping Plugin - e-go Shipping Plugin - Postcode Shipping Plugin - Radius Shipping Plugin - NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart 2.0 Product Review Component
http://extensions.joomla.org/extensions/owner/lumoo
Contact for any VirtueMart or Joomla development & customisation

Semaphore

  • Beginner
  • *
  • Posts: 6
Re: V 1.1.9 and php 5.x compatibility
« Reply #11 on: February 07, 2013, 10:34:18 am »
Joomla! 1.5 in it's latest version work with PHP5.4 -1.5.23)
So ppl "just" have to turn on debug in config panel and to fix the error showned on the front with VM1.19 ?

VirtueMart Forum

Re: V 1.1.9 and php 5.x compatibility
« Reply #11 on: February 07, 2013, 10:34:18 am »