Author Topic: Virtuemart 1.1.6 USPS API Retired  (Read 3483 times)

perfectbalance

  • Beginner
  • *
  • Posts: 1
Virtuemart 1.1.6 USPS API Retired
« on: December 22, 2012, 01:20:32 am »
I am using an older version of Virtuemart 1.1.6 and when I set up the USPS shipping module and I am now receiving an error that says:

API Disabled: RateV2.  This API has been retired. Please use RateV4. Documentation can be found at https://www.usps.com/business/webtools-technical-guides.htm

I have spoken with USPS and they said I need to update my programming to connect to RateV4. I do not know how to do this.

Also, does this mean that any site that I have built in the past using USPS is now inactive?

I am stumped. Please help.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26417
  • Always on vacation
    • Jenkin Hill Internet
Re: Virtuemart 1.1.6 USPS API Retired
« Reply #1 on: December 22, 2012, 15:27:11 pm »
There are several threads in this forum section about V4 in the old VM version - so have a read! 
eg http://forum.virtuemart.net/index.php?topic=101850.0
http://forum.virtuemart.net/index.php?topic=97269
http://forum.virtuemart.net/index.php?topic=106866.0
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.8 on Joomla 3.8.2 PHP 7.0.25

Testing VM3.2.8 on J3.8.3RC