Author Topic: [SOLVED] Hyperlinks dont work, pages are blank! Help  (Read 937 times)

godskitchen

  • Beginner
  • *
  • Posts: 25
[SOLVED] Hyperlinks dont work, pages are blank! Help
« on: October 22, 2012, 18:27:02 pm »
Have installed Virtuemart here http://www.sackstore.co.uk/sofasandchairs/ and as you can see the sample install data is there but when i click on any of the hyperlinks its brings up a blank page! Anyone help me with this?

Joomla 2.5.7 & Virtuemart 2.0.12e

Eddie

bytelord

  • Nikos
  • Global Moderator
  • Hero Member
  • *
  • Posts: 2369
Re: Hyperlinks dont work, pages are blank! Help
« Reply #1 on: October 22, 2012, 19:26:15 pm »
Hello,

Please assign vm frontpage (com_virtuemart) to a joomla menu item. Create a new menu item under joomla and assign it.

Regards
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!

godskitchen

  • Beginner
  • *
  • Posts: 25
Re: Hyperlinks dont work, pages are blank! Help
« Reply #2 on: October 22, 2012, 21:50:33 pm »
Thanks for that Lord but the product details keep failing, have got the categories etc and can assign to a menu/item but when you go into a category such as here:- http://www.sackstore.co.uk/sofasandchairs/index.php/vm-front-page/handtools the Hammer link, Hand Shovel and Nice Saw link are just dead, any ideas or am i doing something wrong?

Eddie

bytelord

  • Nikos
  • Global Moderator
  • Hero Member
  • *
  • Posts: 2369
Re: Hyperlinks dont work, pages are blank! Help
« Reply #3 on: October 22, 2012, 22:02:11 pm »
Hello,

Could you please check joomla error log to see why this error 500 is produced?
And disable also sef urls for both joomla and vm.

btw, what's your PHP version?

Regards
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!

godskitchen

  • Beginner
  • *
  • Posts: 25
Re: Hyperlinks dont work, pages are blank! Help
« Reply #4 on: October 23, 2012, 10:26:13 am »
Hi the server is set to PHP5.2 but i have the option to upgrade to PHP5.3

The SEF URLs are now both disabled on Joomla and were not set for VM and where do you find the joomla error logs please, thanks for your help

Eddie

bytelord

  • Nikos
  • Global Moderator
  • Hero Member
  • *
  • Posts: 2369
Re: Hyperlinks dont work, pages are blank! Help
« Reply #5 on: October 23, 2012, 22:30:16 pm »
Hello,

PHP 5.3 will be better for vm and joomla. Btw, i checked your site and there is no access at all, not only for vm but for joomla also (http://www.sackstore.co.uk/sofasandchairs).
The error logs are located under joomla_folder/logs/error.php
Are you sure you have disable sef options? Also have you enable Use URL rewriting under joomla configurarion? If yes have you configure your .htacess file? Could you try to disable it also?

Regards
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!

godskitchen

  • Beginner
  • *
  • Posts: 25
Re: Hyperlinks dont work, pages are blank! Help
« Reply #6 on: November 22, 2012, 13:58:16 pm »
Hi this topic is now resolved, i did a full reinstall and everything is working fine thanks.

VirtueMart Forum

Re: Hyperlinks dont work, pages are blank! Help
« Reply #6 on: November 22, 2012, 13:58:16 pm »