Author Topic: [solved]Virtuemart Order Emails Not Working  (Read 26187 times)

foxlox

  • Beginner
  • *
  • Posts: 2
Re: [solved]Virtuemart Order Emails Not Working
« Reply #15 on: January 17, 2014, 18:18:08 pm »
hi guys

did you solve? I do it:

in components/com_virtuemart/views/pluginresponse/pluginresponse/tmpl/default.php after JHTML::_('behavior.modal');

insert:
--------------------------------8<----------cut ----------------------
$order_id=$_GET['on'];
$query = 'select virtuemart_order_id from PREFISSOTABELLE_virtuemart_orders where order_number="'.$order_id.'"';
$db = JFactory::getDBO ();
$db->setQuery ($query);
$result=$db->loadObjectList();
$virtuemart_order_id=$result[0]->virtuemart_order_id;
$modelOrder = VmModel::getModel ('orders');
$order['order_status'] = 'C';
$order['virtuemart_order_id'] = $virtuemart_order_id;;
$order['customer_notified'] = 1;
$order['comments'] = "Pagamento ricevuto tramite PayPal per ordine ".$order_id;
$modelOrder->updateStatusForOneOrder($virtuemart_order_id, $order, true);
--------------------------------8<---------- end of cut ----------------------

ciao ciao

dropaway

  • Beginner
  • *
  • Posts: 1
Re: [solved]Virtuemart Order Emails Not Working
« Reply #16 on: March 05, 2014, 12:22:24 pm »
Default Order Status to send email to vendor   - add Pending

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9843
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: [solved]Virtuemart Order Emails Not Working
« Reply #17 on: March 05, 2014, 23:07:09 pm »
How does it work with the vm2.5?
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

alin

  • Beginner
  • *
  • Posts: 20
  • VirtueMart Version: 3
Re: [solved]Virtuemart Order Emails Not Working
« Reply #18 on: November 20, 2014, 12:07:43 pm »
Same problem here.

I created a custom payment method with 0 fees and the email didn't work. As soon as I added some fees for the payment, the email worked.  ;D