Author Topic: [SOLVED] Trouble with recaptcha (can't verify you are not a robot)  (Read 3243 times)


  • Beginner
  • *
  • Posts: 35
  • Skype Name: escozul
Hello all.

I run a VirtueMart shop here: and I'm having issues with Recaptcha and virtuemart.

So captcha works if one tries to register via Joomla or even make an order as a guest (I need captcha on checkout since I don't only use credit cards)

However if one tries to register on the site it's impossible to get through the captcha challenge!
they always get the error

We could not verify you are not a robot.

Also when trying to sign up and pay for the order, that is never finished and the website crashes to 522 (timeout).

The only way to go through is to buy products as a guest.

Now I see that the edit.php file in my template has a point I can move around and it's the captcha:

Code: [Select]
echo $this->loadTemplate ( 'shopper' );
echo $this->captcha;

which is the same as the original edit.php of virtuemart.
Only that there is a code that is commented out:

Code: [Select]
/*if(VmConfig::get ('reg_captcha')){
$dispatcher = JDispatcher::getInstance(); $dispatcher->trigger('onInit','dynamic_recaptcha_1');
<div id="dynamic_recaptcha_1"></div>

Any idea why this is happening? Could you help me out please?

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 4382
  • Joomla & Virtuemart developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3
Re: Trouble with recaptcha (can't verify you are not a robot)
« Reply #1 on: January 11, 2018, 01:59:25 am »
try with protostar template to see if this is from your overides or Virtuemart.


  • Beginner
  • *
  • Posts: 35
  • Skype Name: escozul
Re: Trouble with recaptcha (can't verify you are not a robot)
« Reply #2 on: January 11, 2018, 15:32:47 pm »

The same thing goes with the protostar template.

It seems that it's not my overrides... :(

Any ideas?

Is there any chance that this is any of the known bugs with any chance of a workaround in some forum?

I use joomla 3.7.2 and Virtuemart 3.2.3

Update: and k2 2.7.1
It seems to me that there was a conflict with K2 and the fact that I had enabled the k2 profile integration. Once I removed it, all issues went away. Now I can register, Checkout and register or do any other function normally... I'm going to leave this here as feedback for future issues... K2 and Virtuemart should have only one handling the registration process.

Thanks for all the fish people. ;) (Studio 42 you asking me to use protostar actually triggered a whole domino of tryouts that led to me disabling k2 profile integration and thus I fould the solution to the issue. Thanks for the inspiration man!)


  • Beginner
  • *
  • Posts: 35
  • Skype Name: escozul
Re: [SOLVED] Trouble with recaptcha (can't verify you are not a robot)
« Reply #3 on: January 12, 2018, 16:07:09 pm »
The first hot spot is the code that generates the form. Hopefully that's easy enough to find (by looking for a <form> tag in your html) and you have been able to display the CAPTCHA on your form.
if your form can ever display an error message, for example if a required field is blank, look for the code that generates that error message.

Hello Graby

I've looked at all that before making the initial post.

However, if you look at my latest post you will see that I've actually figured it out. I have K2 installed on my website and it was using the k2 profile integration during registration. That probably caused the generated HTML to have 2 captchas. One visible and one hidden (that is just a speculation actually but I guess that's what was happening). You would take the captcha challenge and it would be captured by the second captcha. So the result would be "we couldn't verify you are not a robot". That's a weird error as captcha usually generates the error "Captcha challenge failed, try again".

Anyway, that is only a speculation but I believe I'm not very far of. Disabling K2 profile integration removed all issues. Also On the Joomla registration form, I saw no captcha and when I removed the k2 integration the captcha came back there too.

Edit: umm.. graby's post is gone.. :/