Author Topic: How to setup Parent/Child products for different shopper groups in VM2.0.6 on JM  (Read 1209 times)

hsiehd

  • Beginner
  • *
  • Posts: 7
Can someone help me to setup Parent/Child products for different shopper groups?
I would like setup 3 different shopper groups for the visitors to my site. To show different prices to different customer/visitor I have used Parent/Child product for the different prices. To explain the problem which I am facing is as follow:

Group 1 only can see price of Product1 10ml; Product1 100ml and only can order 10ml; 100ml products1
Group 2 only can see price of Product1 1kgs; Product1 5kgs and only can order 1kgs; 5kgs products1
Group 3 (did not loggin group) only see product1 information without any price.


Thanks


DH

remeedella

  • Jr. Member
  • **
  • Posts: 62
I cannot believe no one has replied to this thread yet. I've searched numerous times for the right information and I have the newest virtuemart and everything is fresh.

One of the only problems I have now is my client needs individual product prices for 2 different shopper groups. I can succesfully pull this off by CLONING products I have but then I have multiple products in database and each have different quantities and such. If I attempt to put child products of the carts products it will not actually clone the product. It will only copy my the title over, no media, dimensions,fields,nothing else. So basically I would be stuck manually inputting all the information for every single product on the website including images and default information. And even if I did that it's very buggy, I don't know if I'd be able to to sell a product to 1 shopper group or another shopper group and have the in stock quantity change accordingly for the child product and actual product. Furthermore, if I click under Product has children? column the child products never get added to that list, its always empty and I have to go back to no category filter search and look for it manually in (all) products instead of looking it up as a child product.

I'm guessing this is all a known issue... Is there no workaround is there anything broken on my end or something I can do, a workaround? Am I forced to attempt to add child products for everything manually and re-input all the information by hand for days upon days? Would that even achieve what I'm trying to do?

I would love to also give someone access to test site

Any help would be much appreciated as quickly as possible,

Jeremy