Author Topic: Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate  (Read 3968 times)

skifteri

  • Beginner
  • *
  • Posts: 2
I dont have access to php.ini  .I know that I have to increase the file size limit in htacccess but I dont know how. i have a file htaccess.txt but without a limitation inside it. Any suggestion?

bytelord

  • Nikos
  • Global Moderator
  • Full Member
  • *
  • Posts: 2369
Hello,

First if you are using apache you have to rename the file to .htaccess. Then under joomla global configuration you have to enable Use URL rewriting

After that edit your .htaccess and place the line:


php_value memory_limit 64M

or

php_value memory_limit 128M

Depends on your needs

Regards

Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!

skifteri

  • Beginner
  • *
  • Posts: 2
Hi. I have enabled URL rewriting. On what part of .htaccess i should add php_value memory_limit 128M? I'v added like below but with no results.
"
##
# @package      Joomla
# @copyright   Copyright (C) 2005 - 2012 Open Source Matters. All rights reserved.
# @license      GNU General Public License version 2 or later; see LICENSE.txt
##
php_value memory_limit 128M
##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!


jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27574
  • Always on vacation
    • Jenkin Hill Internet
The position does not matter, although convention says put it at the end. Note that many of the cheaper shared hosts do not permit php memory overrides.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.6.8 10204 on Joomla 3.9.13 PHP 7.0.33