Author Topic: blue messages on shopping cart page.  (Read 3212 times)

readyforchange

  • Beginner
  • *
  • Posts: 27
blue messages on shopping cart page.
« on: August 09, 2012, 22:39:47 pm »
On my shopping cart page... I get the following popping up in blue. 

I am not sure what the problem is... can someone help me?

joomla, 2.5.6 & virtuemart 2.0.8e... upgraded from virtuemart 2.0.6

Info: weigth_countries _weightCond orderWeight:0 method->weight_start: method->weight_stop: result:1
Info: weigth_countries _nbproductsCond nbproducts:1 method->nbproducts_start:0 method->nbproducts_stop:0 result:1
weigth_countries _orderamountCond cart_amount:5575 method->orderamount_start:0 method->orderamount_stop:0 result:
weigth_countries _zipCond zip:10250
Info: weigth_countries _weightCond orderWeight:0 method->weight_start: method->weight_stop: result:1
Info: weigth_countries _nbproductsCond nbproducts:1 method->nbproducts_start:0 method->nbproducts_stop:0 result:1
weigth_countries _orderamountCond cart_amount:5575 method->orderamount_start:0 method->orderamount_stop:0 result:
weigth_countries _zipCond zip:10250
Info: weigth_countries _weightCond orderWeight:0 method->weight_start: method->weight_stop: result:1
Info: weigth_countries _nbproductsCond nbproducts:1 method->nbproducts_start:0 method->nbproducts_stop:0 result:1
weigth_countries _orderamountCond cart_amount:5575 method->orderamount_start:0 method->orderamount_stop:0 result:
weigth_countries _zipCond zip:10250

bytelord

  • Nikos
  • Global Moderator
  • Full Member
  • *
  • Posts: 2369
Re: blue messages on shopping cart page.
« Reply #1 on: August 10, 2012, 03:57:56 am »
Hello,


Please first try to disable the debug info messages on both joomla and vm,


If you have select in VM backend debug info messages only for administrators when you login as administrator will show that debug information.


hope it helps.


regards.
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27433
  • Always on vacation
    • Jenkin Hill Internet
Re: blue messages on shopping cart page.
« Reply #2 on: August 10, 2012, 18:33:22 pm »
The debug messages are shown by default when logged in to the front end as admin. You should test the front end as a user/shopper unless debugging.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.8 PHP 7.0.33
Testing VM .3.6.0.10075 on Joomla 3.9.8

dinoide

  • Beginner
  • *
  • Posts: 23
Re: blue messages on shopping cart page.
« Reply #3 on: August 31, 2012, 12:29:37 pm »
I'm receiving the same blue messages for all "normal" users. Not only for admin.
I've already check that debug is OFF but the message are there in a public market in the fronend. very disgust.

Please, could you fix that?

or tell me how to eliminate of this word these stupid messages?

Regards,

Dinoide


jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27433
  • Always on vacation
    • Jenkin Hill Internet
Re: blue messages on shopping cart page.
« Reply #4 on: August 31, 2012, 13:17:53 pm »
Clear your browser session/cache
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.8 PHP 7.0.33
Testing VM .3.6.0.10075 on Joomla 3.9.8

dinoide

  • Beginner
  • *
  • Posts: 23
Re: blue messages on shopping cart page.
« Reply #5 on: August 31, 2012, 13:20:54 pm »
THE SOLUTION FOR THIS STUPID MESSAGE IS

"TO ELIMINATE THEM FROM THE PHP FILE"

Other solutions that you can see in this and other foros are not working for me...

PROCEDURE:

Go to plugins/vmshipment/weight_countries/weight_countries.php

and COMMENT all entries with: vmAdminInfo ('weigth_countries BLA BLA BLA...

f.i.

private function _weightCond ($orderWeight, $method) {

      $weight_cond = (($orderWeight >= $method->weight_start AND $orderWeight <= $method->weight_stop)
         OR
         ($method->weight_start <= $orderWeight AND $method->weight_stop === ''));
      vmAdminInfo ('weigth_countries _weightCond orderWeight:' . $orderWeight . ' method->weight_start:' . $method->weight_start . ' method->weight_stop:' .
         $method->weight_stop . ' result:' . $weight_cond);
      return $weight_cond;
   }

generates stupid and unusefull messages...
to avoid them:

private function _weightCond ($orderWeight, $method) {

      $weight_cond = (($orderWeight >= $method->weight_start AND $orderWeight <= $method->weight_stop)
         OR
         ($method->weight_start <= $orderWeight AND $method->weight_stop === ''));
/**   
*   vmAdminInfo ('weigth_countries _weightCond orderWeight:' . $orderWeight . ' method->weight_start:' . $method->weight_start . ' method->weight_stop:' .
*         $method->weight_stop . ' result:' . $weight_cond);
*/

      return $weight_cond;
   }

and that all. Repeat that in all calls to vmAdminInfo.

I can understand why Virtuemart designers included all the vmAdminInfo calls to see it in the front-end.

The problem is also that vmAdminInfo calls are read by any other user in the front-end, not only admin user. Other bug... but I don't care. In both cases message are 100% usefulness and should be eliminated.

Best Regards,

I lost some hours with this stupid problem that appear each time that I update from official VM release...


bytelord

  • Nikos
  • Global Moderator
  • Full Member
  • *
  • Posts: 2369
Re: blue messages on shopping cart page.
« Reply #6 on: September 17, 2012, 17:55:22 pm »
Hello,

vmAdminInfo will be removed on the next release (perhaps 2.0.12). vmAdminInfo appears only when an vm admin user login in the FE.
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!