Author Topic: Additional product image(s) does/do not show up  (Read 7216 times)

snoopy

  • Beginner
  • *
  • Posts: 19
Additional product image(s) does/do not show up
« on: August 21, 2012, 22:11:40 pm »
Hi

I am using the latest versions of Joomla (2.5.6) and VM (2.0.8e)

Maybe I am dumb. But I have been trying in vain for days to add more than one image to a product.

I go to product list, click on the small Media File Manager symbol for the product I want to upload an additional file, then add a second image. The upload works. The image is stored in /images/stories/virtuemart/product and in /images/stories/virtuemart/product/resized. But the additional image does not show up in the product details view nor anywhere else on the front shop.

I am using template Phoca Wallpaper 2. But the problem does not disappear with others I tested before.

Can anybody help? Adding additional images worked just fine with the old VM version. With VM 2.0 it drives me nuts.

bytelord

  • Nikos
  • Global Moderator
  • Full Member
  • *
  • Posts: 2369
Re: Additional product image(s) does/do not show up
« Reply #1 on: August 21, 2012, 22:43:12 pm »
Hello,
Did you try the default frontend vm layout (template) without overrides?

I think is a template issue. Also if you could provide a test url? Also the template you mention i think is a joomla template.
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!

snoopy

  • Beginner
  • *
  • Posts: 19
Re: Additional product image(s) does/do not show up
« Reply #2 on: August 21, 2012, 23:03:50 pm »
Thanks for your fast reply Bytelord,

Where do I get the default VM layout? When on the VM configuration/template tab the 3 template drop down boxes don't give me this selection.

For the following product page I uploaded an additional image which does not show up. http://www.contemporary-chinese-art.eu/en/component/virtuemart/galleries-paintings/gallery-paintings-zhang-liufeng/zhang-liufeng-star-sky-detail.html?Itemid=0

best

bytelord

  • Nikos
  • Global Moderator
  • Full Member
  • *
  • Posts: 2369
Re: Additional product image(s) does/do not show up
« Reply #3 on: August 21, 2012, 23:40:51 pm »
Hello,

I check your template with firebug and i see there is no div for additional images, but anyway it is not created if no additional images exist. On the backend when you upload an additional image, is that image selected, you should see thumbs under Search for images.

The default vm frontend layout (template) file for display the images is located under your_joomla_folder\components\com_virtuemart\views\productdetails\tmpl\default_images.php

If you have an override this override should located under your_joomla_folder\templates\phoca_wallpapers2\html\com_virtuemart\productdetails\default_images.php
if that file exist in your joomla template folder rename it so the original one will be used.

Something else, you use full image and is little bit huge ... is what you want? because ask_a_question button is over the image. You could use in the same file
<?php echo $this->product->images[0]->displayMediaThumb('class="product-image"',true,"class='modal'"); ?>
instead of
<?php echo $this->product->images[0]->displayMediaFull('class="medium-image" id="medium-image"', false, "class='modal'", true); ?>


regards
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!

snoopy

  • Beginner
  • *
  • Posts: 19
Re: Additional product image(s) does/do not show up
« Reply #4 on: August 22, 2012, 00:21:25 am »
Hi Bytelord

Thanks a lot. I have something to work on after a night of sleep (past midnight here).

The large images are intended. The site is supposed to "sell" expensive art objects. And a product in the sense I use it is always a unique item. Therefore it is so important for me to show good and additional images.

best

bytelord

  • Nikos
  • Global Moderator
  • Full Member
  • *
  • Posts: 2369
Re: Additional product image(s) does/do not show up
« Reply #5 on: August 22, 2012, 00:26:20 am »
Hello,

past midnight and here :)

yes, please try it and post back your results...
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!

snoopy

  • Beginner
  • *
  • Posts: 19
Re: Additional product image(s) does/do not show up
« Reply #6 on: August 22, 2012, 12:11:17 pm »
Hi Bytelord

I could not install your_joomla_folder\components\com_virtuemart\views\productdetails\tmpl\default_images.php.

Sorry for the non-expert question. But how is it installed? Attempts by the Extension manager failed.

ivus

  • Full Member
  • ***
  • Posts: 534
  • - YAY me... proud member of the 500 club...
Re: Additional product image(s) does/do not show up
« Reply #7 on: August 22, 2012, 12:40:38 pm »
Hi snoopy,

You only install using the extension manager if it's a .ZIP file.

Simple overwrite the file into the location specified by bytelord.

Mind you, you should really be using template overrides... just in case you want to revert or compare code.

your_joomla_folder\templates\your_template_name\html\com_virtuemart\productdetails\default_images.php

;D

bytelord

  • Nikos
  • Global Moderator
  • Full Member
  • *
  • Posts: 2369
Re: Additional product image(s) does/do not show up
« Reply #8 on: August 22, 2012, 12:44:46 pm »
As ivus suggests,

Compare or rename the file inside your_joomla_folder\templates\phoca_wallpapers2\html\com_virtuemart\productdetails\default_images.php
and try it again to see the results :)
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!

snoopy

  • Beginner
  • *
  • Posts: 19
Re: Additional product image(s) does/do not show up
« Reply #9 on: August 22, 2012, 15:45:44 pm »
Hi Bytelord and Ivus

Thanks.
Of the specified location I had in my directory tree no \templates\phoca_wallpapers2\html\com_virtuemart\productdetails\default_images.php

just
\templates\phoca_wallpapers2\html\

I created the missing subdirectories and loaded default_images.php into the specified location. But no changes. At least it has not damaged anything.

snoopy

  • Beginner
  • *
  • Posts: 19
Re: Additional product image(s) does/do not show up
« Reply #10 on: August 22, 2012, 17:37:03 pm »
I have just been able to upload and make visible additional images. See http://www.contemporary-chinese-art.eu/en/component/virtuemart/galleries-paintings/gallery-paintings-zhang-liufeng/zhang-liufeng-eclogue-detail.html?Itemid=0

I did it by using not the media manager but the product page. Now the product list also shows the correct number of images = 3 for the above product. Before, when I uploaded the images by the VM media manage, they images were uploaded too, but the counter for images remained on 1.

The way the additional images are displayed is however in my humble opinion minor to the old VM version. You cannot move from one flypage to the next, you see only mini-mini images and one mini-image of the main image shows up in addition which is really superfluous.

Compared to the old VM version this is one or more steps back. First of all you have to tinker for days until you finally find out how to make work a rather "average" task. And then the display is less than what it used to be.

Anyway, thanks to Bytelord and Ivus. You did your best to help me.

bytelord

  • Nikos
  • Global Moderator
  • Full Member
  • *
  • Posts: 2369
Re: Additional product image(s) does/do not show up
« Reply #11 on: August 22, 2012, 17:44:43 pm »
ok,

i was thinking when you were adding additional images you do it from inside the product and not media manager! I found it funny, but glad you find the solution!

O wrote it to you but ... :)

Quote
I check your template with firebug and i see there is no div for additional images, but anyway it is not created if no additional images exist. On the backend when you upload an additional image, is that image selected, you should see thumbs under Search for images.

I am thinking that manual should come out!
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!

n0de

  • Beginner
  • *
  • Posts: 4
Re: Additional product image(s) does/do not show up
« Reply #12 on: October 18, 2012, 02:10:38 am »


i have probelm with additional images too ... anyone can help ?
Other images are in top of main picture .... i want to other ( multiple thumbs ) be little down  ;D

Help me please with this i'll be very thanksfulll!!

bytelord

  • Nikos
  • Global Moderator
  • Full Member
  • *
  • Posts: 2369
Production: Joomla 2.5.8 | VM 2.0.14 | PHP 5.3.13
Testing     : Joomla 2.5.8 | VM 2.0.16 | PHP 5.3.8
Testing     : Joomla 2.5.8 |    VM 2.1   | PHP 5.3.8

- Don't Forget to mark thread as solved when it is solved!
- Please do not PM with support questions, use the forum!