Author Topic: Problems after PHP Upgrade  (Read 1849 times)

KooTjoo

  • Beginner
  • *
  • Posts: 35
Problems after PHP Upgrade
« on: June 26, 2012, 18:54:35 pm »
Hi,

Recently my hoster upgraded the PHP Version to 5.3.13 I am using an old version of Virtuemart 1.1.4. because it worked flawlessly up until now and there are many hacks in it.

It stil works but in the Orderr Management when I click on an ordernumber I get the folloqing error.

[Fri Jun 22 15:26:27 2012] [error] [client 83.86.204.252] ] [notice] EACCELERATOR(29201): PHP crashed on opline 3 of spl_autoload_call() at /home/kkb/public_html/administrator/components/com_virtuemart/classes/ps_database.php:45, referer: http://www.kkb.nl/administrator/index.php?option=com_virtuemart

Does anyone have any idea on how to solve this?

Thanks,
Marco

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27849
  • Always on vacation
    • Jenkin Hill Internet
Re: Problems after PHP Upgrade
« Reply #1 on: June 26, 2012, 23:44:36 pm »
I believe that old version of VirtueMart is not compatible with that PHP version - and Joomla 1.5.26 is also reported to have problems with the latest PHP version of the 5.3 series, which is 5.3.14 and a recommended security upgrade for hosts. I'm not sure if VM1.1.9 will work either - I no longer have any old VM1.1 sites to test.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.8.4.10335 on Joomla 3.9.21 PHP 7.4.9

KooTjoo

  • Beginner
  • *
  • Posts: 35
Re: Problems after PHP Upgrade
« Reply #2 on: June 27, 2012, 14:08:19 pm »
Hi,

I have two similar sites both running with VM 1.1.4 and PHP5.3.13 one is working without any problems and the other has the mentioned problem. The sites are however on a different server so it must be a setting somewhere. The hoster is not coming up with an answer and I can't find it myself either.

If anyone can help?

Thanks,
Marco

KooTjoo

  • Beginner
  • *
  • Posts: 35
Re: Problems after PHP Upgrade
« Reply #3 on: July 10, 2012, 16:55:25 pm »
Hi,

Anyone on this please. I have almost tried everything to get things working again, no luck so far.

Thanks,
KooTjoo