Author Topic: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08  (Read 17402 times)

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
This is not the invoice sent to customers. ( Has nothing to do with the emails)

the PDF creation in the orders area in the backend.

* The print option works well but the PDF file will not display.

* infact it does work on an odd invoice now and again - but for all types of browsers it just shows a blank page.  The page hangs for a good 5 minutes.

And I am confirming I have tried all the settings in the configuration - checkout area and then set all products to my confirmed setting and saved them. (emails arrive with a PDF invoice but the invoice in orders does nothing) - can someone test or confirm>

I have updated to 2.5.6 joomla  but this was not working for a few days and I was waiting to see if others posted something similar. ( so 2.5.4 it did not work as well)

alatak

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2048
    • alatak.net
Re: 2.0.7 G PDF in the invoice orders not working - Backend
« Reply #1 on: June 20, 2012, 22:34:12 pm »
Hello John2400

I don't have problem.

Can you check in the configuration in the tab "checkout" the parameter "Default Order Status to send an invoice".

which payment method do you use?
Is the invoice created? if yes, can you check on the invoice path , that it has been correctly created?

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: 2.0.7 G PDF in the invoice orders not working - Backend
« Reply #2 on: June 20, 2012, 23:37:22 pm »
mmm,

The software works - but it hangs - again I did it this morning - after I click the first and it shows- close the window- the second just hangs .

So yes it works - but it is opening them - I have the best - adobe software on my computer so reading the pdf is not the isssue.

This is after setting shipped in configuration as the default invoice , then changing it to shipped, then saving and receiving an email. I then click on Invoice. and the image you see comes up.  Again. the emails are perfect- with the invoice attached.

* I just think at the end of the financial period people are going to print their invoices - from this part of the computer and the first might be ok - the second ?

path:  or the one that does not open

 http://www.mmmmmmmm.com.au/index.php?option=com_virtuemart&view=invoice&layout=invoice&format=pdf&tmpl=component&virtuemart_order_id=176&order_number=8989034&order_pass=p_37a9c

[attachment cleanup by admin]

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10124
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: 2.0.7 G PDF in the invoice orders not working - Backend
« Reply #3 on: June 21, 2012, 00:57:48 am »
Can you open the pdfs which are attached to the email? Or is it just a problem with the pdfs created in the BE?

For me it looks like an error due not tcpdf compatible images, use jpg.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

alatak

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2048
    • alatak.net
Re: 2.0.7 G PDF in the invoice orders not working - Backend
« Reply #4 on: June 21, 2012, 08:31:21 am »
Hell John2400,

The invoices are stored under your safe path.
Can you upload one of them, and check if you can open it directly with a PDF reader?

For me also it looks like a PDF creation problem.

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: 2.0.7 H PDF in the invoice orders not working - Backend
« Reply #5 on: June 21, 2012, 13:40:42 pm »
The invoices are OK - in the emails .
-------------------------------------------------------------------------------------------------------------------
All in the back end.

* I went to my orders - and then decided to delete the test ones - under G I cannot delete the old ones -. I remember this in some previous version.

Some of the new ones I could delete - (new dates)

* Then thought that if the orders were deleted then the PDF files would be deleted and I could test a new one.

At the moment it just looks too untidy It is a little beyond me -

Alatak - The pdfs in the safe folder do open with a pdf reader

-----------------------------------------------------------------------------------------------------------------------
In the backend If I click on an invoice I get nothing _ a if I click on print In orders i get this

createInvoiceNumber $orderDetails has no virtuemart_order_id


John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: 2.0.7 G PDF in the invoice orders not working - Backend
« Reply #6 on: June 21, 2012, 23:58:13 pm »
Update:

If I try to delete my invoices:

I get vmError:
vmError: VirtueMartModelOrders::remove 163
Order could not be deleted.

This is on only some of them- about 20 in total.

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: 2.0.7 H PDF in the invoice orders not working - Backend
« Reply #7 on: June 25, 2012, 08:21:12 am »

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: 2.0.7 H PDF in the invoice orders not working - Backend
« Reply #8 on: June 26, 2012, 13:12:07 pm »
Hi ,

Just so you can see what invoices are not deleting in the back end -  Please note that they have no name related to the product .

How did this occur - When I went to create a new user in Joomla the software in G version created a user with two emails addresses .

In the shoppers additional information it automatically put the vendors email and in the general users information email it put the one I created. When I ordered a product the invoice then created an invoice with with blank information -

I have no idea how or why this happened but now I have these invoices that just sit in the system -- If some one could tell me where I could delete  these or how.

Can I go Into Mysql and delete them from there ?  you will have to tell me the exact table ?  If not just tell me to wait for an update and see If they can delete from there.

yes I am using H version Now.

[attachment cleanup by admin]

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: 2.0.7 H PDF in the invoice orders not working - Backend
« Reply #9 on: June 26, 2012, 23:03:13 pm »
Version 'I"

I tested and set quite a few emails - The invoice when shipped - sends a PDF and  yes - and I can open that PDF from the "safe file" and from the emails to the customer and seller/vendor.   But the initial issue below is the same - I cannot open the PDF files (invoices) from the back end of the VM system. A blank page shows.

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
This is not the invoice sent to customers. ( Has nothing to do with the emails)

the PDF creation in the orders area in the backend.

* The print option works well but the PDF file will not display.

* infact it does work on an odd invoice now and again - but for all types of browsers it just shows a blank page.  The page hangs for a good 5 minutes.

And I am confirming I have tried all the settings in the configuration - checkout area and then set all products to my confirmed setting and saved them. (emails arrive with a PDF invoice but the invoice in orders does nothing) - can someone test or confirm>

I have updated to 2.5.6 joomla  but this was not working for a few days and I was waiting to see if others posted something similar. ( so 2.5.4 it did not work as well)

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: 2.0.7 I PDF in the invoice orders not working - Backend
« Reply #10 on: June 27, 2012, 13:01:37 pm »
Hi I tried to find the Data base to delete just one order - number 163/
Turned on the bug report and then clicked delete.

vmdebug self::$_jpConfig->lang en_gb
vmdebug vmTime: loadConfig db no: 0.00369501113892
vmError message empty
#0  vmTrace(vmError message empty) called at [/home/xxxxxxx/public_html/administrator/components/com_virtuemart/helpers/config.php:125]
#1  vmError() called at [/home/xxxxxx/public_html/administrator/components/com_virtuemart/tables/orders.php:153]
#2  TableOrders->delete(163) called at [/home/xxxxxx/public_html/administrator/components/com_virtuemart/models/orders.php:1284]
#3  VirtueMartModelOrders->remove(Array ([0] => 163)) called at [/home/xxxxx/public_html/administrator/components/com_virtuemart/helpers/vmcontroller.php:204]
#4  VmController->remove() called at [/home/xxxxxx/public_html/libraries/joomla/application/component/controller.php:760]
#5  JController->execute(remove) called at [/home/xxxxx/public_html/administrator/components/com_virtuemart/admin.virtuemart.php:81]
#6  require_once(/home/xxxxxxa/public_html/administrator/components/com_virtuemart/admin.virtuemart.php) called at [/home/xxxxxx/public_html/libraries/joomla/application/component/helper.php:383]
#7  JComponentHelper::executeComponent(/home/xxxxxxx/public_html/administrator/components/com_virtuemart/admin.virtuemart.php) called at [/home/xxxxxx/public_html/libraries/joomla/application/component/helper.php:351]
#8  JComponentHelper::renderComponent(com_virtuemart) called at [/home/xxxxxxx/public_html/administrator/includes/application.php:153]
#9  JAdministrator->dispatch() called at [/home/xxxxxx/public_html/administrator/index.php:46]
vmdebug self::$_jpConfig->lang en_gb
vmdebug vmTime: loadConfig db no: 0.00385689735413


I tried this _this is the print out from the Invoice (print symbol) Message
vmdebug self::$_jpConfig->lang en_gb
vmdebug vmTime: loadConfig db no: 0. 00400996208191
vmdebug Start used Ram 12.25M
vmdebug createInvoiceNumber $orderDetails has no virtuemart_order_id Var1:
Array
(
)

vmdebug vmTime: VirtuemartControllerInvoice Finished task : 0.263660907745
vmdebug End used Ram 30.25M
vmdebug Peak memory peak 30.25M
Warning
createInvoiceNumber $orderDetails has no virtuemart_order_id

I now have deleted from the MYSQL - table all entries from 1) virtuemart_orders, 2) the invoices, 3) the histories 4) and order items (now)

This did not work and I can still see these entries in The Orders - invoices in the backend.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10124
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: 2.0.7 I PDF in the invoice orders not working - Backend
« Reply #11 on: June 27, 2012, 22:28:45 pm »
order_items also belong to it
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

jack19

  • Jr. Member
  • **
  • Posts: 70
    • Personal Site
Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
« Reply #12 on: July 25, 2012, 19:10:12 pm »
Hi,
I think I have a similar problem. I am using Joomla 2.5.6 - VM 2.0.8e.
The PDF file is incorrect, the one sent by email is blank, there is only the header.
The PDF files generated by back-end contains only one line and up the order number.
Only the print file to back-end is quite good, the only problem is that the logo is printed under the name of the shop and it appears small, (as if it came from the thumbnail).
I attach some screenshots to make better

[attachment cleanup by admin]
Best regards

Joomla! 2.5.9
Virtuemart 2.0.18a

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
« Reply #13 on: July 25, 2012, 23:24:09 pm »
Hi Jack,

Interesting as you can see I have posted earlier in regards to this issue. The team spent a great deal of time in 2.0.8 c,d,e fixing this issue.  My site no longer has this problem and I only updated the software - no hacks in the code.

Can you try and reinstalling 2.0.8 e version again over the top. I write just to say it was for me fixed.

jack19

  • Jr. Member
  • **
  • Posts: 70
    • Personal Site
Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
« Reply #14 on: July 26, 2012, 09:31:03 am »
Hi Jack,

Interesting as you can see I have posted earlier in regards to this issue. The team spent a great deal of time in 2.0.8 c,d,e fixing this issue.  My site no longer has this problem and I only updated the software - no hacks in the code.

Can you try and reinstalling 2.0.8 e version again over the top. I write just to say it was for me fixed.
Hi John
Do you mean uninstall and reinstall the same version?
I used the version 2.0.8E.
For your information I am doing the test in localhost.
Best regards

Joomla! 2.5.9
Virtuemart 2.0.18a