Author Topic: Comment display star bug  (Read 3386 times)

CheezyPuffs

  • Beginner
  • *
  • Posts: 8
Comment display star bug
« on: June 17, 2012, 21:10:41 pm »
Using version 2.0.6 when a user makes a comment on a product the display stars are always wrong. For example when I choose 5 star rating it will always show up in the review with only 2 stars when it should show 5 stars. I am using default settings and have auto review published.

I have found that it will only display the correct number of stars if I go in through the backend in virtuemart and actually open up the individual review and click save. For some reason that's the only way I can get it to display the correct number of stars.

Has anyone else tested the comments and if so does it work for you?

Pic:



CheezyPuffs

  • Beginner
  • *
  • Posts: 8
Re: Comment display star bug
« Reply #1 on: June 18, 2012, 03:22:32 am »
Just uploaded version 2.0.7f to see if it fixed the display star error and its worse now. After you submit a comment it use to say "Thanks for posting a review" or something but now when you post a comment the comment box doesn't go away. The comment shows up but the box to type in the comment still shows up which it use to disappear since you shouldn't be able to post on the same product twice.

Also before you could go into virtuemart backend and open the review and hit apply to make it show the correct number of stars, but now when you do that it doesn't work.

It seems like the comment section has been forgotten about and hasn't been updated with new versions. It still is showing only 2 stars like the picture I posted even when you give it a 4 or 5 etc.

So if you can please test this on your own sites to see if I'm not the only one getting this bug.

Thanks  :D

CheezyPuffs

  • Beginner
  • *
  • Posts: 8
Re: Comment display star bug
« Reply #2 on: June 18, 2012, 20:32:19 pm »
Can anyone help me out, I'm trying to see if this is template side or virtuemart bug.


John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: Comment display star bug
« Reply #3 on: June 19, 2012, 00:07:21 am »
CheezyPuffs,

Hi I can repeat your problem -- yes I think this is a bug.

I added 5 stars and a comment - auto publish and get 2 and sometimes 3 1/2 stars

I never use the reviews but I tested it and it even publish "0" stars at one stage.

CheezyPuffs

  • Beginner
  • *
  • Posts: 8
Re: Comment display star bug
« Reply #4 on: June 19, 2012, 02:25:07 am »
CheezyPuffs,

Hi I can repeat your problem -- yes I think this is a bug.

I added 5 stars and a comment - auto publish and get 2 and sometimes 3 1/2 stars

I never use the reviews but I tested it and it even publish "0" stars at one stage.

I figured it was a bug as it worked fine on previous versions.

So is there anyway to get it to work? For me comment section is pretty important and wrong display stars makes it useless as it gives a false rating to the customers.

Also for some reason in the comment box it's default to start 6 characters in (all spaces) and you have to backspace it to get it back to start at zero.

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: Comment display star bug
« Reply #5 on: June 19, 2012, 02:31:53 am »
CheezyPuffs

You have posted this is the right section ;

The developers will read this - they may not comment but they will see it.

* This may not be fixed asap but in later updates I'm sure this will be looked at.

* unfortunatly if you are using a live site - you may have to wait for this - and turn it off.

CheezyPuffs

  • Beginner
  • *
  • Posts: 8
Re: Comment display star bug
« Reply #6 on: June 19, 2012, 18:36:26 pm »
CheezyPuffs

You have posted this is the right section ;

The developers will read this - they may not comment but they will see it.

* This may not be fixed asap but in later updates I'm sure this will be looked at.

* unfortunatly if you are using a live site - you may have to wait for this - and turn it off.

Thanks for the reply  ;)

But yea just developing my site right now and testing everything out to make sure everything works before I really start adding products. 2.0.6 seems like it finally fixed most bugs but the comment section.

I figure this shouldn't be that hard of a fix? I'm just in the trial phase of virtuemart I guess and deciding if this is what I want to use when me site goes live, so this is a very important feature to me. I don't want to start adding hundreds of products if I can't get a fully working shop if you know what I mean.

CheezyPuffs

  • Beginner
  • *
  • Posts: 8
Re: Comment display star bug
« Reply #7 on: July 05, 2012, 00:18:02 am »
Bump....still messed up in 2.0.8, is there any solution to this?

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10018
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Comment display star bug
« Reply #8 on: July 05, 2012, 08:50:38 am »
You gave a vote of 5 stars and you see 3 in the rating? Means maybe that you voted 1 and 5 => 2,5 rating.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Re: Comment display star bug
« Reply #9 on: July 05, 2012, 09:07:51 am »
The Average rating : stars add up _ 2+5 = 6   therefore 6 stars divided by two voters -  mmm I'll test that out too.

yes that is it - the average -    it does work that way --   

* one small issue in regards to the stars - when you rollover the stars to pick them - a small fraction appears - it always says 5/5  - personally - I would just get rid of the 5/5  people know how many stars they have chosen by looking at the image. 

works for me -

CheezyPuffs

  • Beginner
  • *
  • Posts: 8
Re: Comment display star bug
« Reply #10 on: July 06, 2012, 03:27:39 am »
Sorry just got the time to post again...

This is still a test site so I'm the only one reviewing the products and it happens on the first review you make so it's not an average rating thats messing it up.

The weird thing is above the product it says 5/5 rating but the actual stars in the review only show two stars (like the picture I posted).

It appears to be a bug?

shaunyness

  • Beginner
  • *
  • Posts: 8
Re: Comment display star bug
« Reply #11 on: September 04, 2012, 12:29:20 pm »
Sorry just got the time to post again...

This is still a test site so I'm the only one reviewing the products and it happens on the first review you make so it's not an average rating thats messing it up.

The weird thing is above the product it says 5/5 rating but the actual stars in the review only show two stars (like the picture I posted).

It appears to be a bug?

Any update on this/
@shaunyness

butchtones

  • Beginner
  • *
  • Posts: 27
Re: Comment display star bug
« Reply #12 on: March 04, 2014, 21:53:55 pm »
Did any of the original posters get this resolved?  I posted a new thread with the same issue as I never found a thread with a solution.