Author Topic: 2.0.7 F Prices not showing to shopper group - "logged in default" group  (Read 4161 times)

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Prices not showing to the default shopper who is logged in -

* this affects everything in relation to the default shopper ( I have no groups against any product) or on my store settings-
* setting a product to a default shopper group does not result in the price showing up.

In E and before this worked perfectly

* when I logged in using my test person who is a shopper group "default" - which is automatically chosen by the software. They are a shopper and registered.

* I can no longer see any prices of goods - but they do add to the"mini cart" there are no product prices in the large cart.

* the public - non registered person has no problems and can see the cart. and buy.

*

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10273
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
I think this is just a misconfiguration, because  it isnt changed since some weeks.

The pricedisplay is set global, per shoppergroup and per currency. So there are various settings, which can be easily configured wrong.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
mmm,

My test person was set up for weeks and I never changed their settings.

* I was testing tax per state for someone and I deleted the "default" fora moment and then replaced the 'defaut' setting after I had tested the state per tax.

I updated to 2.0.7 F and the large cart would not show prices ? the mini cart does.


* They have returned after I unticked the box below in the group settings - below.



[attachment cleanup by admin]

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10273
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
of course, all overwrites are set to "do not display price". Now you disabled the overwrites and now your global config is taken.

For me it looks like everything is working as expected.

But the checkbox "show prices" is misleading. Better would be "disable all price displayes", becaus this is what it really does.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.6+
Ok,

I have disabled the "Show Prices" and the shop works .

* For me the word "Default" is misleading -  I think this word is the standard setting for a new user. They are automatically given this group when registered in the shop.

* So for a first time user of the VM shop I would then look everywhere to ensure that everything is set to "default" -  I would go into the shop ( products), I would set the taxes the same and try my best to make every thing "default" - 

* For long term users - we know that you do not have to do this _ but it is very unclear -

*To fix this my suggestion is the:  word that needs changing is the VM users - "default" wording in the users section - It needs to be a word like "user" or "registered" .

* Elsewhere there needs to be in the back end - in products and in the taxes, etc a small written script that says

 " you do not need to set shopper groups for the shop to run"  I would put this wording in the shopper group section.  You have a lot of room at the top of the shopper group section.   maybe the first line says that- but the rest is a clear explanation of groups is needed.