Author Topic: Stop PDF invoices being sent  (Read 9021 times)

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.0.12
Re: Stop PDF invoices being sent
« Reply #15 on: July 05, 2012, 12:48:30 pm »

* now the extra bit did you - do what I did below and turn the configurtion to none. then save . then turn it back say to shipping and save and then reset to another configuartion and test.  -  did they emails come but the PDFs stop. ???  this is important .

did some one test this - reset your configurations - to something else and save - test buy a product - reset them back save and buy a product?

bpluijms

  • Beginner
  • *
  • Posts: 28
Re: Stop PDF invoices being sent
« Reply #16 on: July 05, 2012, 12:52:38 pm »
Hello John,

I have tried this a couple of times, but it still doesn't work.
VM 2.0.8c is installed correctly, I have switch the status for PDF invoice attachment a couple of times but it is attached at every mail.
Could this be a caching problem?

UPDATE: I have tried to delete all cache, changed the status a couple of times and saved it everytime, but there is still a problem with the PDF invoices that are attached to EVERY e-mail.

And indeed, the Vendor message inside the e-mail is always the same (confirmed), but I hope to get an option to turn off vendor e-mails.

slammy

  • Jr. Member
  • **
  • Posts: 169
  • vm supporter member
  • VirtueMart Version: vm 3.0.x and jml 3.4.5
Re: Stop PDF invoices being sent
« Reply #17 on: August 05, 2012, 12:04:44 pm »
Hello,

I think John2400 posted already the solution for this (Thanks John!), but it took me some minutes to get it.

I am on a testenvironment with vm sr 2.0.8_e and jml 2.5.6 and I didn´t use pdf-invoices in the past, we put a hardcopy with when we ship the goods.
Last week I was just interessted in the pdf-invoice and changed the configuration under vm backend -> configuration -> attach pdf invoices  from "none" to "confirmation". I did some testorders last week, and those I did, have a pdf-invoice attachement in every mail when I change the status, even when I change the configuration back to "none"and make a orderstatus change.

BUT:!!!

I just did a new order (with configuration setting none) and pdf-invoices are gone.

Maybe vm saves the actual pdf-configuration-mode (this time the order is placed) and attaches this information to the order, this would explain why old orders with this configuration mode still further send pdf-invoices and new orders with configuration mode "none" don´t.

Can someone confirm?


Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9789
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Stop PDF invoices being sent
« Reply #18 on: August 05, 2012, 13:32:34 pm »
There was an error,

fixed in the svn.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

slammy

  • Jr. Member
  • **
  • Posts: 169
  • vm supporter member
  • VirtueMart Version: vm 3.0.x and jml 3.4.5
Re: Stop PDF invoices being sent
« Reply #19 on: August 05, 2012, 17:04:38 pm »
Hello again,

I have to correct my last post. The workaround worked fine until I enabled PayPal payment method. Now I have ongoing invoice attachements again. If I do the workaround again, with disabling paypal payment  method and "none" in backend configuration and a new order it works again without attachements.
 
Milbo, can u post a file ?Which file(s) are fixed in svn, view.html.php from views/invoice?
thank u for ur time.
regards slammy