Author Topic: Problem with "Show Children Category" 2.0.7 (Cant see Category images / links)  (Read 11700 times)

lipes

  • Full Member
  • ***
  • Posts: 720
I got a problem with "Show Children Category" .. i got it checked in the Configuration > Templates ....
(administrator/index.php?option=com_virtuemart&view=config)
 
In the beggining it was everything working fine (i saw the images of the specific Category with correct linking...)
But now i dont know whats happening .. i got it checked and the Category images were gone away....

Breadcrub is also displaying no images of the category's with the link ( index.php?option=com_virtuemart&view=category&virtuemart_category_id=1 ) that i've got when go back from Product Details....
and must be ( index.php?option=com_virtuemart&view=categories&virtuemart_category_id=1 ) to work... how can i change this?
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10412
  • VirtueMart Version: 3+
I got a problem with "Show Children Category" .. i got it checked in the Configuration > Templates ....
(administrator/index.php?option=com_virtuemart&view=config)
 
In the beggining it was everything working fine (i saw the images of the specific Category with correct linking...)
But now i dont know whats happening .. i got it checked and the Category images were gone away....

Breadcrub is also displaying no images of the category's with the link ( index.php?option=com_virtuemart&view=category&virtuemart_category_id=1 ) that i've got when go back from Product Details....
and must be ( index.php?option=com_virtuemart&view=categories&virtuemart_category_id=1 ) to work... how can i change this?

breadcrumbs dont have images

and 'child categories" are "subcategories"

Do you see top level categories when you go to the frontpage?
J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

lipes

  • Full Member
  • ***
  • Posts: 720
maybe i am not well explained..
i know that breadcrumbs dont have "images" lol give us a url map of the article or product... like.. "website map"

I dont have top level in 1st page... i got the Module VM Products published with 10 products in random...
If i click in some product i go to an url like this one:
http://127.0.0.1/teste2/index.php?option=com_virtuemart&view=productdetails&virtuemart_product_id=21&virtuemart_category_id=96

if i click to go back in breadcrumbs to top level Category:
http://127.0.0.1/teste2/index.php?option=com_virtuemart&view=category&virtuemart_category_id=82
it give me the space that must be with images of the categories a empty space...

To the 2nd (and last level) of the Category where all Products of this "example" are displayed works fine:
http://127.0.0.1/teste2/index.php?option=com_virtuemart&view=category&virtuemart_category_id=96
but the first level it isnt working ...
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10412
  • VirtueMart Version: 3+
lipes, if you noticed the category ID changed in the 2 urls, thats the problem
J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

lipes

  • Full Member
  • ***
  • Posts: 720
virtuemart_category_id=82 -> its the 1st level category
virtuemart_category_id=96 -> its an second level category

i got one "0 level" category that display's all the 1st level category images:
http://127.0.0.1/teste2/index.php?option=com_virtuemart  (whit this link is working normal it displays all the 1st level category images)

i dont know how to explain this well from my language to english...
what i really know is that this page doesnt work (going back from the product details page):
http://127.0.0.1/teste2/index.php?option=com_virtuemart&view=category&virtuemart_category_id=82
But if i change the url this is working (i can see all the categories images with the links):
http://127.0.0.1/teste2/index.php?option=com_virtuemart&view=categories&virtuemart_category_id=82

From breadcrumbs link:
Home › 1st Level › 2nd Level › Product Name
Home: it's working normal; 1st Level: not working; 2nd Level: it's working normal; 3rd Level: the Product Details layout it's working normal....
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

lipes

  • Full Member
  • ***
  • Posts: 720
please tell me that i dont need to install vm2 again to get this function back again...  :/

Doesnt Show/Display the <div class="category-view"> and also the content inside this div...
(All the Categories with images/text/links...)  this is empty...

I only can see:
Code: [Select]
<div class="browse-view">
     
</div>
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10412
  • VirtueMart Version: 3+
lipes, its very hard to understand what you mean, and without a url to look at.

ARE: you sure you did not edit anything that conflicted with it?>


have you disabled all template overrides?
J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

lipes

  • Full Member
  • ***
  • Posts: 720
I've changed the template override folder name to 'com_virtuemartZZZ' that disables all the overrides..
and it does the same thing by clicking to go back (1st level) in the joomla breadcrumb.

Yes, i am pretty 100% sure that i didnt do nothing to change any setup.
I was inserting some products with CSVi (was the 1st time that i instaled this component).
But i remember that i've got the same problem some weeks ago i've posted the same questions in this forum about the problems in the Category image and url ... and the solution was solved by instaling again the VM2 with the Sample Data...
Now it happened again.
http://webcache.googleusercontent.com/search?q=cache:O8ThBL3lg6MJ:forum.virtuemart.net/index.php%3Ftopic%3D102797.0


Maybe some users do not notice/have this problem.. because they dont have the breadcrumb enable to test it.

Quote
lipes, its very hard to understand what you mean, and without a url to look at.
i will ask my old brother to put this test website in his account to test.. just a moment please (PM)
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10070
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Set it online lipes. I am sorry, I also do not understand, what you mean.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10412
  • VirtueMart Version: 3+
Set it online lipes. I am sorry, I also do not understand, what you mean.

MIlbo, I have checked his site, and the problem is.

When you navigate through the menu.

The view is

categories

and you can see the subcategories.
The category has NO products in it.


BUT: If you get to a product thats in one of the "subcategories"
The breadcrumbs link view will be

category

and the subcategories will not display.


This happens when you get to one of the products via the product module
J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10070
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Imho there are no products in the first level. Only products in the second level. I think he is not displaying the children categories, we added an option for this, or not? Lets take a look.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

lipes

  • Full Member
  • ***
  • Posts: 720
'Show Children Category' option isnt working... 'Checked' or 'unchecked' it's the same in the layout (dont do nothing).

I've got 1 Level with 10 Categories main names (it's like the shop category names index, but with 0 product inside.. i dont know if this is the "Zero Level" or the "1st Level" maybe it's the parent ?)

Then we could select 1 main Category of that 10.... and ..
We'll see another Level with many Categories names inside .. so maybe this are the childs categories (they have products inside) ..

if we select and click in any of that Category name (i think) we go to the "Category browse page" (where we could see the products displayed)...
Then we could Select/choose 1 Product and we go to the last level that it's the "Product Details" page ...

PS:
From the joomla menu works normal :
- (index.php?option=com_virtuemart&view=categories&virtuemart_category_id=82&Itemid=732)

The start point to have this problem is from the VM Products Module (random) that it's in the index template. We must select one product and we go to the Product Details page...
Then if we want to go back by the joomla breadcrumbs (or any other module) doesnt work well:
- (index.php?option=com_virtuemart&view=category&virtuemart_category_id=82)
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

lipes

  • Full Member
  • ***
  • Posts: 720
UPDATE: Not working yet in 2.0.7 F
:-/
cant see yet the categories images
VM V. online: J2.5.14 | VM 2.0.20a | SQL 5.1.70 | PHP 5.3.25

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10412
  • VirtueMart Version: 3+
lipes,

you are explaining this wrong.

Its "dont show child categories"

J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10070
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Lippes the views "categories" and "category" are not the same thing.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/